Encapsulation dot1q: Недопустимое название — Xgu.ru

Содержание

5.4 VLAN: связь между VLAN

Каталог статей

Маршрутизация одной рукой предназначена для экономии оборудования и физических портов. Она редко используется в производственной среде. Принцип и конфигурация также очень просты. Топология и конфигурация следующие. Общая конфигурация vlan VPC4 — 10, IP-адрес 192.168.10.10/24, шлюз 192.168.10.1; vlan VPC5 — 20, IP-адрес 192.168.20.20, шлюз 192.168.20.1, порт устройства Cisco начинается с ether0, Huawei — gi0 / 0 начало.
  Совет: убедитесь, что все VLAN являются активными VLAN.

1.1 Cisco

1. Настроить vlan коммутатора.
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#ex

 2. Настройте vlan-интерфейс коммутатора.
Switch(config)#int ether0/0
Switch(config-if)#switchport trunk encapsulation dot1q 
Switch(config-if)#switchport mode trunk 
 Switch (config-if) # no shutdown ----------- Это очень важно
Switch(config-if)#int ether0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport  access vlan 10
Switch(config-if)#no shutdown  
Switch(config-if)#int ether0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport  access vlan 20
Switch(config-if)#no shutdown  

 3. Настройте интерфейс роутера.
Router(config)#int ether0/0
 Маршрутизатор (config-if) # no shutdown ----- Порты устройств Cisco закрыты по умолчанию, не забудьте открыть
Router(config-if)#int ether0/0.10
 Маршрутизатор (config-subif) #encapsulation dot1Q 10 ------- Не несоответствие. Этот vlanID должен быть одним из списков vlan, которые необходимо передать.
Router(config-subif)#ip add 192.168.10.1 255.255.255.0
Router(config-subif)#int ether0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip add 192.168.10.1 255.255.255.0
Router(config-subif)#exit

 4. Тест
 Пинг-тест устройства, просто связь.

1.2 Huawei

1. Настроить коммутатор vlan
[Huawei]vlan batch 10 20

 2. Настройте порты коммутатора.
[Huawei]int gi 0/0/1
[Huawei-GigabitEthernet0/0/1]port link trunk
[Huawei-GigabitEthernet0/0/1]port trunk allow vlan 10  20
[Huawei-GigabitEthernet0/0/1]int gi 0/0/2
[Huawei-GigabitEthernet0/0/2]port link access
[Huawei-GigabitEthernet0/0/2]port default vlan 10
[Huawei-GigabitEthernet0/0/2]q
[Huawei-GigabitEthernet0/0/2]int gi 0/0/3
[Huawei-GigabitEthernet0/0/3]port link access
[Huawei-GigabitEthernet0/0/3]port default vlan 20
[Huawei-GigabitEthernet0/0/3]q

 3. Настроить роутер.
[Huawei]int gi0/0/1.10
[Huawei-GigabitEthernet0/0/1.10]dot1q termination vid 10
[Huawei-GigabitEthernet0/0/1.10]ip add 192.168.10.1 24
[Huawei-GigabitEthernet0/0/1.10]arp broadcast enable 
[Huawei-GigabitEthernet0/0/1.10]q
[Huawei]int gi 0/0/1.20
[Huawei-GigabitEthernet0/0/1.20]dot1q termination vid 20
[Huawei-GigabitEthernet0/0/1.20]ip add 192.168.20.1 24
[Huawei-GigabitEthernet0/0/1.20]arp broadcast enable 
[Huawei-GigabitEthernet0/0/1.20]q

 4. Тест
 Пинг-тест устройства, просто связь.

Большинство из них теперь используют коммутаторы уровня 3 для поддержки функций маршрутизации, поэтому чаще используется vsi или vlanif напрямую. Схема топологии, используемая для конфигурации, показана ниже. Общая конфигурация VPC4 имеет vlan 10, IP-адрес 192.168.10.10/24 и шлюз 192.168.10.1; VPC5 имеет vlan 20, IP-адрес 192.168.20.20, шлюз 192.168.20.1 и порт устройства Cisco. Он начинается с ether0, а Huawei — с gi0 / 0.

  Совет: убедитесь, что все VLAN являются активными VLAN.

2.1 Cisco

1. Включите функцию маршрутизации.
 Switch (config) #ip routing --------- Дело в том, что коммутаторы Cisco уровня 3 не включают маршрутизацию по умолчанию

 2. Настроить vlan
Switch(config)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config-vlan)#ex

 3. Настройте физический интерфейс.
Switch(config-if)#int ether0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport  access vlan 10
Switch(config-if)#no shutdown  
Switch(config-if)#int ether0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport  access vlan 20
Switch(config-if)#no shutdown 

 4. Настроить интерфейс vsi
Switch(config-if)#int vlan 10
Switch(config-if)#ip add 192.168.10.1 255.255.255.0
 Переключатель (config-if) # no shut -------- Клавиша: должен быть включен
Switch(config-if)#int vlan 20
Switch(config-if)#ip add 192.168.20.1 255.255.255.0
Switch(config-if)#no shut

 5. Тест
 Устройство можно пинговать.

2.2 Huawei

1. Настроить коммутатор vlan
[Huawei]vlan batch 10 20

 2. Настройте порты коммутатора.
[Huawei]int gi 0/0/2
[Huawei-GigabitEthernet0/0/2]port link access
[Huawei-GigabitEthernet0/0/2]port default vlan 10
[Huawei-GigabitEthernet0/0/2]q
[Huawei-GigabitEthernet0/0/2]int gi 0/0/3
[Huawei-GigabitEthernet0/0/3]port link access
[Huawei-GigabitEthernet0/0/3]port default vlan 20
[Huawei-GigabitEthernet0/0/3]q

 3. Настроить интерфейс vlanif
[Huawei]int vlanif 10
[Huawei-Vlanif10]ip add 192.168.10.1 24
[Huawei-Vlanif10]int vlanif 20
[Huawei-Vlanif20]ip add 192.168.20.1 24
[Huawei-Vlanif20]q

 4. Тест
 Устройство можно пинговать.

Super vlan у Huawei, h4C и ZTE есть все, но Cisco не нашла подобной концепции. Предыдущая однонаправленная маршрутизация, vsi / vlanif, представляет собой vlan, соответствующий IP-подсети, и иногда это кажется потерей IP-адресов. Таким образом, super vlan разработан для обеспечения трехуровневой связи и двухуровневой изоляции vlan, а также для экономии ресурсов IP-адресов.
Топология, используемая super vlan, показана на рисунке ниже, и она также должна соответствовать следующим требованиям:
1. Устройство поддерживает функцию маршрутизации, которая представляет собой трехуровневый коммутатор.
2. Все подчиненные vlan в супервлане должны находиться в одной IP-подсети.
3. Основной vlan (super vlan) может устанавливать только виртуальный интерфейс vlanif, а IP-адрес используется в качестве шлюза; дополнительный vlan (sub vlan) должен быть настроен на физическом интерфейсе, а виртуальный интерфейс vlanif использовать нельзя.

1. Настроить vlan
[Huawei]vlan batch  2 3 10
[Huawei]vlan 10
 [Huawei-vlan10] aggregate-vlan --------- Настройте vlan 10 как super vlan
 [Huawei-vlan10] access-vlan 10 20 ------ Настройте 2 и 3 как sub vlan

 2. Настройте порты коммутатора.
[Huawei]int gi 0/0/2
[Huawei-GigabitEthernet0/0/2]port link access
[Huawei-GigabitEthernet0/0/2]port default vlan 2
[Huawei-GigabitEthernet0/0/2]q
[Huawei-GigabitEthernet0/0/2]int gi 0/0/3
[Huawei-GigabitEthernet0/0/3]port link access
[Huawei-GigabitEthernet0/0/3]port default vlan 3
[Huawei-GigabitEthernet0/0/3]q

 3. Настроить интерфейс vlanif
[Huawei]int vlanif 10
[Huawei-Vlanif10]ip add 192.168.10.1 24
 [Huawei-Vlanif10] arp-proxy inter-sub-vlan-proxy enable ------- ARP-прокси между VLAN должен быть включен.
 [Huawei-Vlanif10] dhcp select interface ----- Необязательная команда для настройки dhcp (при условии, что dhcp включен глобально)

 4. Тест
 IP-адрес ПК1 - 192.168.10.254, а IP-адрес ПК2 - 192.168.10.253, которые могут пинговать друг друга.

Метим кадры – разбираемся с 802.1p / 802.1Q / 802.1ad

Привет.

Коммутация – одна из самых нелюбимых тем у слушателей, готовящихся к CCIE Routing and Switching. Бывают люди, которые с ходу разбираются с динамической маршрутизацией (таких большинство), кто-то сразу вкуривает, как работает Frame Relay (их меньше), кто-то интересуется взаимодействием TokenRing и IPX (это некрофилы). Свичинг не любит практически никто – за его “мутность”.

В случае, например, динамической маршрутизации, весь траблшутинг и анализ ситуации достаточно понятен и осознаваем мозгом – можно посмотреть, от кого к кому пришли какие маршруты и достаточно быстро сделать выводы о типовых проблемах в конфигурировании. В случае с траблшутингом работ на канальном уровне дело обычно хуже – надо лезть в отладку и вычислять “кто на кого почему каким портом в каком статусе смотрит и не напутали ли ничего с виланами-stp-прочим”. В принципе, со временем уже становится проще, но на психически здорового человека, попавшего на курс SWITCH с детальным разбором работы протоколов семейства STP, производит специфическое впечатление. Усугубляется это наличием книжки от русской редакции Cisco Press с названием “Коммутация в локальных сетях”, в которой полторы тысячи страниц, примеры про CatOS года так от 2003-2004, жуткий язык изложения достаточно несложных тем и постоянный подтекст а-ля Братья Гримм “но это ещё фигня, дальше только страшнее будет” (у меня в своё время сложилось впечатление, что цель этой серии – нагон слушателей на курсы путём внедрения мысли вида “видите, как всё страшно, без курсов никак не справитесь”). Поэтому на коммутацию можно и нужно потратить время – именно детальное знание таких “очевидных” штук и отличает профессионала от “мы с ребятами вчера убунту поставили – вроде всё понятно, теперь мы специалисты по суперкомпьютерной ОС”.

Сегодняшний разговор – про метки кадров.

Как обычно, я предполагаю, что Вы знаете коммутацию на уровне CCNA.

Одиночный вариант: метим кадры 802.1Q

Достаточно часто возникает задача логического мультиплексирования нескольких потоков данных в пределах одной физической среды передачи. Для её [задачи] реализации в стандартах семейства 802.x даже есть специальный стандарт – 802.2. Но в самом распространённом протоколе канального уровня – 802.3 – вместо данной схемы формирования заголовка LLC-уровня используется Ethernet II (т.е. когда после SRC MAC сразу идёт 2 байта с кодом протокола (поле EtherType)).

Конечно, есть и другие варианты – например, любимый фирмой Novell “raw ethernet”, когда сразу после двухбайтового поля Length идёт заголовок IPX, но на данный момент это решение уже не используется.

Что же используется? В основном используется 802.1Q – достаточно простой стандарт, подразумевающий добавление в кадр дополнительного заголовка размером в 4 байта, и имеющего такой формат:

  • Поле TPID – Tag Protocol ID – два байта, идентифицирующие тип доп.заголовка – всегда
    0x8100
    .
  • Поле PCP – Priority Code Point – три бита, рождённые в муках комитетом 802.1p, которому вообще-то предписывали заниматься динамической фильтрацией мультикастового трафика, но, видимо, увидев КПД (три бита), расстреляли комитет в полном составе. Эти три бита также часто называются CoS – Class of Service.
  • Поле CFI – Canonical Format Indicator – 1-битовый флаг, показывающий формат MAC-адресов. В авторизованных курсах Cisco игриво называется “Признак Token Ring”, хотя говорит чуть о другом. Это поле всегда должно быть в нуле (т.е. показывать нормальность формата MAC’ов в кадре), а если оно в единице – это говорит о том, что MAC’и в кадре нетрадиционной ориентации и не могут дружить с обычными коммутаторами. По сути, найдя единицу в этом поле, коммутатор не должен отдавать указанный кадр в untagged-виде (т.е. например в транк с native-vlan’ом, совпадающим с указанным в заголовке), т.к. в этом случае не гарантируется корректная обработка кадра получателем.
  • Поле VID – Virtual LAN ID – 12 бит, содержащих наконец-то главное – номер VLAN’а.

Чуть уточнение в плане терминологии. Когда упоминается о “чистом 802.1p”, то обычно имеется в виду вариант 802.1Q, в котором VID = 0. Тогда значимым считается только поле PCP, и вся конструкция называется Priority Tag. В остальных случаях – 802.1Q. В случае явного указания “Заголовок 802.1Q/p” обычно подразумевается, что обрабатываются оба поля – и номер VLAN, и приоритет канального уровня. Поле CFI сейчас фактически не используется.

В стандартах семейства 802.11 местная реализация записи данных QoS канального уровня называется 802.11e и технически представляет из себя тот же заголовок 802.1Q.

Конечно, есть ещё вариант логического мультиплексирования с использованием ISL-инкапсуляции, но про него, если нужно, я напишу подробнее отдельно. Сейчас основное и стандартное решение всё ж 802.1Q.

Соответственно, вкратце про то, как объединить/разделить несколько потоков данных внутри одной Ethernet-сети (да и WiFi) мы разобрались, можно подытожить:

  • Можно сделать несколько независимых потоков данных, разделив их на канальном уровне
  • Для протоколов 802.x для этого существует SNAP-инкапсуляция
  • Кроме протокола 802.3, для него практикуется использование 802.1Q, который заодно умеет передавать данные о приоритете кадра через поле 802.1p
  • Ну и кроме 802.11, для которого есть 802.11e, который по сути тот же 802.1Q

Теперь удвоим ставки.

Технология 802.1ad – двойная метка

Как указывалось выше, у данной технологии есть и другие названия. QinQ, к примеру, или Stacked VLAN – всё это тоже имеет отношение к 802.1ad. Суть же достаточно проста. 12 бит для номера VLAN хватает только на 4 с небольшим тысячи отдельных сред передачи данных, а когда надо больше – то нужно придумывать что-то другое. Сценарии могут быть различны – провайдеру надо “пробросить” транк клиента, не затрагивая схему нумерации VLAN’ов, надо балансировать нагрузку между субинтерфейсами внутри сети провайдера, либо просто – маловато номеров. Самое простое – сделать ещё одну такую же метку (tag). В этом случае внешней (OuterTag) будет называться метка, которая ближе к заголовку кадра (т.е. которая сразу за SRC MAC), а внутренней (InnerTag) – следующая за ней. Также изменения будут и в названиях VID – VID во внешней метке будет называться SP-VLAN (Service Provider), во внутренней – CE-VLAN (Customer Edge).

  • Тэгом – InnerTag / OuterTag – называется весь доп.заголовок, который 802.1Q, все его 4 байта
  • OuterTag идёт первым (левее, если представить кадр как битовую строку), а InnerTag вторым (соответственно, правее)
  • Когда всё это используется для проброса клиентских транков через сеть провайдера, то поле VID внутри OuterTag называют SP-VLAN, а поле VID внутри InnerTag называют CE-VLAN
Самих меток коснутся изменения – если внутренняя сохранит свой вид, то у внешней будет использоваться другой EtherType – вместо 0x8100 там могут быть: Притом стандартным является 0x88a8, остальные же два распознаются только частью оборудования (например, старшими линейками роутеров Cisco – значение 0x9200 будет являться стандартным для организации туннелей Q-in-Q между роутерами семейства Cisco 10000). Дополнительным изменением является смена роли “бестолкового” бита CFI у OuterTag. Вместо CFI бит станет называться DEI – Drop Eligible Indicator, и по сути является дополнительным флагом для управления механимом CoS и работает аналогично подобному у Frame Relay. Над данной структурой определены 2 операции – push tag и pop tag. Операция push tag над обычным 802.1Q кадром добавляет новый OuterTag, операция pop tag над QinQ-кадром удаляет OuterTag и возвращает кадр в вид 802.1Q (соответственно, его 802.1Q является бывшим InnerTag’ом). Давайте перейдём к практической части – как это настраивается.

Базовые операции с настройкой 802.1Q на оборудовании Cisco

Начинаем настройку всегда с предположения, что ничего не настроено и не работает. Поэтому заходим на интерфейс и пробуем ввести команду host(config-if)# switchport В случае, если наш коммутатор умный и поддерживает L3, то эта команда в явном виде укажет, что порт должен работать в режиме порта коммутатора, а не routed. Если глупый – пошлёт, сказав, что такой команды нет. Это не страшно. Далее, мы с Вами должны зафиксировать тип транкинга – чтобы не тратилось время на автосогласование типа транка. Мы выберем 802.1Q. host(config-if)# switchport trunk encapsulation dot1q Если надо вернуть автосогласование типа транкинга, то: host(config-if)# switchport trunk encapsulation negotiate Опять же – если коммутатор просто не знает других типов транкинга, кроме 802.1Q, он не сможет выполнить эту команду. Что тоже, в общем-то, не страшно. Эту команду надо делать до переключения интерфейса в транк по той причине, что иначе переключение просто не произойдёт. Теперь фиксируем EtherType транка – помним, что он может не всегда быть 0x8100: host(config-if)# switchport dot1q ethertype тип И включаем в явном виде транк: host(config-if)# switchport mode trunk В общем-то интерфейс теперь работает в режиме транка, и если с другой стороны будет стоять динамическое согласование либо тоже транк – всё будет ОК. Если есть уверенность, что с той стороны тоже в явном виде будет транк, а не динамическое согласование, можно убрать обработку кадров протокола согласования транка (DTP). Это чуть уменьшит трафик (чисто символически, в общем), плюс приведёт к тому, что когда с другой стороны будет динамически настроенный порт, то всё закончится плохо – связь не будет установлена, т.к. наша сторона будет молчать, как пленный партизан, на все запросы. Выключить динамическое согласование транкинга можно так: host(config-if)# switchport nonegotiate Теперь настройка для роутеров. В случае PE-роутера, который будет принимать поток со Stacked VLAN, ему надо будет по внешней метке понять, на какой субинтерфейс отдать поток клиентского трафика. Поэтому на родительском интерфейсе (не на субинтерфейсе!) надо для начала указать используемый EtherType. Это необходимо, чтобы работать с не-Cisco оборудованием, которое использует EtherType = 0x9100 да и вообще – в явном виде указать не помешает. Убирайте разложенные грабли заранее. Команда host(config-if)# dot1q tunneling ethertype значение устанавливает на интерфейсе используемый EtherType, а команда host(config-if)# no dot1q tunneling ethertype возвращает тип к дефолтному 0x8100. После этого нам, скорее всего, захочется создать субинтерфейс, на котором надо будет принимать трафик с нужными SP-VLAN и CE-VLAN. Это делается командой: host(config-subif)# encapsulation dot1q SP-VLAN second-dot1q CE-VLAN Вместо CE-VLAN можно указать слово any, тогда на этот интерфейс будут приходить все “остальные” кадры, для которых не нашлось явно сконфигурированных субинтерфейсов. Также надо отметить, что SP-VLAN будет задаваться явным значением, а CE-VLAN может быть и диапазоном (вида 40-50,70,80).

Заключение

Тема решений класса Metro Ethernet и Carrier достаточно интересна, по крайней мере – надо хорошо представлять базовые вопросы, принципы и терминологию. Как всегда я пишу в этом месте статьи – в случае проявления интереса данный материал может быть (и будет) расширен и дополнен.

Дата последнего редактирования текста: 2013-10-05T07:08:21+08:00

Возможно, вам будет также интересно почитать эти статьи с нашей Knowledge Base

Cisco EVCs настройка bridge-domain, service instance и rewrite

На этот раз попробуем разобраться с интересной технологией виртуальных сетей — Ethernet Virtual Connections (EVCs). Рассмотрим на примерах создание service instance с правидами трансляции vlan с помощью механизма rewrite и привязку bridge-domain к L3 интерфейсам.

Итак, начнем с определений:

EVCs (Ethernet Virtual Connections) — технология виртуальных соединений, позволяющая организовать внутри физического коммутатора несколько широковещательных L2 доменов (виртуальных коммутаторов). Домен EVC состоит из bridge-domain и подключенными к нему EFP.

Bridge domain – это некая L2 логическая широковещательная область внутри устройства. Принцип работы такойже как и у коммутатора, а именно передача кадров в соответствии с mac таблицей. Для каждого номера bridge-domain будет свой экземпляр mac таблицы.

Ethernet Flow Point (EFP) — это логический интерфейс c набором правил определяющими критерии пересылки пакетов в bridge-domain. В конфигурации cisco под EFP понимается service instance с включеными в нее настройками например (encapsulation, rewrite, bridge-domain и т.п.). К одному bridge-domain можно подключить сразу несколько EFP на одном физическом интерфейсе.

Encapsulation – этот параметр в настройках Service instance задает критерий выбора пакетов. Например настройка encapsulation dot1q 20 говорит что будут обработаны только кадры с тегом равным 20 (VLAN 20).

Настройка EVCs — servise instanse, bridge-domain на cisco

Рассмотрим самый простой пример настройки интерфейса.

interface gigabitethernet0/1
 switchport mode trunk
 switchport trunk allowed vlan none
 service instance 5 Ethernet 
  encapsulation dot1q 20
  bridge-domain 20

Видно, что на физическом интерфейсе создается логический интерфейс так называемый service instance под номером 5, с encapsulation dot1q 20 и bridge-domain 20.

Все пакеты с тегом 20 будут попадать в bridge-domain 20.

В encapsulation dot1q можно указать несколько тегов. Например 10, c 14 по 16.

encapsulation dot1q 10,14-16

Если мы хотим принимать нетегированный траффик то в энкапсуляции задаем untagged.

encapsulation untagged

На одном физическом интерфейсе может быть создано несколько service instanse, причем bridge-domain могут совпадать или быть разными.

interface gigabitethernet0/1
 switchport mode trunk
 switchport trunk allowed vlan none
 service instance 5 Ethernet 
  encapsulation dot1q 20
  bridge-domain 20
 service instance 10 Ethernet 
  encapsulation dot1q 15
  bridge-domain 20
 service instance 18 Ethernet 
  encapsulation dot1q 30
  bridge-domain 35
 service instance 30 Ethernet 
  encapsulation untagged
  bridge-domain 40

Принцип работы rewrite ingress tag pop или трансляция vlan на cisco

Одна из ключевых особенностей технологии EVC это её повышенная гибкость, позволяющая с помощью механиза rewrite направлять кадры с разных vlan в нужный нам bridge-domain.

Рассмотрим пример использования rewrite.

service instance 5 Ethernet
 encapsulation dot1q 20
 rewrite ingress tag pop 1 symmetric
 bridge-domain 50 

В данном примере из всех входящих кадров с тегом 20 (encapsulation dot1q 20) будет удален внешний тег (rewrite ingress tag pop 1 symmetric), а во все исходящие кадры из bridge-domain будет тег (VLAN 20) добавлен.

Bridge Domain Routing или как связать L3 интерфейс с бридж доменом

Продолжим разговор о гибкости технологии EVC. Вот Вам пример: Клиент отдает нам маркированный траффик в VLAN 20. Нам его нужно принять на L3 интерфейсе, но VLAN 20 и соответственно interface vlan 20 у нас уже заняты, например под управление.

Решение данной задачи используя технологию EVC.

interface gigabitethernet0/1
 switchport mode trunk
 switchport trunk allowed vlan none
 service instance 1 Ethernet
  encapsulation dot1q 20
  rewrite ingress tag pop 1 symmetric
  bridge-domain 300

interface vlan 300
 ip address 192.168.1.1 255.255.255.0

Маркированный траффик (VLAN 20) попадает на порт gigabitethernet0/1 service instance 1, далее снимается метка (rewrite ingress tag pop 1 symmetric) перекидывается в bridge-domainc с номером 300, ну и далее траффик попадает на L3 интерфейс.

Интересный момент который следует понимать — привязка interface vlan к bridge-domain осуществляется по номеру bridge-domain (в нашем случае это 300).

А вот еще один пример только теперь мы принимаем траффик с двумя тегами от клиента.

interface gigabitethernet0/1
 switchport mode trunk
 switchport trunk allowed vlan none
 service instance 1 Ethernet
  encapsulation dot1q 50 second-dot1q 60
  rewrite ingress tag pop 2 symmetric
  bridge-domain 400

interface vlan 400
 ip address 192.168.1.1 255.255.255.0

Команды мониторинга и диагностики при работе с bridge-domain и service instance

1.Просмотр информации по bridge-domain. Выводит принадлежность bridge-domain к физическому интерфейсу и сервис инстансу.

R1#show bridge-domain 400
Bridge-domain 400 (1 ports in all)
State: UP                    Mac learning: Enabled
Maximum address limit: 10000
    GigabitEthernet0/15 service instance 400

2.Просмотр mac таблицы в бридже домене.

R1#show mac-address-table bridge-domain 25
          Mac Address Table
-------------------------------------------
BD      Mac Address       Type        Ports
----    -----------       --------    -----
...          ...            ...         ....
25      xxxx.xxxx.xxxx    DYNAMIC     Te0/1+Efp34
25      xxxx.xxxx.xxxx    DYNAMIC     Te0/1+Efp34
25      xxxx.xxxx.xxxx    DYNAMIC     Te0/1+Efp34
Total Mac Addresses for this criterion: 27 400 

3.Просмотр всех созданных service instance.

R1#show ethernet service instance 
Identifier  Type      Interface                State     CE-Vlans
3           Static    GigabitEthernet0/1       Up                                            
11          Static    GigabitEthernet0/1       Up                                            
30          Static    GigabitEthernet0/2       Up                                            
60          Static    GigabitEthernet0/5       Up                                            
1           Static    GigabitEthernet0/10      Up                                            
17          Static    GigabitEthernet0/10      Up                                            

Просмотр детальной информации по Ethernet Flow Point.

R1#show ethernet service instance id 23 interface gigabitEthernet 0/14 detail 
Service Instance ID: 23
Service Instance Type: Static
Description: VoIP
Associated Interface: GigabitEthernet0/14
Associated EVC: 
L2protocol drop
CE-Vlans:                                                                        
Encapsulation: dot1q 23 vlan protocol type 0x8100
Rewrite: ingress tag pop 1 symmetric
Interface Dot1q Tunnel Ethertype: 0x8100
State: Up
EFP Statistics:
   Pkts In   Bytes In   Pkts Out  Bytes Out
   2130904  144901472   77356021 5260209428
EFP Microblocks:
****************
Microblock type: Bridge-domain
Bridge-domain: 1530
Microblock type: L2Mcast
L2 Multicast GID: 55
Microblock type: dhcp_snoop
L2 Multicast GID: 55

Просмотр статистики по Ethernet Flow Point.

R1#show ethernet service instance id 23 interface gigabitEthernet 0/15 stats 
Port maximum number of service instances: 4000
Service Instance 23, Interface GigabitEthernet0/15
   Pkts In   Bytes In   Pkts Out  Bytes Out
   2130904  144901472   77356043 5260210924

На этом все. Мы рассмотрели только малую часть всех возможностей технологии EVC, но этого понимания должно хватить для дальнейшего самостоятельного освоения. Комментируем, подписываемся ну и всем пока:)

О сетях передачи данных: Транки и etherchannel

Многие возможно знают про логическую агрегацию нескольких физических линков между коммутаторами. Она настраивается достаточно просто. Например:
sw-01

interface GigabitEthernet1/0/21
description to gi1/0/1 sw-02
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active

interface GigabitEthernet1/0/22
description to gi1/0/2 sw-02
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active

sw-02

interface GigabitEthernet1/0/1
description to gi1/0/21 sw-01
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active

interface GigabitEthernet1/0/1
description to gi1/0/22 sw-01
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active


При этом на каждом коммутаторе автоматически после введения команды «channel-group» создастся логический интерфейс Port-channel с тем же номером группы и вообще без настроек. Настройки на нем следует сделать идентичные портам, которые он объединяет.

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk

Проверка:
sw-01#show etherchannel summary 
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi1/0/21(P) Gi1/0/22(P)

Иногда в транковых портах есть необходимость ограничить vlan’ы.
Допустим, что на sw-01 появились подобные настройки в портах Po1,Gi1/0/21,Gi1/0/22 и они идентичны:

switchport trunk allowed vlan 100

Вопрос заключается в том, как будут реагировать порты на изменение конфигурации? Какова последовательность редактирования этих трех портов? Вот пример:
sw-01(config)#interface GigabitEthernet1/0/21
sw-01(config-if)#switchport trunk allowed vlan add 101
sw-01(config-if)#^Z
sw-01#show run int gi1/0/21
Building configuration...

Current configuration : 190 bytes
!
interface GigabitEthernet1/0/21
description to gi1/0/1 sw-02
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101
switchport mode trunk
channel-group 1 mode active
end

sw-01#show run int gi1/0/22
Building configuration...

Current configuration : 184 bytes
!
interface GigabitEthernet1/0/22
description to gi1/0/2 sw-02
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100
switchport mode trunk
channel-group 1 mode active
end

sw-01#conf t
Enter configuration commands, one per line. End with CNTL/Z.
sw-01(config)#interface GigabitEthernet1/0/22
sw-01(config-if)#switchport trunk allowed vlan add 101
Connection closed by foreign host.


Что же произошло? Смотрим логи
%PARSER-5-CFGLOG_LOGGEDCMD: User:tester  logged command:interface GigabitEthernet1/0/21 
%EC-5-CANNOT_BUNDLE2: Gi1/0/21 is not compatible with Gi1/0/22 and will be suspended (vlan mask is different)
%PARSER-5-CFGLOG_LOGGEDCMD: User:tester logged command:switchport trunk allowed vlan add 101
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/21, changed state to down
%SYS-5-CONFIG_I: Configured from console by tester on vty0 ()
%PARSER-5-CFGLOG_LOGGEDCMD: User:tester logged command:interface GigabitEthernet1/0/22
%EC-5-CANNOT_BUNDLE2: Gi1/0/21 is not compatible with Po1 and will be suspended (vlan mask is different)
%EC-5-CANNOT_BUNDLE2: Gi1/0/21 is not compatible with Po1 and will be suspended (vlan mask is different)
%EC-5-CANNOT_BUNDLE2: Gi1/0/22 is not compatible with Po1 and will be suspended (vlan mask is different)
%PARSER-5-CFGLOG_LOGGEDCMD: User:tester logged command:switchport trunk allowed vlan add 101
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/22, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down

Худшее, что можно придумать — это настраивать транки на etherchannel’е на «удаленной» стороне. Ошибка изначально заключалась в том, что изменения следовало начать с логического интерфейса Po1. Но и тут не все так просто. Я не стану приводить далее логи и команды последующих тестов и расскажу на словах.
При добавлении vlan’а в транк на Po1 не происходит ничего. Можно спокойно добавить vlan в оставшиеся физические интерфейсы. При удалении vlan’а из Po1 происходит длительное выключение физических интерфейсов из etherchannel’а, что неудобно и неприемлимо.
Итого:
— лучше отказаться от редактирования транков в etherchannel’е.
— если отказаться нельзя — редактировать на «ближней» стороне.
— при редактировании желательно вывести логирование на экран командой terminal monitor, чтобы своевременно обнаружить неполадки.

UPDATE: В разных IOS реакция на редактирование логического интерфейса Po разная. Так в некоторых достаточно настаивать только его, а все настройки будут автоматически копироваться в конфигурацию физических интерфейсов

Маленькое дополнение про Native VLAN.

Одно из отличий коммутаторов Cisco от коммутаторов других производителей, это введение так называемого Native VLAN. Что он из себе представляет?

Native VLAN — это влан к которому коммутатор относит все кадры идущие без тега, или кадры получаемые с не распределенных портов (портов которые явно не включены ни в один влан). То есть если коммутатор получает нетегированные кадры на транковом порту он автоматически причисляет их к Native VLAN. И точно так же кадры генерируемые с не распределенных портов при попадании в транк-порт причисляются к Native VLAN.

Продемонстрировать все это для наглядности можно все в том же Packet Tracer в режиме симуляции.

Итак, имеем два коммутатора. Порты fa 0/1 являются портами доступа для VLAN2, а порты fa 0/3 — для VLAN1. Порты fa 0/2 не распределены. Между коммутаторами транковый линк.

Сгенерируем пинг от PC1 к PC2 и заглянем в структуру PDU. На входе в 1 порт коммутатора в заголовке кадра будет указан тип 0x800 — что соответствует протоколу IP.

На выходе в 5й (транк-порт) в заголовке тип будет уже 0x810 — инкапсуляция 802.1Q (оно же технология VLAN) с тегом 2.

Теперь пинг от PC3 к PC4.

И на входе во 2й порт и на выходе в 5й (транковый порт) получаем один и тот же заголовок Ethernet II без тега.

И последнее. Пинг от PC5 к PC6. Напомним, что порты распределены в 1 влан, и native vlan по умолчанию так же носит номер 1. Соответственно трафик так же как и в предыдущем случае идет без тега.

Посмотреть информацию по  тому, какой native vlan сконфигурирован на устройстве можно командами show interface trunk

и show interface <тип> <номер> switchport

На транковом линке обоих коммутаторов Native VLAN должен совпадать.Если не совпадают то коммутатор известит об этом общением — Native VLAN mismatch. Сам native vlan указывается при помощи команды switchport trunk native vlan <номер>.

Так как кадры Native VLAN обязаны проходить по транк-линкам без тегов, появление в транк-линке кадра с тегом номер которого совпадает с номером Native VLAN является не допустимым, и коммутатор получив такой кадр его уничтожает.
Скачать: pkt-файл

PS в pkt-файле есть небольшое изменение. Порты коммутаторов fa 0/2 переведены в режим trunk. Результат точно такой же, кадры идут без тега и дублируются на порты распределенные в первый влан (т.к. он же native) и наоборот.


ROUTER1:
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0

ROUTER2:
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.2 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.2 255.255.255.0

SW1, SW2:
interface FastEthernet0/1
switchport trunk native vlan 10
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 10
switchport mode trunk

Схема: ROUTER1<—->SW1<—->SW2<—->ROUTER2

Объяснение инкапсуляции 802.1Q

Когда вам нужен трафик VLAN между двумя коммутаторами, возникает одна проблема, с которой мы сталкиваемся… взгляните на изображение ниже:

Это обычный фрейм Ethernet… вы видите какое-нибудь поле, в котором мы можем указать, к какой VLAN принадлежит наш фрейм Ethernet? Ну нет! Так как же коммутатор узнает, к какой VLAN что-то принадлежит, когда он получает кадр? Он понятия не имеет, поэтому нам нужен еще один протокол, чтобы помочь нам.




Если вы хотите передавать трафик VLAN между коммутаторами, мы должны использовать транк .Магистральное соединение — это не что иное, как обычная ссылка, но оно может передавать трафик из разных VLAN и имеет метод разделения трафика между VLAN. Вот пример:

 

Как вы можете видеть, у нас есть компьютеры с обеих сторон, и они находятся в разных VLAN, используя транки, мы можем убедиться, что весь трафик VLAN может быть отправлен между коммутаторами. Поскольку наши обычные фреймы Ethernet ничего не показывают, к какой VLAN они принадлежат, нам понадобится другой протокол.

Существует два транкинговых протокола:

  • 802.1Q : Это наиболее распространенный транкинговый протокол. Это стандарт, поддерживаемый многими поставщиками.
  • ISL : Это транкинговый протокол Cisco. Не все коммутаторы поддерживают его.

Давайте посмотрим на 802.1Q:

Вот пример кадра Ethernet 802.1Q. Как видите, это то же самое, что и обычный фрейм Ethernet, но мы добавили тег посередине (синее поле).В нашем теге вы найдете «идентификатор VLAN», который представляет собой VLAN, к которой принадлежит этот кадр Ethernet. Так коммутаторы узнают, к какой VLAN принадлежит наш трафик.

Также есть поле под названием «Приоритет», с помощью которого мы можем присвоить разный приоритет разным типам трафика. Это полезно, когда у вас есть одна VLAN для передачи голоса по IP-трафику, а другая VLAN для трафика данных, и вы, вероятно, захотите назначить приоритет трафику VoIP, иначе качество связи может пострадать.

Я надеюсь, что это было полезно для понимания 802.1 кв.

Если вы хотите узнать, как настраивать транки… взгляните на этот урок, который я написал ранее. В нем объясняется, как настроить соединительные линии на коммутаторах Cisco Catalyst.

Команда Encapsulation Dot1Q на маршрутизаторе/коммутаторе CISCO

Команда

Encapsulation Dot1Q

Использование

Позволяет использовать интерфейс маршрутизатора в качестве магистрального порта для коммутатора. Это также известно как «маршрутизатор на флешке», потому что коммутатор использует маршрутизатор для маршрутизации между VLAN.

Синтаксис

Router(config-subif)#encapsulation dot1Q

Option

Пример

В приведенном ниже примере мы настроим базовую конфигурацию «маршрутизатор на флешке». Во-первых, мы настроим порт, подключенный к интерфейсу Fa0/1 2611XM, в качестве транка на коммутаторе.Маршрутизаторы
поддерживают только инкапсуляцию Dot1Q.

 2950-XL#показать соседний CDP
Коды возможностей: R — Маршрутизатор, T — Trans Bridge, B — Source Route Bridge
S — коммутатор, H — хост, I — IGMP, r — повторитель

ID устройства Local Intrfce Holdtme Capability Platform ID Port ID
2611XM Fas 0/1 174 R S I Cisco 2611Fas 0/0
2611XM Fas 0/3 166 R S I Cisco 2611Fas 0/1

2950-XL#конф т
2950-XL(конфигурация)#int fa0/3
2950-XL(config-if)#инкапсуляция соединительной линии порта коммутатора dot1q
2950-XL(config-if)#switchport mode trunk 

Теперь настроим интерфейс Fa0/1 маршрутизатора для работы в качестве транка.
Во-первых, мы удаляем IP-адрес на физическом интерфейсе.
Далее мы настраиваем субинтерфейс для каждой VLAN, для которой канал будет транком. Номер интерфейса может быть каким угодно.
После этого настраиваем encapsulation dot1q для каждого сабинтерфейса. Эту команду необходимо ввести перед IP-адресом, иначе вы получите сообщение об ошибке, показанное ниже.
Наконец, настройте IP-адрес для VLAN. Обычно это шлюз по умолчанию.

 2611XM(config-if)#int fa0/1
2611XM(config-if)#без добавления ip
2611XM(config-if)#нет закрытия
2611XM(config-if)#int fa0/1
* 25 июля 02:40:49.523: %LINK-3-UPDOWN: интерфейс FastEthernet0/1, изменено состояние на up

2611XM(config-if)#int fa0/1.70
2611XM (config-subif) # инкапсуляция dot1Q 70
2611XM(config-subif)#ip добавить 10.10.70.1 255.255.255.0

2611XM(config-subif)#int fa0/1.99
2611XM(config-subif)#ip добавить 10.10.99.1 255.255.255.0

% Настройка IP-маршрутизации на субинтерфейсе LAN разрешена только в том случае,
подинтерфейс уже настроен как часть IEEE 802.10, IEEE 802.1Q,
или ISL vLAN.

2611XM (config-subif) # инкапсуляция dot1Q 99
2611XM(config-subif)#ip добавить 10.10.99.1 255.255.255.0 

Для тестирования мы добавим пару интерфейсов SVI, чтобы мы могли выполнить некоторые тесты ping.

 2950-XL(конфигурация)#int vlan 70
2950-XL(config-subif)#ip добавить 10.10.70.254 255.255.255.0
2950-XL(config-subif)#int vlan 99
2950-XL(config-subif)#ip добавить 10.10.99.254 255.255.255.0
2950-XL(config-subif)#конец
2950-XL#пинг 10.10.70.1

Введите escape-последовательность, чтобы прервать.
Отправка 5 100-байтовых эхо-сообщений ICMP на адрес 10.10.70.1, время ожидания составляет 2 секунды:
!!!!!
Вероятность успеха составляет 100 процентов (5/5), время приема-передачи мин./сред./макс. = 1/3/6 мс
2950-XL#пинг 10.10.99.1

Введите escape-последовательность, чтобы прервать.
Отправка 5 100-байтовых эхо-сообщений ICMP на адрес 10.10.99.1, время ожидания составляет 2 секунды:
!!!!!
Вероятность успеха составляет 100 процентов (5/5), время приема-передачи мин./сред./макс. = 1/203/1006 мс.
2950-XL# 

%PDF-1.6 % 153 0 объект > эндообъект внешняя ссылка 153 511 0000000016 00000 н 0000011851 00000 н 0000012096 00000 н 0000012123 00000 н 0000012173 00000 н 0000012227 00000 н 0000012276 00000 н 0000012316 00000 н 0000012600 00000 н 0000012723 00000 н 0000012847 00000 н 0000012971 00000 н 0000013094 00000 н 0000013292 00000 н 0000013513 00000 н 0000013719 00000 н 0000013798 00000 н 0000013875 00000 н 0000013954 00000 н 0000019145 00000 н 0000019194 00000 н 0000019297 00000 н 0000019346 00000 н 0000019396 00000 н 0000019445 00000 н 0000019495 00000 н 0000019544 00000 н 0000019593 00000 н 0000019642 00000 н 0000019691 00000 н 0000019740 00000 н 0000019789 00000 н 0000019845 00000 н 0000019894 00000 н 0000019943 00000 н 0000019992 00000 н 0000020041 00000 н 0000020090 00000 н 0000020139 00000 н 0000020188 00000 н 0000020237 00000 н 0000020286 00000 н 0000020335 00000 н 0000020384 00000 н 0000020433 00000 н 0000020482 00000 н 0000020531 00000 н 0000020580 00000 н 0000020629 00000 н 0000020678 00000 н 0000020727 00000 н 0000020776 00000 н 0000020825 00000 н 0000020875 00000 н 0000020925 00000 н 0000020974 00000 н 0000021023 00000 н 0000021072 00000 н 0000021121 00000 н 0000021170 00000 н 0000021219 00000 н 0000021268 00000 н 0000021317 00000 н 0000021366 00000 н 0000021415 00000 н 0000021464 00000 н 0000021513 00000 н 0000021562 00000 н 0000021611 00000 н 0000021660 00000 н 0000021709 00000 н 0000021758 00000 н 0000021807 00000 н 0000021856 00000 н 0000021907 00000 н 0000021956 00000 н 0000022005 00000 н 0000022054 00000 н 0000022103 00000 н 0000022152 00000 н 0000022202 00000 н 0000022251 00000 н 0000022301 00000 н 0000022350 00000 н 0000022400 00000 н 0000022449 00000 н 0000022498 00000 н 0000045154 00000 н 0000067081 00000 н 0000088817 00000 н 0000112857 00000 н 0000137254 00000 н 0000161689 00000 н 0000162128 00000 н 0000162853 00000 н 0000163374 00000 н 0000163537 00000 н 0000163718 00000 н 0000163916 00000 н 0000164059 00000 н 0000164717 00000 н 0000165013 00000 н 0000165343 00000 н 0000165627 00000 н 0000169677 00000 н 0000170143 00000 н 0000170522 00000 н 0000170948 00000 н 0000171339 00000 н 0000171569 00000 н 0000171839 00000 н 0000172111 00000 н 0000176056 00000 н 0000176466 00000 н 0000176555 00000 н 0000177656 00000 н 0000177888 00000 н 0000202416 00000 н 0000225485 00000 н 0000229025 00000 н 0000229418 00000 н 0000230134 00000 н 0000241475 00000 н 0000242056 00000 н 0000242114 00000 н 0000242248 00000 н 0000242323 00000 н 0000242496 00000 н 0000242571 00000 н 0000242658 00000 н 0000242741 00000 н 0000242820 00000 н 0000242903 00000 н 0000242974 00000 н 0000243049 00000 н 0000243128 00000 н 0000243195 00000 н 0000243270 00000 н 0000243333 00000 н 0000243391 00000 н 0000243449 00000 н 0000243520 00000 н 0000243583 00000 н 0000243650 00000 н 0000243721 00000 н 0000243779 00000 н 0000243846 00000 н 0000243909 00000 н 0000243972 00000 н 0000244035 00000 н 0000244089 00000 н 0000244147 00000 н 0000244205 00000 н 0000244263 00000 н 0000244326 00000 н 0000244441 00000 н 0000244548 00000 н 0000244631 00000 н 0000244706 00000 н 0000244777 00000 н 0000244844 00000 н 0000244907 00000 н 0000244965 00000 н 0000245040 00000 н 0000245107 00000 н 0000245174 00000 н 0000245245 00000 н 0000245299 00000 н 0000245366 00000 н 0000245429 00000 н 0000245492 00000 н 0000245546 00000 н 0000245604 00000 н 0000245662 00000 н 0000245720 00000 н 0000245783 00000 н 0000246096 00000 н 0000246167 00000 н 0000246246 00000 н 0000246313 00000 н 0000246371 00000 н 0000246434 00000 н 0000246549 00000 н 0000246628 00000 н 0000246731 00000 н 0000246798 00000 н 0000247059 00000 н 0000247113 00000 н 0000247176 00000 н 0000247263 00000 н 0000250568 00000 н 0000250825 00000 н 0000251042 00000 н 0000251331 00000 н 0000251879 00000 н 0000252020 00000 н 0000267012 00000 н 0000267051 00000 н 0000267588 00000 н 0000267716 00000 н 0000320267 00000 н 0000320306 00000 н 0000320399 00000 н 0000320508 00000 н 0000320617 00000 н 0000320726 00000 н 0000320833 00000 н 0000320922 00000 н 0000321031 00000 н 0000321214 00000 н 0000321384 00000 н 0000321577 00000 н 0000321775 00000 н 0000321955 00000 н 0000322141 00000 н 0000322385 00000 н 0000322578 00000 н 0000322758 00000 н 0000322962 00000 н 0000323180 00000 н 0000323414 00000 н 0000323592 00000 н 0000323781 00000 н 0000324005 00000 н 0000324187 00000 н 0000324384 00000 н 0000324593 00000 н 0000324790 00000 н 0000324965 00000 н 0000325174 00000 н 0000325382 00000 н 0000325579 00000 н 0000325758 00000 н 0000325967 00000 н 0000326146 00000 н 0000326324 00000 н 0000326535 00000 н 0000326722 00000 н 0000326918 00000 н 0000327097 00000 н 0000327284 00000 н 0000327469 00000 н 0000327691 00000 н 0000327863 00000 н 0000328055 00000 н 0000328269 00000 н 0000328441 00000 н 0000328616 00000 н 0000328800 00000 н 0000328979 00000 н 0000329166 00000 н 0000329357 00000 н 0000329536 00000 н 0000329715 00000 н 0000329885 00000 н 0000330073 00000 н 0000330263 00000 н 0000330448 00000 н 0000330648 00000 н 0000330839 00000 н 0000331034 00000 н 0000331216 00000 н 0000331393 00000 н 0000331592 00000 н 0000331813 00000 н 0000331991 00000 н 0000332175 00000 н 0000332369 00000 н 0000332583 00000 н 0000332818 00000 н 0000333002 00000 н 0000333183 00000 н 0000333355 00000 н 0000333535 00000 н 0000333717 00000 н 0000333892 00000 н 0000334073 00000 н 0000334254 00000 н 0000334432 00000 н 0000334604 00000 н 0000334792 00000 н 0000334972 00000 н 0000335144 00000 н 0000335322 00000 н 0000335497 00000 н 0000335677 00000 н 0000335852 00000 н 0000336068 00000 н 0000336243 00000 н 0000336423 00000 н 0000336609 00000 н 0000336788 00000 н 0000336960 00000 н 0000337135 00000 н 0000337307 00000 н 0000337485 00000 н 0000337660 00000 н 0000337833 00000 н 0000338010 00000 н 0000338183 00000 н 0000338362 00000 н 0000338537 00000 н 0000338714 00000 н 0000338893 00000 н 0000339063 00000 н 0000339241 00000 н 0000339419 00000 н 0000339596 00000 н 0000339775 00000 н 0000339950 00000 н 0000340119 00000 н 0000340300 00000 н 0000340494 00000 н 0000340669 00000 н 0000340847 00000 н 0000341027 00000 н 0000341200 00000 н 0000341370 00000 н 0000341549 00000 н 0000341728 00000 н 0000341903 00000 н 0000342095 00000 н 0000342267 00000 н 0000342443 00000 н 0000342618 00000 н 0000342795 00000 н 0000342972 00000 н 0000343152 00000 н 0000343334 00000 н 0000343515 00000 н 0000343687 00000 н 0000343862 00000 н 0000344046 00000 н 0000344223 00000 н 0000344398 00000 н 0000344573 00000 н 0000344743 00000 н 0000344919 00000 н 0000345095 00000 н 0000345270 00000 н 0000345445 00000 н 0000345620 00000 н 0000345795 00000 н 0000345996 00000 н 0000346176 00000 н 0000346350 00000 н 0000346567 00000 н 0000346802 00000 н 0000347029 00000 н 0000347240 00000 н 0000347440 00000 н 0000347645 00000 н 0000347835 00000 н 0000348044 00000 н 0000348251 00000 н 0000348434 00000 н 0000348621 00000 н 0000348796 00000 н 0000348994 00000 н 0000349184 00000 н 0000349370 00000 н 0000349556 00000 н 0000349743 00000 н 0000349915 00000 н 0000350093 00000 н 0000350359 00000 н 0000350540 00000 н 0000350712 00000 н 0000350891 00000 н 0000351064 00000 н 0000351274 00000 н 0000351470 00000 н 0000351662 00000 н 0000351865 00000 н 0000352040 00000 н 0000352210 00000 н 0000352390 00000 н 0000352593 00000 н 0000352777 00000 н 0000352972 00000 н 0000353147 00000 н 0000353337 00000 н 0000353521 00000 н 0000353710 00000 н 0000353906 00000 н 0000354076 00000 н 0000354251 00000 н 0000354438 00000 н 0000354621 00000 н 0000354796 00000 н 0000354971 00000 н 0000355145 00000 н 0000355323 00000 н 0000355514 00000 н 0000355702 00000 н 0000355881 00000 н 0000356056 00000 н 0000356240 00000 н 0000356421 00000 н 0000356591 00000 н 0000356761 00000 н 0000356930 00000 н 0000357099 00000 н 0000357268 00000 н 0000357441 00000 н 0000360572 00000 н 0000360752 00000 н 0000360924 00000 н 0000361113 00000 н 0000361296 00000 н 0000361479 00000 н 0000361654 00000 н 0000361854 00000 н 0000362032 00000 н 0000362204 00000 н 0000362425 00000 н 0000362618 00000 н 0000362793 00000 н 0000363018 00000 н 0000363206 00000 н 0000363388 00000 н 0000363560 00000 н 0000363730 00000 н 0000363900 00000 н 0000364072 00000 н 0000364242 00000 н 0000364584 00000 н 0000364764 00000 н 0000364945 00000 н 0000365131 00000 н 0000365317 00000 н 0000365500 00000 н 0000365685 00000 н 0000365866 00000 н 0000366046 00000 н 0000366218 00000 н 0000366390 00000 н 0000366571 00000 н 0000366742 00000 н 0000366976 00000 н 0000367168 00000 н 0000367368 00000 н 0000367599 00000 н 0000367784 00000 н 0000367991 00000 н 0000368195 00000 н 0000368371 00000 н 0000368558 00000 н 0000368740 00000 н 0000368926 00000 н 0000369113 00000 н 0000369300 00000 н 0000369476 00000 н 0000369650 00000 н 0000369835 00000 н 0000370008 00000 н 0000370186 00000 н 0000370364 00000 н 0000370540 00000 н 0000370722 00000 н 0000370897 00000 н 0000371089 00000 н 0000371290 00000 н 0000371457 00000 н 0000371649 00000 н 0000371828 00000 н 0000372017 00000 н 0000372227 00000 н 0000372463 00000 н 0000372707 00000 н 0000372940 00000 н 0000373142 00000 н 0000373332 00000 н 0000373558 00000 н 0000373755 00000 н 0000373968 00000 н 0000374154 00000 н 0000374334 00000 н 0000374545 00000 н 0000374746 00000 н 0000374933 00000 н 0000375132 00000 н 0000375307 00000 н 0000375482 00000 н 0000375692 00000 н 0000375892 00000 н 0000376067 00000 н 0000376246 00000 н 0000376429 00000 н 0000376604 00000 н 0000376788 00000 н 0000376977 00000 н 0000377167 00000 н 0000377361 00000 н 0000377537 00000 н 0000377713 00000 н 0000377889 00000 н 0000378061 00000 н 0000378237 00000 н 0000378409 00000 н 0000378576 00000 н 0000378748 00000 н 0000378933 00000 н 0000379110 00000 н 0000379167 00000 н 0000379304 00000 н 0000379438 00000 н 0000379555 00000 н 0000379701 00000 н 0000011681 00000 н 0000010728 00000 н трейлер ]/Предыдущая 504839/XRefStm 11681>> startxref 0 %%EOF 663 0 объект >поток hTKHQ09F#fj#Xib)a(Z S4XQ€yci`iYA/»ZA

Что такое инкапсуляция DOT1Q? – Gzipwtf.ком

Что такое инкапсуляция DOT1Q?

Что такое инкапсуляция 802.1Q? 802.1Q — это сетевой стандарт, определяющий виртуальные локальные сети (VLAN) в сети Ethernet. VLAN — это логические сети, которые совместно используют одно физическое соединение с использованием тегированных кадров 802.1Q.

Что такое инкапсуляция Switchport DOT1Q?

Инкапсуляция магистрали коммутатора

dot1q устанавливает режим инкапсуляции интерфейса магистрали в соответствии с отраслевым стандартом 802.1Q. switchport trunk encapsulation isl устанавливает режим инкапсуляции транкового интерфейса на проприетарный ISL.транк режима switchport административно настраивает порт как транк.

В чем разница между ISL и DOT1Q?

ISL и DOT1Q — это 2 стандарта инкапсуляции, поддерживающие виртуальные локальные сети (VLAN) в сети Ethernet… ISL и DOT1Q —

ПАРАМЕТР МСЛ ДОТ1К
Родная рама ISL не помечает кадры из собственных Vlan 802.1q не помечает кадры из собственного Vlan

Каковы характеристики 802.1К инкапсуляция?

— это протокол обмена сообщениями уровня 2, который поддерживает конфигурации vlan в сети. он включает 8-битное поле, которое определяет приоритет кадра. он используется исключительно для маркировки кадров vlan и не решает проблемы реконвергенции сети после изменений топологии коммутируемой сети.

Что такое инкапсуляция ISL?

ISL — это протокол инкапсуляции VLAN от Cisco, который поддерживается только некоторым оборудованием Cisco по каналам Fast и Gigabit Ethernet.При использовании ISL кадр Ethernet инкапсулируется с заголовком, который передает идентификаторы VLAN между коммутаторами и маршрутизаторами. В IEEE 802.1Q тег является внутренним.

Что такое 802 Q?

IEEE 802.1Q, часто называемый Dot1q, — это сетевой стандарт, который поддерживает виртуальные локальные сети (VLAN) в сети IEEE 802.3 Ethernet. Стандарт был разработан IEEE 802.1, рабочей группой комитета по стандартам IEEE 802, и продолжает активно пересматриваться.

Что такое dot1q Cisco?

802.1q (также известный как dot1q) — это транкинговый протокол промышленного стандарта IEEE. Коммутаторы Cisco поддерживают как ISL (Inter Switch Link — собственность Cisco), так и 802.1q. Порты коммутатора, совместимые со стандартом 802.1Q, можно настроить для передачи тегированных или нетегированных кадров.

Что такое инкапсуляция ARPA?

Encapsulation ARPA: это протокол уровня 2, который мы используем, когда мы используем Ethernet, он отображается как ARPA (Агентство перспективных исследовательских проектов), что является инкапсуляцией Ethernet версии 2. Если вы используете PPP, HDLC или frame-relay на последовательных каналах, они будут отображаться здесь.

Что такое соединительная линия Dot1q?

VLAN Trunking (802.1Q) позволяет совместно использовать или использовать несколько физических сетевых интерфейсов в вычислительной среде. Сетевые устройства в сети взаимодействуют только с пакетами, имеющими правильные теги. Это позволяет нескольким различным логическим сетям работать на одном и том же кабеле и коммутационной инфраструктуре.

Что такое транкинг ISL?

Inter-Switch Link (ISL) Trunking — это дополнительное программное обеспечение, для которого требуется лицензия, позволяющая создавать транкинговые группы ISL между соседними коммутаторами.

Что такое ISL-порт?

ISL — это соединение между двумя коммутаторами через порт расширения (E_Port). ISL Trunking упрощает проектирование сети и снижает стоимость управления хранилищем за счет оптимизации использования полосы пропускания и обеспечения балансировки нагрузки трафика на уровне кадров.

Настройка магистральных портов с использованием ISL или 802.1q

Интерфейсы магистрали

— это обычное развертывание, позволяющее нескольким коммутаторам совместно использовать трафик, принадлежащий нескольким VLAN.В этом лабораторном занятии будет обсуждаться и демонстрироваться конфигурация и проверка транкинга с использованием ISL и 802.1q.

Применение в реальном мире и основные знания

Итак, у вас есть несколько VLAN на нескольких коммутаторах, но как вы передаете трафик между этими коммутаторами, не подключая перекрестный кабель к порту, который существует в каждой VLAN, что может быть большой потерей плотности портов? Ответ довольно прост, это называется магистральным каналом. Поначалу магистральные каналы могут быть трудно понять, но природа магистрального канала заключается только в передаче нескольких vlan-трафика между 2 или более коммутаторами по одному каналу.Это делается с помощью проприетарного протокола инкапсуляции магистрали Inter-Switch Link (ISL) Cisco или протокола инкапсуляции магистрали стандарта IEEE 802.1q (dot1q).

В качестве CCNA вам потребуется понимать работу обоих протоколов инкапсуляции магистральных каналов, а также способы настройки, проверки и устранения неполадок магистральных каналов с использованием ISL или Dot1q.

Inter-Switch Link (ISL), как указывалось ранее, является проприетарным магистральным протоколом Cisco, который инкапсулирует весь кадр в 26-байтовый заголовок и 4-байтовую последовательность проверки кадра (FCS), которая добавляет 10-битный идентификатор VLAN и передает его по магистральному каналу на убедитесь, что трафик из SW1 VLAN 10 остается в VLAN 10 при поступлении на SW2.

Стандарт IEEE 802.1q (Dot1q), однако, НЕ инкапсулирует весь кадр Ethernet, а вводит 32-битное поле в кадр Ethernet между MAC-адресом и полями EtherType/Length исходного кадра.

32 бита в поле dot1q разбиты на 4 отдельных раздела. первые 16 бит — это TPID, следующие 3 — это PCP, за ними следует CFI и, наконец, VID.

Идентификатор протокола тегов (TPID) представляет собой 16-битное поле. Для него установлено значение 0x8100, чтобы идентифицировать кадр как IEEE 802.1Q-тегированный кадр.

Кодовая точка приоритета (PCP) представляет собой 3-битное поле, которое относится к приоритету IEEE 802.1p. Поле указывает уровень приоритета кадра, который можно использовать для приоритезации трафика. Поле может представлять 8 значений (от 0 до 7).

Индикатор канонического формата (CFI) представляет собой 1-битное значение; on или off, который определяет, скорее всего, MAC-адрес находится в неканоническом формате.

Идентификатор VLAN (VID) представляет собой 12-битное поле.Он однозначно идентифицирует VLAN, к которой принадлежит кадр. Поле может иметь значение от 0 до 4095.

Согласно рекомендации Cisco, все развертывания должны использовать стандарт IEEE 802.1q, так как он может использоваться разными поставщиками, в то время как Cisco ISL относится только к коммутаторам Cisco.

В этой лабораторной работе вы познакомитесь со следующими командами;

Команда Описание
соединительная линия режима порта При выполнении этой команды в режиме настройки интерфейса на порту коммутатора этот порт будет настроен как магистральный порт, через который проходит весь трафик VLAN.
инкапсуляция магистрали коммутатора isl Эта команда выполняется в режиме конфигурации интерфейса, чтобы указать, что магистраль будет использовать протокол инкапсуляции Cisco Inter-Switch Link (ISL).
инкапсуляция магистрали коммутатора dot1q Эта команда выполняется в режиме конфигурации интерфейса, чтобы указать, что соединительная линия будет использовать стандартный протокол инкапсуляции IEEE 802.1q.
показать соединительную линию интерфейса Эта команда выполняется в привилегированном режиме, чтобы показать, какие интерфейсы в настоящее время транкинговые и какой транкинговый протокол используется.
показать интерфейс interfacename#/# switchport Эта команда при выполнении в привилегированном режиме покажет информацию, относящуюся к указанному интерфейсу, такую ​​как режим работы интерфейса (транк или доступ), собственный vlan, транкинговые VLAN, разрешенные на транковом канале, и многое другое.

Лабораторные предпосылки

  • Если вы используете GNS3, загрузите топологию Free CCNA Workbook GNS3, а затем запустите устройства; SW1, SW2, R1 и R2.
  • Установите сеанс консоли с устройствами SW1, SW2, R1 и R2, затем настройте соответствующие имена хостов устройств.
  • Настройте интерфейс FastEthernet0/0 маршрутизатора R1 с IP-адресом 10.1.1.1/24 и интерфейс FastEthernet0/1 маршрутизатора R2 с IP-адресом 10.1.1.2/24
  • Создайте VLAN 10 как VLAN уровня 2 на SW1 и SW2. (VLAN уровня 2 не имеют интерфейсов VLAN уровня 3, представляющих VLAN, т. е. нет интерфейса Vlan10.)
  • Настройте интерфейсы FastEthernet0/1 SW1 и FastEthernet0/2 SW2 в качестве статических интерфейсов доступа для VLAN 10.

Лабораторные цели

  • Отключите интерфейсы FastEthernet0/11 и FastEthernet0/12 на SW1 и SW2 и настройте IEEE 802.Транк 1q на интерфейсе FastEthernet0/10 обоих SW1 и SW2.
  • Проверьте конфигурацию магистрального канала с помощью команды show interface interfacename#/# trunk.
  • Убедитесь, что R1 имеет IP-доступ к R2, используя команду ping на R1.
  • Измените интерфейс FastEthernet0/2 SW1, чтобы поместить его в VLAN 5, и снова проверьте доступность IP-адресов между R1 и R2.

Лабораторная инструкция для этой лабораторной работы демонстрируется с использованием коммутатора Cisco Catalyst серии 3560, а не NM-16ESW.. Также обратите внимание, что NM-16ESW не поддерживает инкапсуляцию магистрали ISL, что будет продемонстрировано в лабораторной инструкции.

Лабораторная инструкция

Шаг 1. – Отключите интерфейсы FastEthernet0/11 и FastEthernet0/12 на SW1 и SW2 и настройте соединительную линию IEEE 802.1q на интерфейсе FastEthernet0/10 на SW1 и SW2.

Чтобы настроить интерфейс в качестве статической магистрали, сначала необходимо настроить тип инкапсуляции, так как интерфейс, инкапсуляция магистрали которого «Авто», не может быть настроен на режим «магистраль».

SW1 con0 теперь доступен



Нажмите RETURN, чтобы начать.



SW1>включить
SW1#настроить терминал
Введите команды конфигурации, по одной в строке. Конец с CNTL/Z.
SW1(config-if)#диапазон интерфейса Fa0/11 - 12
SW1 (диапазон конфигурации) # выключение
SW1(config-if-range)#интерфейс fa0/10
SW1 (config-if) # инкапсуляция транкового порта коммутатора dot1q
SW1(config-if)#переключатель режима транка
SW1(config-if)#нет закрытия
SW1 (конфигурация-если) # конец
SW1#
 

А теперь такая же конфигурация на SW2;

SW2 con0 теперь доступен



Нажмите RETURN, чтобы начать.SW2>включить
SW2# настроить терминал
Введите команды конфигурации, по одной в строке. Конец с CNTL/Z.
SW2(config-if)#диапазон интерфейса Fa0/11 - 02
SW2 (диапазон конфигурации) # выключение
SW2(config-if-range)#интерфейс fa0/10
SW2 (config-if) # инкапсуляция магистрального порта коммутатора dot1q
SW2(config-if)#переключатель режима транка
SW2(config-if)#нет закрытия
SW2(config-if)#конец
SW2#
 

Шаг 2 . – Проверьте конфигурацию магистрального канала с помощью команды show interface FastEthernet0/10 trunk, как показано ниже, на SW1 и SW2;

SW1#показать интерфейс Транк FastEthernet0/10

Статус инкапсуляции режима порта Native vlan
Fa0/10 на 802.1q транкинг 1

Порты Vlan разрешены на транке
Fa0/10 1-4094

Порты Vlan разрешены и активны в домене управления
Фа0/10 1,10

Вланы портов в состоянии переадресации связующего дерева и не обрезаны
Fa0/10 1
SW1#
 
SW2#показать интерфейс Транк FastEthernet0/10

Статус инкапсуляции режима порта Native vlan
Fa0/10 на транкинге 802.1q 1

Порты Vlan разрешены на транке
Fa0/10 1-4094

Порты Vlan разрешены и активны в домене управления
Фа0/10 1,10

Вланы портов в состоянии переадресации связующего дерева и не обрезаны
Fa0/10 1
SW2#
 

Шаг 3.– Убедитесь, что R1 имеет IP-доступ к R2, используя команду ping на R1.

Теперь, когда у вас есть магистральный канал между SW1 и SW2, трафик, созданный на SW1 в VLAN 10, должен иметь возможность распространяться в VLAN 10 на SW2. Чтобы проверить это, отправьте эхо-запрос на интерфейс FastEthernet 0/1 маршрутизатора R2 (IP-адрес 10.1.1.2) с маршрутизатора R1, как показано ниже;

R1#пинг 10.1.1.2

Введите escape-последовательность, чтобы прервать.
Отправка 5 100-байтовых эхо-сообщений ICMP на адрес 10.1.1.2, время ожидания составляет 2 секунды:
.!!!!
Вероятность успеха составляет 80 процентов (4/5), время приема-передачи мин./сред./макс. = 4/29/60 мс
R1#
 

Когда вы отправляете эхо-запрос на IP-адрес интерфейса FastEthernet0/1 R2 от R1, маршрутизатор знает, что IP-адрес назначения находится в той же локальной подсети, поэтому он использует ARP для MAC-адреса хоста 10.1.1.2. Этот запрос ARP получен на SW1 и перенаправлен на SW2 и на R2, который отвечает: «Эй, я 10.1.1.2, мой MAC-адрес — ABCD.EF12.3456». Теперь, когда R1 знает MAC-адрес для 10.1.1.2, он пересылает пакет ICMP к SW1 с правильным MAC-адресом назначения. Первоначально SW1 не будет знать местоположение этого MAC-адреса, потому что машина не является локальной для этого коммутатора, поэтому он будет пересылать интерфейсы вывода кадров в этой VLAN, за исключением интерфейса, на котором был получен кадр.Когда кадр принимается SW2, он переключается на правильный порт, поскольку MAC уже существует в его таблице MAC-адресов. Когда R2 ответит на пакет ICMP, он пойдет в обратном направлении к SW1. После того, как SW1 получит ответ от R2, предназначенный для R1, увидев НОВЫЙ исходный MAC-адрес, который SW1 не узнал, он затем установит MAC-адрес в таблицу CAM (таблицу MAC-адресов) для будущего использования.

Шаг 4. Измените интерфейс FastEthernet0/2 SW1, чтобы он был помещен в VLAN 5, и снова проверьте доступность IP-адресов между R1 и R2.

Вы также можете проверить это дальше, поместив интерфейс SW2, подключенный к R2, в другой vlan и попытаться пропинговать R2 от R1, и вдвойне это не удастся, как показано ниже;

SW2# настроить терминал
Введите команды конфигурации, по одной в строке. Конец с CNTL/Z.
SW2(config)#интерфейс FastEthernet0/2
SW2(config-if)#switchport vlan 5 доступа
% Access VLAN не существует. Создание влана 5
SW2(config-if)#конец
SW2#
 
R1#пинг 10.1.1.2

Введите escape-последовательность, чтобы прервать.
Отправка 5 100-байтовых эхо-сообщений ICMP на адрес 10.1.1.2, время ожидания составляет 2 секунды:
.....
Вероятность успеха составляет 0 процентов (0/5)
R1#
 

Как показано в этом лабораторном занятии, вы можете использовать магистральные каналы для передачи трафика в нескольких VLAN между несколькими коммутаторами с использованием одного канала.

Из-за того, что NM-16ESW и Cisco 2950 не поддерживают инкапсуляцию магистрали ISL, ниже приведен пример конфигурации. Обратите внимание, что единственная разница в конфигурации между Dot1q и ISL заключается в инкапсуляции транка коммутатора isl | опция команды dot1q .

c3560-Switch2>включить
c3560-Switch2 # настроить терминал
c3560-Switch2(config)#интерфейс fa0/10
c3560-Switch2 (config-if) # switchport trunk encap isl
c3560-Switch2 (config-if) # магистраль режима порта коммутатора
c3560-Switch2 (конфигурация-если) # конец
c3560-Switch2#sh внутр. магистраль fa0/10

Статус инкапсуляции режима порта Native vlan
Fa0/10 на магистрали isl 1

Порты Vlan разрешены на транке
Fa0/10 нет

Порты Vlan разрешены и активны в домене управления
Fa0/10 нет

Вланы портов в состоянии переадресации связующего дерева и не обрезаны
Fa0/10 нет
c3560-Switch2#
 

Что такое инкапсуляция команды dot1q? – Джанет Паник.ком

Что такое инкапсуляция команды dot1q?

Команда dot1q switchport trunk encapsulation сообщает коммутатору, что интерфейс должен использовать инкапсуляцию IEEE 802.1Q для кадров, когда интерфейс настроен как магистраль. В основном 802.1Q вставляет тег VLAN в кадры. Это контрастирует с ISL, который фактически инкапсулирует кадры в кадр ISL.

Что такое инкапсуляция Switchport dot1q?

switchport trunk encapsulation dot1q устанавливает режим инкапсуляции транкового интерфейса в соответствии с отраслевым стандартом 802.1 кв. switchport trunk encapsulation isl устанавливает режим инкапсуляции транкового интерфейса на проприетарный ISL. транк режима switchport административно настраивает порт как транк.

Что такое туннелирование dot1q?

Туннелирование 802.1Q позволяет поставщикам услуг использовать одну VLAN для поддержки клиентов, у которых есть несколько VLAN, сохраняя при этом идентификаторы VLAN клиентов и разделяя трафик в разных VLAN клиентов. Порт, сконфигурированный для поддержки туннелирования 802.1Q, называется туннельным портом.

В чем разница между QinQ и dot1q?

Пакеты

VLAN классифицируются на пакеты dot1q, которые несут только один тег VLAN, и пакеты QinQ, которые несут два тега VLAN. Завершение Dot1q: завершает пакеты, которые несут один тег VLAN. Завершение QinQ: завершает пакеты, содержащие два тега VLAN.

Что такое инкапсуляция dot1q в Cisco?

Инкапсуляция

IEEE 802.1Q настраивается на интерфейсах Ethernet и EtherChannel. IEEE 802.1Q — это стандартный протокол для соединения нескольких коммутаторов и маршрутизаторов, а также для определения топологии VLAN.Используйте команду encapsulation dot1q в режиме конфигурации диапазона подынтерфейсов, чтобы применить идентификатор VLAN к подынтерфейсу.

Что такое dot1q Cisco?

802.1q (также известный как dot1q) — это магистральный протокол промышленного стандарта IEEE. Коммутаторы Cisco поддерживают как ISL (Inter Switch Link — собственность Cisco), так и 802.1q. Порты коммутатора, совместимые со стандартом 802.1Q, можно настроить для передачи тегированных или нетегированных кадров.

Что такое соединительная линия DOT1Q?

VLAN Trunking (802.1Q) позволяет совместно использовать или использовать несколько физических сетевых интерфейсов в вычислительной среде.Сетевые устройства в сети взаимодействуют только с пакетами, имеющими правильные теги. Это позволяет нескольким различным логическим сетям работать на одном и том же кабеле и коммутационной инфраструктуре.

Что такое ISL и dot1q?

ISL и DOT1Q — это два стандарта инкапсуляции, поддерживающие виртуальные локальные сети (VLAN) в сети Ethernet. Это 2 протокола тегирования кадров, которые поддерживает Cisco. Протокол тегирования может быть указан вручную на магистральном порту или динамически согласован с использованием собственного динамического транкового протокола (DTP) Cisco.

Что такое соединительная линия DOT1Q?

VLAN Trunking (802.1Q) позволяет совместно использовать или использовать несколько физических сетевых интерфейсов в вычислительной среде.

Что такое Dot1q Dot1q в коммутаторе Cisco?

Инкапсуляция Dot1Q. Использовать. Позволяет использовать интерфейс маршрутизатора в качестве транкового порта для коммутатора. Это также известно как «маршрутизатор на флешке», потому что коммутатор использует маршрутизатор для маршрутизации между VLAN. Синтаксис. Маршрутизатор (config-subif) # encapsulation dot1Q Option

Как настроить инкапсуляцию Dot1q на маршрутизаторе?

Маршрутизаторы

поддерживают только инкапсуляцию Dot1Q.Теперь мы настроим интерфейс Fa0/1 маршрутизатора для работы в качестве транка. Во-первых, мы удаляем IP-адрес на физическом интерфейсе. Далее мы настраиваем подынтерфейс для каждой VLAN, для которой канал будет транком. Номер интерфейса может быть каким угодно.

Что такое команда Dot1q в командной строке?

Команда. Инкапсуляция Dot1Q. Использовать. Позволяет использовать интерфейс маршрутизатора в качестве транкового порта для коммутатора. Это также известно как «маршрутизатор на флешке», потому что коммутатор использует маршрутизатор для маршрутизации между VLAN.Синтаксис. Маршрутизатор (config-subif) # encapsulation dot1Q Option

Почему на выходе интерфейса коммутатора Catalyst 3750 появляются Runts?

Когда инкапсуляция 802.1Q используется на транковом интерфейсе на коммутаторах Catalyst 3750, в выходных данных show interface можно увидеть ранты, поскольку действительные инкапсулированные пакеты 802.1Q размером 61–64 байта, включая q-tag, учитываются коммутатором Catalyst 3750 как кадры меньшего размера, хотя эти пакеты пересылаются корректно.

Для чего используется инкапсуляция dot1q? – Сделано в сборе.ком

Для чего используется инкапсуляция dot1q?

Что такое инкапсуляция 802.1Q? 802.1Q — это сетевой стандарт, определяющий виртуальные локальные сети (VLAN) в сети Ethernet. VLAN — это логические сети, которые совместно используют одно физическое соединение с использованием тегированных кадров 802.1Q.

Что такое инкапсуляция маршрутизатора dot1q?

Router(config-subif)# encapsulation dot1q 1. Включает инкапсуляцию трафика IEEE 802.1Q на указанном подынтерфейсе в сетях VLAN и по умолчанию использует связанную сеть VLAN как собственную сеть VLAN.Шаг 3. Router(config-subif)# bridge-group bridge-group. Назначает каждый сетевой интерфейс группе мостов.

Каково назначение тега 802.1Q?

Протокол тегирования 802.1Q позволяет увеличить размер кадра Ethernet на четыре байта до диапазона от 68 до 1522 байт. Это увеличение размера связано с вставкой в ​​кадр четырехбайтового тега VLAN. Теги, которые включают в себя идентификатор VLAN (VID), присоединяются к каждому кадру Ethernet по MAC-адресу.

Инкапсуляция тегов VCA?

IEEE802.1Q, часто называемый DOT1Q или 1Q, представляет собой сетевой стандарт, поддерживающий виртуальные локальные сети (VLAN) в сети IEEE 802.3 Ethernet. Это наиболее широко используемый метод инкапсуляции для тегирования VLAN. Его также называют стандартом Ethernet.

Что такое инкапсуляция ISL?

ISL — это протокол инкапсуляции VLAN от Cisco, который поддерживается только некоторым оборудованием Cisco по каналам Fast и Gigabit Ethernet. При использовании ISL кадр Ethernet инкапсулируется с заголовком, который передает идентификаторы VLAN между коммутаторами и маршрутизаторами.В IEEE 802.1Q тег является внутренним.

Что такое инкапсуляция при переключении?

Магистраль — это канал «точка-точка» между двумя сетевыми устройствами, которые поддерживают более одной VLAN. В результате коммутаторы с магистральными портами добавляют теги к кадрам для идентификации — процесс, обычно известный как инкапсуляция VLAN.

Как работает IEEE 802.1Q?

IEEE 802.1Q, часто называемый Dot1q, — это сетевой стандарт, который поддерживает виртуальные локальные сети (VLAN) в IEEE 802.3 Сеть Ethernet. Стандарт определяет систему маркировки VLAN для кадров Ethernet и сопутствующие процедуры, которые должны использоваться мостами и коммутаторами при обработке таких кадров.

Где используется ISL?

Коммутаторы Cisco
Приложения: ISL используется в коммутаторах Cisco для коммутации VLAN. Cisco также представила средство для передачи кадров Token Ring, FDDI и ATM через Ethernet ISL. ISL Trunking можно использовать для повышения производительности, управляемости и надежности.

В чем разница между ISL и DOT1Q?

ISL и DOT1Q — это два стандарта инкапсуляции, поддерживающие виртуальные локальные сети (VLAN) в сети Ethernet.Это 2 протокола тегирования кадров, которые поддерживает Cisco….ISL и DOT1Q —

.
ПАРАМЕТР МСЛ ДОТ1К
Родная рама ISL не помечает кадры из собственных Vlan 802.1q не помечает кадры из собственного Vlan

Как определить формат инкапсуляции VLAN как IEEE 802.1Q?

Чтобы определить формат инкапсуляции VLAN как IEEE 802.1Q, используйте следующие команды в режиме конфигурации интерфейса: Указывает подынтерфейс, который будет использовать VLAN.Определяет формат инкапсуляции как IEEE 802.1Q ( dot1q ) и указывает идентификатор VLAN.

Что означает приоритет в инкапсуляции 802.1Q?

Также есть поле под названием «Приоритет», с помощью которого мы можем присвоить разный приоритет разным типам трафика. Это полезно, когда у вас есть одна VLAN для передачи голоса по IP-трафику, а другая VLAN для трафика данных, и вы, вероятно, захотите назначить приоритет трафику VoIP, иначе качество связи может пострадать.

Когда использовать 802.1Q на транковом интерфейсе?

Когда инкапсуляция 802.1Q используется на транковом интерфейсе на коммутаторах Catalyst 3750, в выходных данных show interface можно увидеть ранты, поскольку действительные инкапсулированные пакеты 802.1Q размером 61–64 байта, включая q-tag, учитываются коммутатором Catalyst 3750 как кадры меньшего размера, хотя эти пакеты пересылаются корректно.

Как работает кадр Ethernet 802.1Q?

Вот пример кадра Ethernet 802.1Q. Как видите, это то же самое, что и обычный фрейм Ethernet, но мы добавили тег посередине (синее поле).В нашем теге вы найдете «идентификатор VLAN», который представляет собой VLAN, к которой принадлежит этот кадр Ethernet. Так коммутаторы узнают, к какой VLAN принадлежит наш трафик.

Добавить комментарий

Ваш адрес email не будет опубликован.