Cisco 2960 настройка с нуля – Настройка коммутатора Cisco 2960 | Deltaconfig.ru

Содержание

Настройка коммутатора Cisco 2960 | Deltaconfig.ru

Read this article in Read in EnglishEnglish

Рассмотрим простейший случай, когда требуется подключить 3 отдела фирмы в разные логические сети Vlan, используя один коммутатор уровня доступа Cisco 2960 (Иногда такие коммутаторы называются коммутаторами 2го уровня модели OSI) .

Требуется организовать следующие сети (Vlan):

— отдел продаж (192.168.10.0 255.255.255.0)
— бухгалтерия (192.168.20.0 255.255.255.0)
— администраторы (192.168.100.0 255.255.255.0)
— сеть для управления сетевым оборудованием (192.168.1.0 255.255.255.0)

Базовая настройка коммутатора Cisco 2960

Видео версия этой статьи на английском языке.

Для справки:
Устройства 2го уровня способны передавать данные только внутри одной сети и осуществляют передачу на основе информации о MAC адресах (например внутри сети 192.168.0.0 /24).

Устройства 3го уровня (например коммутатор Cisco 3560) способны маршрутизировать данные на основе информации об ip адресах и передавать их между различными сетями (например между сетью 192.168.1.0 /24 и сетью 192.168.2.0 /24).

deltaconfig - cisco аутсорсинг

Шаг 0. Очистка конфигурации

(Выполняется только с новым или тестовым оборудованием, так как ведет к полному удалению существующей конфигурации)

После извлечения коммутатора из коробки, подключаемся к нему с помощью консольного кабеля и очищаем текущую конфигурацию, зайдя в привилегированный режим и выполнив команду write erase. (Подробнее о режимах конфигурирования оборудования Cisco можно прочитать в этой статье)

Switch>enable
Switch# write erase
/подтверждение очистки конфигурации/
Switch# reload
/подтверждение/

После выполнения коммутатор должен перезагрузиться в течение 3ех минут, а при старте вывести запрос о начале настройки. Следует отказаться.
Would you like to enter the basic configuration dialog (yes/no): no

 Шаг 1. Имя коммутатора

Присвоим коммутатору имя SW-DELTACONFIG-1. (SW – сокращение названия SWitch) Для этого зайдем в режим конфигурирования и введем следующие команды:

Switch #conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch (config)# hostname SW-DELTACONFIG-1
SW-DELTACONFIG-1(config)#

Название устройства изменилось со «Switch» на «SW-DELTACONFIG-1».

Шаг 2. Интерфейс для удаленного управления

Настраиваем интерфейс для управления коммутатором. По умолчанию это Vlan 1. Для этого присваиваем ip адрес интерфейсу и включаем его командой no shutdown.

SW-DELTACONFIG-1(config)#
interface vlan 1
ip address 192.168.1.11 255.255.255.0
no shutdown


В дальнейшем коммутатор будет доступен именно под адресом 192.168.1.11


Шаг 3. Авторизация пользователей

Настраиваем авторизацию для доступа к устройству. Для этого задаем пароль доступа к привилегированному режиму (знак # рядом с названием устройства), а также создаем учетную запись пользователя и пароль для удаленного подключения.

Задаем пароль для доступа к привилегированному режиму #
SW-DELTACONFIG-1(config)#
enable secret XXXX

Создаем учетную запись для удаленного управления и пароль для нее
username admin secret YYYYY

Включение авторизации, с использованием локальной базы данных пользователей и паролей
SW-DELTACONFIG-1(config)#
line vty 0 4
login local

Для проверки доступности enable режима (#) после ввода этих команд выходим из всех режимов конфигурирования (командой exit или буквой Q в каждом из режимов или сочетанием клавиш Ctrl+Z), оказываемся в первоначальном режиме (обозначается знаком >) и пробуем вновь зайти в привилегированный режим (обозначается знаком

#). На запрос пароля вводим тот, который только что задали.

Если ничего не напутали, то видим примерно следующее:
SW-DELTACONFIG-1>enable
Password:  XXXXX
SW-DELTACONFIG-1#

Проверку удаленного доступа можно осуществить , запустив из командной строки рабочей станции команду telnet 192.168.1.11. Должен появиться диалог запроса логина и пароля.

После того, как убедитесь, что устройство доступно по протоколу Telnet рекомендую настроить защищенный доступ по протоколу SSH. Подробные инструкции приведены в этой статье.

 Шаг 4. Создание Vlan

Создаем Vlan для каждого из отделов и присваиваем им порядковые номера и названия.
SW-DELTACONFIG-1(config)#
vlan 10
name NET_SALES
vlan 20
name NET_ACCOUNT
vlan 100
name NET_ADMIN

Сеть Vlan 1 всегда присутствует на коммутаторе по умолчанию. Она будет использоваться для удаленного управления.

Проверить текущие настройки Vlan можно, выполнив команду sh vlan:

SW-DELTACONFIG-1# show vlan
VLAN Name                 Status    Ports
---- -------------------- -------- -------------------------------
1    default              active    Fa0/1, Fa0/2, /...вырезано.../
10  NET_SALES            active
20  NET_ACCOUNT          active
100  NET_ADMIN            active

Убеждаемся, что все созданные нами сети присутствуют в списке.

Шаг 5. Привязка портов

Соотносим порты доступа коммутатора (access port)  нужным сетям. На коммутаторе из примера 24  порта FastEthernet и 2 порта Gigabit Ethernet. Для подключения пользователей будут использоваться только Fast Ethernet.

Распределим их следующим образом:

  •  первые 6 из них в сеть администраторов (Vlan 100)
  • 12 в сеть отдела продаж (Vlan 10)
  • 6  следующих в сеть для бухгалтерии (Vlan 20).

На каждом интерфейсе для удобства дальнейшего администрирования добавим  примечания командой description. Это обычное текстовое поле, которое никак не влияет на другие настройки.

SW-DELTACONFIG-1(config)#
interface range fa 0/1 – 6
switchport access vlan 100
description NET_ADMIN
interface range fa 0/7 – 18
switchport access vlan 10
description NET_SALES
interface range fa 0/19 – 24
switchport access vlan 20
description NET_ACCOUNT

После этого  рядом с каждым Vlan будут указаны принадлежащие ему порты, а вывод команды sh vlan должен стать примерно таким:
SW-DELTACONFIG-1# show vlan
VLAN Name            Status    Ports
---- ---------------- --------- -------------------------------
1    default          active
10  NET_SALES        active    Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18
20  NET_ACCOUNT      active    Fa0/19, Fa0/20, Fa0/21, Fa0/22, Fa0/23, Fa0/24
100  NET_ADMIN        active    Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5, Fa0/6

Введенными командами мы разделили один физический коммутатор на 4 логических (Vlan 1, Vlan 10, Vlan 20 и Vlan 100).

Важно!
Взаимодействие без использования маршрутизатора будет осуществляться только(!) между портами, принадлежащими одному и тому же

Vlan.
Рабочие станции, подключенные в порты, принадлежащие разным Vlan, не смогут взаимодействовать друг с другом даже если будет настроена адресация из одной сети.

Для взаимодействия всех 4ех сетей необходим маршрутизатор, подключенный к коммутатору с помощью trunk порта. Инструкцию по настройке вы найдете здесь. Отличие trunk интерфейса в том, что при передаче по нему трафика каждый пакет помечается номером Vlan, которому принадлежит. Это позволяет устройствам правильно перенаправлять пакеты. На самом коммутаторе порт настраивается следующим образом:
SW-DELTACONFIG-1(config)#
interface GigabitEthernet 0/1
switchport mode trunk
switchport trunk encapsulation dot1q

Если система не принимает последнюю строчку, то это значит, что режим dot1q – единственно возможный, и он настроен по умолчанию.

После выполнения всех описанных действий для проверки подключите две рабочие станции в порты, принадлежащие одному  Vlan, например с номером 100, установите на них

ip адреса 192.168.100.1 и 192.168.100.2, после чего запустите ping с одной из них на другую. Успешный ответ означает, что все работает как нужно.
Для справки:
Существуют модели коммутаторов 3го уровня модели OSI (Например Cisco 3560), которые объединяют в себе функции коммутатора 2го уровня (access или уровня доступа) и маршрутизатора (устройства 3го уровня).  Устройства 3го уровня используются для передачи данных между различными сетями и руководствуются информацией об ip адресах.

Решение аналогичной задачи организации нескольких Vlan на таком коммутаторе рассмотрено в этой статье)

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
FW-DELTACONFIG-1#write
Building configuration...
[OK]

Перейти к оглавлению

deltaconfig.ru

Базовая настройка Cisco 2960 с нуля

Подключение и настройка Cisco Catalyst 2960 имеет свои нюансы и несколько отличается от подключения оборудования других производителей.


Подключение и настройка Cisco Catalyst 2960 имеет свои нюансы и несколько отличается от подключения оборудования других производителей. Первоначальная настройка потребует наличие фирменного плоского кабеля RJ-45–RS-232 (в голубой оплетке, поставляется с оборудованием) и присутствие на материнской плате компьютера COM-порта, через который будут выполняться процедуры настройки.

nastroyka-cisco-2960-02.png

На материнских платах современных компьютеров COM-порт отсутствует, поэтому чтобы провести настройку потребуется специальный переходник. Компания Cisco в своем оборудовании для консоли использует разъемы Mini–USB. Чтобы провести настройку через порт Mini–USB следует скачать программу cisco usb console driver.

Настройка Гипер Терминала

Если процедура настройки выполняется с использованием операционной системы Windows 7/8, то возникнет проблема отсутствия HyperTerminal. Ее можно быстро решить, если скопировать нужную папку с ОС Windows XP в любой каталог ОС Windows 7/8. В Windows XP папка располагается в каталоге Program Files. Чтобы запустить программу используется файл hypertrm.exe, который располагается в этой же папке. Также может использоваться другая программа – Putty. Кроме подключения к оборудованию Cisco, ее используют для работы с маршрутизаторами, серверами, когда для их подключения нужна настройка SSH.

nastroyka-cisco-2960-03.png

Чтобы выполнить процедуру коммутации кабель нужно подключить в разъем RJ-45, который на передней панели обозначен, как «Console». Дале нужно включить электропитание коммутатора и зайти в HyperTerminal на компьютере. В программе нужно выбрать интерфейс разъема, соответствующий COM1 и его скорость, равную 9600 Б/с. На все последующие вопросы следует выбирать отрицательный ответ «No». Если выбрать в интерфейсе разъема настройка VLAN, то на нем можно будет настроить IP-адресс устройства.

nastroyka-cisco-2960-04.png

Общие принципы настройки Cisco-оборудования

Чтобы обеспечивать высокий уровень безопасности коммутаторы Cisco поддерживают два режима ввода команд:

  • пользовательский – используется для поверки состояния оборудования;
  • привилегированный – применяется для того, чтобы менять конфигурацию коммутатора (он является аналогом режима администратора для Windows или root для UNIX).

Если в строке перед командой есть символ «#», то активный привилегированный режим. Как и в системе UNIX при вводе пароля на экране он отображаться не будет. Чтобы перейти в привилегированный режим используется команда enable, а для выхода disable.

Первоначальная настройка коммутатора. Когда во время первой загрузки установочный мастер выдаст сообщение пошаговой настройки нужно от нее отказаться: Continue with configuration dialog? [yes/no]: no. После этого загрузится пользовательский режим: Switch>

Далее следует перейти в привилегированный режим. По умолчанию пароль отсутствует, поэтому нужно просто нажать на «Enter».

Switch>enable

Password:

Switch#

Чтобы задать настройки, которые относятся ко всему коммутатору, нужно активировать режим глобальной конфигурации. Чтобы настраивать отдельные интерфейсы используют соответствующий режим интерфейса.

Базовые настройки Cisco 2960

Замена имени коммутатора (изначально оно Switch):

Switch# configure terminal

Switch(config)# hostname Switch01 (задается новое имя – Switch01)

Switch01(config)#

Если есть много коммутаторов, то уникальное имя должен иметь каждый из них. В дальнейшем это поможет определить, что конфигурация реализуется именно на том устройстве, что нужно. Длинные имена использовать не рекомендуется, лучше выбирать короткие.

Установка IP-адреса для порта управления коммутатором

Switch01(config)# interface fa0/0 (задается интерфейс для настройки)

Switch01(config-if)# no shutdown (включается интерфейс)

Switch01(config-if)# ip address 192.168.0.1 255.255.255.0 (задается IP-адрес и маска)

Switch01(config-if)# exit (выход из режима конфигурации интерфейса)

Switch01(config)#

Установка пароля привилегированного режима

Switch01(config)# enable secret pass1234 (пароль pass1234)

Switch01(config)# exit

Switch01#

Учитывая, что информация при telnet-соединениях передается в открытом виде, нужно использовать SSH-соединения, которые обеспечат шифрование трафика.

Switch01# clock set 12:00:00 15 April 2015 (установка текущего времени и даты)

Switch01# conf t Switch01(config)# ip domain name geek—nose.com (задается домен, если его нет пишется любой)

Switch01(config)# crypto key generate rsa (генерация RSA-ключа под ssh)

Switch01(config)# ip ssh version 2 (версия ssh-протокола)

Switch01(config)# ip ssh autentification-retries 3 (число попыток подключения по ssh)

Switch01(config)# service password-encryption (сохранение паролей в шифрованном виде)

Switch01(config)# line vty 0 2 (преход к режиму конф-и терминальных линий)

Switch01(config-line)# transport input ssh (подключение только по ssh)

Switch01(config-line)# exec timeout 20 0 (активация автоматического разъединения ssh-сессии через 20 минут)

Switch01(config—line)# end (Выход из режима конфигурирования)

Switch01# copy running-config startup-config (Сохранение настроек)

Это была базовая настройка SSH. Более продвинутая имеет вид:

Switch01# conf t Switch01(config)# aaa new-model (включается ААА–протокол)

Switch01(config)# username root privilege 15 secret pass1234 (создается пользователь root, с максимальным уровнем привилегий – 15, и паролем pass1234)

Switch01(config)# access—list 01 permit 192.168.0 0.0.0.255 (задается правило доступа с названием 01 по ssh для всех хостов сети 192.168.0.0/24; может задаваться конкретный IP-адрес)

Switch01(config)# line vty 0 2 (пееход к режиму конф-и терминальных линий) Switch01(config—line)# privilege level 15 (разрешение входа в привилегированный режим )

Switch01(config—line)# access—class 23 in (привязка созданного правила доступа по ssh к терминальной линии)

Switch01(config—line)# logging synchronous (отключение журнальных сообщений)

Switch01(config—line)# end (выход из режима конфигурирования)

Switch01# copy running-config startup-config (сохранение настроек).

Базовая настройка коммутатора Cisco 2960 на этом завершается. При потребности всегда можно сделать сброс на заводские настройки и выполнить настройки «с нуля».



Возврат к списку

linkas.ru

Настройка Cisco 2960: устанавливаем коммутатор

Компания Cisco — одна из ведущих транснациональных корпораций на рынке телекоммуникационного оборудования.

Продукция компании Cisco получила признание во всем мире из-за своей надежности и неприхотливости.

Содержание:

Настройка Cisco 2960: в этой статье мы выполним базовую настройку коммутатора. Статья будет полезна всем, начинающим работать с продукцией компании Cisco.


Шаг 1. Подключение оборудования Cisco

Настройка оборудования Cisco весьма специфична и несколько отличается от оборудования других производителей.

Например, для выполнения первичных настроек коммутаторов компании Cisco, нам потребуется фирменный плоский кабель RJ-45 – RS-232 голубого цвета (идет в комплекте с оборудованием) и наличие COM-порта на компьютере, с которого будет производиться настройка.

Большинство материнских плат современных настольных и портативных компьютеров не имеют соответствующего разъема. В таком случае необходимо искать переходник.

В последнее время Cisco стала комплектовать оборудование разъемом Mini—USB для консоли.

Для настройки устройства через порт Mini—USB, необходимо скачать cisco usb console driver.


к содержанию ↑

Шаг 2. Настройка ГиперТерминала

Следующей проблемой, с которой вам придется столкнуться – это отсутствие ГиперТерминала (HyperTerminal) в Windows 7/8.

Решением вопроса является копирование папки HyperTerminal c Windows XP (месторасположение каталога – Program Files) в любой удобный каталог Windows 7/8.

Для запуска программы используется файл hypertrm.exe, который можно найти в той же папке.

Либо использовать программу Putty, которую помимо подключения к Cisco-оборудованию можно использовать для подключения к серверам, маршрутизаторам, пр. с помощью SSH-подключения.

Переходим к подключению. На передней панели коммутатора ищем разъем RJ-45 с подписью «Console», и подключаем кабель.

Включаем питание коммутатора.

Заходим на компьютере в HyperTerminal, выбираем интерфейс разъема (COM1), скорость порта – 9600 Б/с, на все дальнейшие вопросы даем отрицательный ответ («No»).


к содержанию ↑

Шаг 3. Общие принципы настройки оборудования Cisco

В целях безопасности на коммутаторах Cisco доступно 2 режима ввода команд: пользовательский режим для проверки состояния коммутатора и привилегированный режим (аналог пользователя root в UNIX или администратора в Windows) для изменения конфигурации коммутатора.

Для пользователей, привыкших работать в UNIX-системах, понять в каком режиме они работают не составит труда.

Для пользователей, работающих в Windows дадим пояснение, — если строка перед командной начинается с символа «#», вы в привилегированном режиме.

То же самое касается ввода пароля, как и в UNIX-системах, пароль, который вводит пользователь не отображается на экране.

Для перехода в привилегированный режим служит команда «enable», без кавычек, а для выхода «disable».

Приступим к первичной настройке коммутатора. При первой загрузке устройства мастер установки предложит выполнить пошаговую настройку, отказываемся от этого шага:

Continue with configuration dialog? [yes/no]: no

После чего оказываемся в пользовательский режиме:

Switch>

Переходим в привилегированный режим, пароль по умолчанию, как правило, отсутствует, поэтому ничего не вводим, а нажимаем «Enter».

Switch> enable

Password:

Switch#

Для задания настроек, касающихся всего коммутатора (задание имени коммутатора, IP-адреса, указание сервера синхронизации времени, пр), используется режим глобальной конфигурации, для настройки отдельных интерфейсов существует режим конфигурации интерфейса.


к содержанию ↑

Шаг 4. Базовая настройка Cisco 2960

1. Изменим имя нашего коммутатора (по умолчанию имя Switch):

Switch# configure terminal

Switch(config)# hostname Switch01 (Задаем имя коммутатора – Switch01)

Switch01(config)#

При наличии множества коммутаторов, рекомендуем в обязательном порядке присваивать уникальные имена для каждого из них.

В последующем это помогает быть уверенным, что конфигурация выполняется именно на нужном устройстве.

Также обращаем ваше внимание на то, что вместо длинных команд как, например, «configure terminal» существуют их короткие аналоги «conf t».

2. Зададим IP-адрес для интерфейса управления коммутатором.

Switch01(config)# interface fa0/0 (указываем интерфейс для настройки)

Switch01(config-if)# no shutdown (включаем интерфейс)

Switch01(config-if)# ip address 192.168.0.1 255.255.255.0 (задаем IP-адрес и маску)

Switch01(config-if)# exit (выходим из режима конфигурации интерфейса)

Switch01(config)#

3. Установим пароль для привилегированного режима:

Switch01(config)# enable secret pass1234 (пароль pass1234)

Switch01(config)# exit

Switch01#

Важно! Установка пароля может быть выполнена двумя командами password и secret. В первом случае пароль хранится в конфигурационном файле в открытом виде, а во втором в зашифрованном. Если использовалась команда password, необходимо зашифровать пароли, хранящиеся в устройстве в открытом виде с помощью команды «service password-encryption» в режиме глобальной конфигурации.

4. Поскольку данные при telnet соединении передаются в открытом виде, для удаленного подключения к коммутатору будем использовать SSH-соединение позволяющее шифровать весь трафик.

Switch01# clock set 12:00:00 15 April 2015 (Устанавливаем точное текущее время дату)

Switch01# conf t

Switch01(config)# ip domain name geek—nose.com (Указываем домен, если домена нет пишем любой)

Switch01(config)# crypto key generate rsa (Выполняем генерацию RSA-ключа для ssh)

Switch01(config)# ip ssh version 2 (Указываем версию ssh-протокола)

Switch01(config)# ip ssh autentification-retries 3 (Задаем кол—во попыток подключения по ssh)

Switch01(config)# service password-encryption (Сохраняем пароли в зашифрованном виде)

Switch01(config)# line vty 0 2 (Переходим в режим конф-и терминальных линий)

Switch01(config-line)# transport input ssh (Разрешаем подключение только по ssh)

Switch01(config-line)# exec timeout 20 0 (Активируем автоматическое разъединение ssh-сессии через 20 минут)

Switch01(config—line)# end (Выходим из режима конфигурирования)

Switch01# copy running-config startup-config (Сохраняем настройки)

Важно! Для выхода из подменю конфигурирования на 1 уровень выше, например, из «config—line» в «config» используется команда «exit». Для полного выхода из режима конфигурирования используйте команду «end».

Выше была описана базовая настройка ssh, с более продвинутой настройкой можно ознакомиться ниже:

Switch01# conf t

Switch01(config)# aaa new-model (Включаем ААА—протокол)

Switch01(config)# username root privilege 15 secret pass1234 (Создаем пользователя root, с максимальным уровнем привилегий – 15, пароль pass1234)

Switch01(config)# access—list 01 permit 192.168.0 0.0.0.255 (Создаем правило доступа с названием 01 регламентирующие право заходить по ssh всем хостам сети 192.168.0.0/24; вместо адреса сети можно указать конкретный IP-адрес.

Внимательно подумайте есть ли необходимость в такой настройке для ваших задач.)

Switch01(config)# line vty 0 2 (Переходим в режим конф-и терминальных линий)

Switch01(config—line)# privilege level 15 (Разрешаем вход сразу в привилегированный режим )

Switch01(config—line)# access—class 23 in (Привязываем созданное правило доступа по ssh к терминальной линии)

Switch01(config—line)# logging synchronous (Очень неудобно когда лог-сообщения коммутатора прерывают ввод команд.

Отключая журнальные сообщения данной командой, коммутатор ждет завершение вводимой команды, а также вывода отчета о ее исполнении, после чего в случае необходимости выводит лог)

Switch01(config—line)# end (Выходим из режима конфигурирования)

Switch01# copy running-config startup-config (Сохраняем настройки)

На этом базовая настройка коммутатора Cisco 2960 завершена.

geek-nose.com

Настройка коммутатора Cisco Catalyst 2960

На это странице вы найдете большую подборку руководств по настройке коммутаторов Cisco Catalyst 2600.

СОДЕРЖАНИЕ:

  • Быстрый сброс Cisco 2960 на заводские настройки
  • Сброс настроек (пароля) на Cisco 2960 с помощью командной строки
  • Настройка коммутатора Cisco Catalyst 2960 с нуля
  • Как прописать на различные порты Cisco определенные VLAN
  • Создание и настройка VLAN в cisco packet tracer на коммутаторе Cisco Catalyst 2960
  • Настройка ssh подключения к Cisco
  • Как настроить ssh на Cisco Switch catalyst 2960 с помощью командной строки
  • Настройка DHCP на роутере Cisco
  • Настройка Cisco 2960 Netflow
  • Конфигурирование Netflow на роутерах Cisco Router и Solar Winds netflow analyzer
  • Настройка удаленного доступа на Cisco через Web интерфейс
  • Настройка времени на Cisco 2960
  • Настройка QoS очередей на платформах коммутаторов Cisco
  • Настройка PoE на cisco 2960

 

Быстрый сброс Cisco 2960 на заводские настройки

Сброс настроек (пароля) на Cisco 2960 с помощью командной строки

Подключите терминал или PC с программой эмуляции терминала к консольному порту маршрутизатора. Если пароль на консольный доступ не установлен, наберите show version и запишите значение конфигурационного регистра в самом конце вывода этой команды. Обычно это 0x2102 or 0x102.

Выключите и включите маршрутизатор. Пошлите сигнал Break в течение первых 30 с после включения. Вы должны увидеть приглашение rommon> в командной строке. Если этого не произошло, значит, Вы не послали маршрутизатору сигнал Break. Полезно, кстати, проверить настройки терминального доступа Вашей программы. Они должны быть такими - 9600, 8-«n»-1, no flow control. Наберите confreg. Ответьте ««y»» на вопрос «Do you wish to change configuration[y/n]?» Отвечайте «n» на все остальные вопросы, пока не увидите вопрос «ignore system config info[y/n]?». Ответьте «y». Отвечайте «n» на все оставшиеся вопросы до тех пор, пока не увидите вопрос «change boot characteristics[y/n]?». Ответьте «y». Ответьте «no» на вопрос «Do you wish to change configuration [y/n]?». Напечатайте reset. После перезапуска ответьте «no» на приглашение начать процедуру Setup.

Наберите enable в строке Router>. Вы должны увидеть Router#. Теперь можете посмотреть на конфигурационный файл (команда show startup-config). Если пароль в нем зашифрован, то наберите copy startup-config running-config. Затем наберите conf t и enable secret [новый пароль]. Нажмите sZ. Наберите copy running config startup-config. Наберите config t. Наберите config register 0x2102 (или то значение, которое вы записали). Нажмите sZ. Наберите reload. После перезагрузки должен начать действовать Ваш новый пароль.

Настройка коммутатора Cisco Catalyst 2960 с нуля

Как прописать на различные порты Cisco определенные VLAN

Создание и настройка VLAN в cisco packet tracer на коммутаторе Cisco Catalyst 2960

Настройка ssh подключения к Cisco

Несмотря на то, что устройства Cisco и имеют GUI интерфейс управления, его никто не использует, так как соединение ssh надежнее и подтверждает, что человек, который по нему подключился как минимум знает, что делает. Еще одним из преимуществ является, то что ssh соединение, это просто консольный ввод команд, а значит он кушает меньше трафика и требует меньшую сетевую пропускную способность, в отличии от графического GUI интерфейса, а это означает, что вы легко сможете управлять устройством из мест, где очень слабый интернет.

Как настроить ssh на Cisco Switch catalyst 2960 с помощью командной строки

Настройка DHCP на роутере Cisco

Настройка динамической раздачи IP адресов с помощью сервера DHCP. Суть настройки. Подробная инструкция конфигурирования маршрутизатора. Необходимые настройки для автоматической выдачи IP адресов.

Настройка Cisco 2960 Netflow

Это видео покажет, как сконфигурировать роутер Cisco для экспорта данных NetFlow используя NetFlow version 9 так же известный как Flexible NetFlow.

Конфигурирование Netflow на роутерах Cisco Router и Solar Winds netflow analyzer

Настройка удаленного доступа на Cisco через Web интерфейс

Включение http сервера на оборудование Cisco.

Заходим в привилегированный режим.

Router> enable

Входим в режим конфигурирования.

Router# configure terminal

Создаем access-list 1, в дальнейшем будет использоваться для доступа с определенного ip-адреса.

Router(config)# access-list 1 permit 172.16.1.1

Заводим пользователея myuser с паролем UserPassWord.

Router(config)# username myuser privilege 15 secret UserPassWord

Включаем http сервер с локальной аутентификацией.

Router(config)# ip http server

Router(config)# ip http authentication local

Разрешаем доступ с определенного ip адреса, используя для этого созданный ранее access-list 1.

Router(config)# ip http access-class 1

Включение https сервера на оборудование Cisco

Заходим в привилегированный режим.

Router> enable

Входим в режим конфигурирования.

Router# configure terminal

Задаем имя устройству mycisco

Router(config)# hostname Bullmastiff

Задаем доменное имя - mydomain.com

mycisco(config)# ip domain-name mydomain.com

Создаем access-list 1, в дальнейшем будет использоваться для доступа с определенного ip-адреса.

mycisco(config)# access-list 1 permit 172.16.1.1

Заводим пользователея myuser с паролем UserPassWord.

mycisco(config)# username myuser privilege 15 secret UserPassWord

Выключаем http сервер и включаем https сервер с локальной аутентификацией.

mycisco(config)# no ip http server

mycisco(config)# ip http secure-server

mycisco(config)# ip http authentication local

Разрешаем доступ с определенного ip адреса, используя для этого созданный ранее access-list 1.

mycisco(config)# ip http access-class 1

Вот и все, настройка доступа через веб интерфейс на оборудование cisco завершена.

Настройка времени на Cisco 2960

Установка времени на Cisco производится из привилегированного режима в который вы попадаете командой enable, далее пишем вот такую команду:

clock set 13:53:00 28 nov 2018 где идет время потом месяц и год.

Сразу же сохраним и в память оборудования эту дату командой clock update-calendar иначе после перезагрузки у вас она слетит на 1993 год, работает данная команда не везде, где ее нет нужно использовать NTP сервер.

Для того, чтобы теперь посмотреть время на Cisco вы можете воспользоваться командой: sh clock

Настройка QoS очередей на платформах коммутаторов Cisco

Настройка PoE на cisco 2960

Варианты настройки:

Switch> enable

Switch# configure terminal

Switch(config)# interface gigabitethernet2/0/1

Switch(config-if)# power inline port poe-ha

Switch(config-if)# end

 

Включение / Выключение PoE на интерфейсе коммутатора:

#configure terminal

#interface interface-id

#power inline {auto | never}

Ввод auto (значение по умолчанию) настраивает интерфейс на автоматическое распознание требуемой мощности и предоставляет питание, если требуемая мощность доступна. Ввод never запрещает PoE на интерфейсе.

 


network.msk.ru

Первоначальная настройка коммутатора Cisco Catalyst 2960G - Geek Notes

Базовые настройки коммутатора Cisco Catalyst 2960G.

Данная статья также подойдет для настройки таких коммутаторов, как Cisco Catalyst 2950, Cisco Catalyst 2960, Cisco Catalyst 3550, Cisco Catalyst 3560, Cisco Catalyst 3560G.

Для первичных настроек коммутаторов Cisco, нам потребуется кабель RJ-45RS-232 и наличие COM-порта в компьютере.

В качестве консоли я буду использоваться ZOC.

Настройки подключения:

При первой загрузке устройства мастер установки предложит выполнить пошаговую настройку, отказываемся от этого шага:

Continue with configuration dialog? [yes/no]: no

После чего оказываемся в пользовательский режиме:

Переходим в привилегированный режим:

Switch> enable 
Password:

Switch

Изменим имя коммутатора

Switch
Switch(config)
C2960G-test(config)

Зададим IP-адрес для интерфейса управления коммутатором.

В моем случае я использую 24 порт коммутатора с управляющим Vlan-ом, в других вариациях можно настроить иные порты.

C2960G-test(config)
C2960G-test(config-vlan)
C2960G-test(config-vlan)
C2960G-test(config-vlan)
C2960G-test(config)
C2960G-test(config)
C2960G-test(config-if)
C2960G-test(config-if)
C2960G-test(config-if)
C2960G-test(config)

Альтернативный вариант:

C2960G-test(config)
C2960G-test(config-if)
C2960G-test(config-if)
C2960G-test(config-if)
C2960G-test(config)

Установим пароль для привилегированного режима

C2960G-test(config)
C2960G-test(config)
C2960G-test

Установка пароля может быть выполнена командами password и secret. В первом случае пароль хранится в конфигурационном файле в открытом виде, а во втором - в зашифрованном. Если использовалась команда password, необходимо зашифровать пароли, хранящиеся в устройстве в открытом виде с помощью команды service password-encryption в режиме глобальной конфигурации.

Установим пароль для входа по telnet

C2960G-test(config)
C2960G-test(config-line)

И разрешим вход по telnet:

C2960G-test(config-line)
C2960G-test(config)

Зашифруем пароли, как я сообщал ранее:

Если ошибиться при наборе чего-либо в консоле или ввести команду на русском, то Cisco попробует это отрезолвить, выключим эту особенность, чтобы не тратить время:

Зададим имя домена:

Зададим IP-адрес DNS сервера:

Чтобы по команде show logging отображалось нормальное время, а не количество дней и прочее пропишем:

Настроим access-list для доступа к свитчу только с указанных IP-адресов:

C2960G-test(config)
C2960G-test(config-std-nacl)

bogachev.biz

Первоначальная настройка коммутатора Cisco

Первоначальная настройка коммутатора Cisco.

December 18, 2009

В этой статье будет рассказано, про то как “запустить” свежекупленный коммутатор Cisco Catalyst 2960/3560/3750. В принципе, данные настройки применимы для всех коммутаторов cisco, данные серии коммутаторов указаны, более, для определенности.

Итак, у нас есть коммутатор Cisco Catalyst 2960 или 3560 или 3750. Внешне он будет выглядеть примерно так как на рис. 1.

На рис. 1 Перед нами “48″ портовый коммутатор который, если быть точным, обозначается как Catalyst 2960-48TC-S.

У него 48 портов 10/100 Ethernet мегабит в сек. (то есть портов которые могут работать как и на 10 мегабит в сек, так и на 100 мегабит сек в зависимости от того сколько мегабит в сек устройство к нему подключено на данный конкретный порт.) Кроме этих 48 портов, в нем дополнительно есть еще два порта 10/100/1000 ( т.е. могущие работать и на 10 и на 100 и на 1000 ) и есть еще два места (слота) куда могут быть установлены так называемые модули SFP. SFP модули бывают и оптические, таким образом покупка за отдельную плату SFP модулей

и их установка в эти слоты позволит нам сделать так, чтоб наш коммутатор можно будет подключить по оптике к другим устройствам. Итого в данном коммутаторе есть 50 портов. То есть можно подключить к нему 50 устройств, 50 – не смотря на то, что есть 52 “дырочки”, так как одновременно работать SFP и медный “гигабитный” порт ПОД НИМ не могут. SFP слева и медный гигабитный справа – могут, но вот SFP “сверху” и “медный” порт под ним не могут.

Если посмотреть сзади (1) на этот коммутатор, то можно обнаружить еще две дырочки. Одна для подключения кабеля питания 220 вольт (2), вторая, похожая на порт к которому можно подключить ETHERNET , но которая таковым не является с надписью CONSOLE (3). Этот порт будет использоваться нами для первоначальной настройки коммутатора.

Внизу на рис. 2 представлен вид этого коммутатора сзади.

Берем голубой кабель который идет в комплекте с коммутатором. И подключаем его к COM порт компьютера. Запускаем программу HyperTerminal на компьютере. Выбираем COM порт к которому подключен коммутатор (обычно COM1), устанавливаем скорость передачи данных 9600 и включаем коммутатор.

При первом запуске коммутатора Cisco Catalyst, так как в нем нет никакой записанной конфигурации он запускает программу setup, которая посредством задания вам множества вопросов на английском языке, вроде бы сама пытается все настроить. Но имхо, этот setup только запутывает все, так что если вы увидите на экране такое:

То лучше сказать “n”, прервать тем самым setup, а потом самому настроить коммутатор с нуля. Тем более это очень просто.

Не бойтесь тут нажимать на что-то – вы ничего не сипортите. Жмите смело “n” и Enter потом.

После чего вы должны увидеть такое :

switch>

Это есть командный режим управления Коммутаторм Cisco. Дальше будем настраивать.

Первым делом нам нужно перейти в так называемый “привилегированный режим”, по сути это режим в котором можно конфигурировать, в отличии от того в котором мы находимся по умолчанию и имеем ограниченные воз0можности по управлению коммутатором. ” Привилегированный режим” это что-то вроде root режима в юникс и входа на windows пол админом. Переход в этот привелигированный режим производится просто – пишем enable и вводим пароль. Пароль по умолчанию на оборудовании cisco это либо “cisco”, либо “Cisco”, либо просто жмем enter не вводя ничего

switch>enable

Password:

switch#

То что у нас изменилось приглашение на ввод и стало таким “switch#” говорит о том, что мы как раз вошли в тот самый привилегированный режим.

Конфигурируем дальше. Нам, по идее, для первоначальной настройки необходимо просто настроить чтоб до коммутатора можно было попасть через телнет. Для этого на Cisco нужно сделать следующее

Задать ip адрес

Настроить параметры входа (в терминах cisco это настроить VTY, задать логин и пароль)

IP адрес для коммутатора cisco обычно задается заданием его на, так называемый, интерфейс VLAN 1. (Так как коммутатор, по идее, сам не обязательно должен иметь ip адрес для того чтоб выполнять свои функции, то ip адрес для его работы и не нужен. Он нужен только для управления им. А так как нет “физических” интерфейсов (портов) с IP адресами на коммутаторе, то такой адрес и задается виртуальному интерфейсу – который и является интерфейс VLAN 1 ).

Для того чтоб настраивать коммутатор Cisco нужно перейти в режим конфигурирования. Делает это заданием команды “configuration terminal”, что обозначает – ” настраиваем с терминала”. Задавать такую длинную команду лень. Мы и не будем. Дело в том, что cisco может сам по начальным буквам слова определять нужную команду (если введенные буквы неоднозначно определяют команду, то cisco его не выполнит, а предупредит об этом). Так что нам достаточно задать “conf t”

switch# conf t

switch(config)#

switch(config)# – обозначает, что мы перешли в режим конфигурирования.

задаем ip адрес:

switch(config)#interface vlan 1 (входим в режим конфигурирования интерфеса VLAN 1)

switch(config-if)#ip address 10.1.1.1 255.255.255.0 (задаем выбранный нами ip)

switch(config-if)#no shutdown (эта команды включает интерфейс, по умолчанию он может быть выключен)

switch(config-if)exit (выходим из режима конфигурирования интерфейса)

switch(config)#exit (выходим из режима конфигурирования )

switch#

Далее нам нужно задать пароль на вход в привилегированный режим

switch# conf t

switch(config)# enable secret пароль_на_вход_в привилегированный режим

switch(config)# exit

switch#

Настраиваем параметры входа

switch# conf t

switch(config)# line VTY 0 4

switch(config-line)# login

switch(config-line)#password пароль_на_вход

switch(config-line)#exit

switch(config)#exit

switch#

Все. Первый сеанс настройки коммутатора Cisco почти завершен. Осталось только сохранить сделанную конфигурацию. Делается это командой “write mem”

switch# write mem

Building configuration

OK

switch#

Сохранились. Можно выдергивать консольный кабель, подключать к коммутатору компы и заходить, при необходимости, на данный коммутатор далее по телнет. При этом, для управления этим коммутатором нам нужно будет знать два пароля – “пароль_на_вход” и “пароль_на_вход_в привилегированный режим”. Запомните их.

Для быстрого конфигурирования коммутора можно сделать следующее:

Скопировать текст ниже в текстовый редактор, задать в нем ip адрес и пароли свои и просто вставить полученный текст (опция “передать главному компьютеру” в hyperterminal по клику правой мыши).

conf t

interface vlan 1

ip address 10.1.1.1 255.255.255.0

no shutdown

exit

enable secret пароль_на_вход_в привилегированный режим

line VTY 0 4

login

password пароль_на_вход

exit

write mem

exit

Знаете ли вы, что:

Крутить настройки Cisco - это занятие коллективов профессионалов, которые называются системными интеграторами. Системный интегратор CTI настроит вам и Cisco и другое сетевое оборудование за кратчайшие сроки по сходной цене.

webhamster.ru

Настройка Cisco Catalyst 2960 — IT Blog

На тесте настрою Cisco Catalyst WS-C2960-24TT-L с прошивкой 12.2(25)FX

Подключимся к коммутатору консольным кабелем.
Из Windows для этого можно использовать программу Putty, из Linux можно использовать Minicom.

При первом подключении если будут задаваться вопросы — отвечаем no.

Перейдем в режим конфигурирования:

enable
configure terminal

Установим пароль на enable:

enable password PASSWORD

Включим хранение паролей в шифрованном виде:

service password-encryption

Если необходимо отменить какую нибудь команду, наберем её еще раз добавив перед ней no, например:

no service password-encryption

По желанию можно указать имя устройству:

hostname IXNFO

Настроим интерфейс для управления коммутатором в отдельном VLAN (я использую 207), ну или во VLAN 1 если у вас один коммутатор, а не большая сеть:

vlan 207
interface vlan 207
ip address 192.168.1.2 255.255.255.0
exit

При необходимости можно указать шлюз чтобы коммутатор можно было увидеть из других сетей (например в сети 192.168.1.0/24 его видно и без шлюза так как ему назначен IP адрес 192.168.1.2):

ip default-gateway 192.168.1.1

Настроим 25 входящий Uplink порт (vlan 207 для управления с tag, а vlan 226 для пользователей тоже с тегом):

interface gigabitEthernet 0/1
switchport trunk allowed vlan 207,226
switchport mode trunk
no shutdown
exit

Укажем vlan 226 без тега для портов клиентов:

interface range fastEthernet 0/1-24
switchport access vlan 226
switchport mode access
no shutdown
exit

Запретим автоматическое переключение порта в режим access или trunk:

interface range fastEthernet 0/1-24
switchport nonegotiate
exit

26 порт тоже настроим для клиентов:

interface gigabitEthernet 0/2
switchport access vlan 226
switchport mode access
no shutdown
exit

Как настраивать порты я описывал также в этой статье:
Настройка портов в коммутаторах Cisco

Настроим access-list со списком IP-адресов с которых будет разрешено управлять коммутатором:

ip access-list standard 11
permit 192.168.1.1
permit 192.168.1.50
exit

Установим пароль для входа по telnet, укажем timeout сессии и укажем созданный access-list чтобы разрешить управлять только указанным в нем IP-адресам:

line vty 0 4
login
password PASSWORD
exec-timeout 5 0
access-class 11 in
exit
line vty 0 15
password PASSWORD
login
exec-timeout 5 0
access-class 11 in
exit

Настроим SNMP (11 означает номер access-list, public — пароль для доступа по SNMP, RO (read only) — доступ только для чтения):

snmp-server community public RO 11

Настроим синхронизацию времени с NTP сервером и период обновления в секундах:

ntp server 192.168.1.1 version 2 source vlan 207
ntp clock-period 36028811
ntp max-associations 1
service timestamps log datetime localtime

По желанию можно отключить web интерфейс:

no ip http server

Любой из команд сохраним конфигурацию:

copy running-config startup-config
write

Пример просмотра текущей конфигурации и сохраненной:

show running-config
show running-config interface gigabitEthernet 0/1
show configuration

ixnfo.com

Отправить ответ

avatar
  Подписаться  
Уведомление о