Port channel: Недопустимое название — Xgu.ru

Содержание

Тренинг Cisco 200-125 CCNA v3.0. День 38. Протокол EtherChannel для 2 уровня OSI

Сегодня мы рассмотрим работу протокола агрегирования каналов Layer 2 EtherChannel для 2 уровня модели OSI. Этот протокол не слишком отличается от протокола 3-го уровня, однако прежде чем начать изучение Layer 3 EtherChannel, я должен ознакомить вас с несколькими концепциями, так что к третьему уровню мы перейдем позже. Мы продолжаем следовать расписанию курса CCNA, так что сегодня рассмотрим раздел 1.5 «Настройка, проверка и неполадки Layer 2/3 EtherChannel» и подразделы 1.5а «Статический EtherChannel», 1.5b «Протокол PAGP» и 1.5с «Открытый стандарт IEEE- LACP».

Перед тем, как идти дальше, мы должны понять, что такое EtherChannel. Предположим, у нас имеется свитч А и свитч В, избыточно соединенные тремя линиями связи. Если использовать протокол STP, две лишних линии будут логически заблокированы, чтобы предотвратить образование петель.

Допустим, у нас имеются порты FastEthernet, обеспечивающие скорость трафика 100 Мбит/с, так что суммарная пропускная способность составляет 3 х 100 = 300 Мбит/с. Мы оставляем всего один канал связи, из-за чего она снизится до 100 Мбит/с, то есть в данном случае STP ухудшит характеристики сети. Кроме того, 2 лишних канала будут зря простаивать.

Для предотвращения подобного разработчик KALPANA – компания, которая создала свитчи Cisco Catalist и которую позже купила Cisco, в 1990-х разработала технологию под названием EtherChannel.

В нашем случае эта технология превращает три отдельных канала связи в один логический канал пропускной способностью 300 Мбит/с.

Первый режим технологии EtherChannel – это ручной, или статический режим. При этом свитчи ничего не будут делать при любых условиях передачи, полагаясь на то, что все ручные настройки параметров работы сделаны правильно. Канал просто включается и работает, полностью доверяя настройкам администратора сети.

Второй режим – это проприетарный протокол агрегирования каналов Cisco PAGP, третий – IEEE стандартный протокол агрегирования каналов LACP.

Для того, чтобы эти режимы работали, EtherChannel необходимо сделать доступным. Статическую версию этого протокола очень легко активировать: нужно зайти в настройки интерфейса свитча и ввести команду channel-group 1 mode .

Если у нас есть свитч А с двумя интерфейсами f0/1 и f0/2, мы должны войти в настройки каждого порта и ввести данную команду, причем номер группы интерфейсов EtherChannel может иметь значение от 1 до 6, главное, чтобы это значение было одинаково для всех портов свитча. Кроме того, порты должны работать в одинаковых режимах: оба в режиме access или оба в режиме trunk и иметь одинаковые native VLAN или разрешенные VLAN.

Агрегирование EtherChannel сработает только в случае, когда группа каналов будет состоять из одинаково настроенных интерфейсов.

Соединим свитч А двумя линиями связи со свитчем В, который также имеет два интерфейса f0/1 и f0/2. Эти интерфейсы образуют свою группу. Настроить их для работы в EtherChannel можно с помощью той же команды, причем номер группы не имеет значения, поскольку они расположены на локальном свитче. Можно обозначить эту группу номером 1, и всё будет работать. Однако запомните – чтобы оба канала работали без проблем, все интерфейсы должны быть настроены совершенно одинаково, на один режим – access или trunk. После того, как вы зашли в настройки обоих интерфейсов свитча А и свитча В и ввели команду channel-group 1 mode on, агрегирование каналов EtherChannel будет выполнено.

Оба физических интерфейса каждого из свитчей будут работать как один логический интерфейс. Если просмотреть параметры STP, мы увидим, что у свитча А будет показан один общий интерфейс, сгруппированный из двух физических портов.

Перейдем к рассмотрению PAGP – протоколу агрегирования портов, разработанного компанией Cisco.

Представим ту же картину – два свитча А и В, каждый с интерфейсами f0/1 и f0/2, соединенные двумя линиями связи. Для включения PAGP используется та же команда channel-group 1 mode с параметрами <desirable/auto>. В ручном статическом режиме вы просто вводите команду channel-group 1 mode on на всех интерфейсах, и агрегирование начинает работать, здесь же нужно указывать параметр desirable либо auto. Если ввести команду channel-group 1 mode со знаком ?, система выдаст подсказку с вариантами параметров: on, desirable, auto, passive, active.

Если на обоих концах линии связи вы введете одинаковую команду channel-group 1 mode desirable, режим EtherChannel будет активирован. Аналогично произойдет, если на одном конце канала интерфейсы будут настроены командой channel-group 1 mode desirable, а на другом – командой channel-group 1 mode auto.

Однако если интерфейсы на обоих концах каналов настроить на auto командой channel-group 1 mode auto, агрегации каналов не произойдет. Поэтому запомните – если вы хотите использовать EtherChannel по протоколу PAGP, интерфейсы хотя бы одной из сторон должны находится в состоянии desirable.

При использовании открытого протокола LACP для агрегирования каналов используется та же команда channel-group 1 mode с параметрами <active/passive>.

Возможные комбинации настроек на обеих сторонах каналов таковы: если интерфейсы настроены на режим active или одна сторона на active, а другая на passive — режим EtherChannel будет работать, если обе группы интерфейсов настроить на passive, агрегирования каналов не произойдёт. Нужно помнить, что для организации объединения каналов по протоколу LACP необходимо, чтобы хотя бы одна из групп интерфейсов находилась в состоянии active.

Давайте попробуем ответить на вопрос: если у нас есть соединенные линиями связи свитчи А и В, причем интерфейсы одного свитча находятся в состоянии active, а другого в состоянии auto или desirable, будет ли работать EtherChannel?

Нет, не будет, потому что в сети должен действовать одинаковый протокол – либо PAGP, либо LACP, поскольку они не совместимы друг с другом.

Рассмотрим несколько команд, используемых для организации EtherChannel. В первую очередь вам нужно назначить номер группы, он может быть любым. Для первой команды channel-group 1 mode в качестве option можно выбрать 5 параметров: on, desirable, auto, passive или active.
В подкомандах интерфейса мы используем ключевое слово channel-group, но если, например, вы хотите задать балансировку нагрузки, используется слово port-channel. Рассмотрим, что представляет собой балансировка нагрузки.

Предположим, у нас имеется свитч А с двумя портами, которые соединены с соответствующими портами свитча В. К свитчу В подсоединены 3 компьютера – 1,2,3, а к свитчу А – один компьютер № 4.

Когда трафик перемещается от компьютера №4 к компьютеру №1, свитч А начнет передавать пакеты по обеим линиям связи. Метод балансировки нагрузки использует хеширование MAC-адреса отправителя таким образом, что весь трафик четвертого компьютера будет проходить только по одной из двух линий связи. Если мы подсоединим к свитчу А компьютер №5, благодаря балансировке нагрузки весть трафик этого компьютера будет перемещаться только по одной, нижней линии связи.

Однако это не типичная ситуация. Допустим, у нас есть облако-интернет и устройство, к которому подсоединен свитч А с тремя компьютерами. Интернет-трафик будет направляться к свитчу с MAC-адресом данного устройства, то есть с адресом конкретного порта, потому что это устройство является шлюзом. Таким образом, весь исходящий трафик будет иметь MAC-адрес данного устройства.

Если перед свитчем А расположить свитч В, соединенный с ним тремя линиями связи, то весь трафик свитча В в направлении свитча А устремится по одной из линий, что не соответствует нашим целям. Поэтому нам нужно задать параметры балансировки для данного свитча.

Для этого используется команда port-channel load-balance , где в качестве параметра option используется IP-адрес назначения. Если это будет адрес компьютера №1, трафик устремится по первой линии, если №3 – по третьей, а если указать IP-адрес второго компьютера, то по средней линии связи.

Для этого в команде используется ключевое слово port-channel в режиме глобальной конфигурации.

Если вы хотите посмотреть, какие линки задействованы в канале и какие протоколы используются, то в привилегированном режиме нужно ввести команду show etherchannel summary. Посмотреть настройки балансировки нагрузки можно с помощью команды show etherchannel load-balance.

Теперь рассмотрим все это в программе Packet Tracer. У нас имеется 2 свитча, соединенные двумя линками. STP начнет свою работу, и один из 4-х портов будет заблокирован.

Зайдем в настройки SW0 и введем команду show spanning-tree. Мы видим, что STP работает и можем проверить Root ID и Bridge ID. Использовав ту же команду для второго свитча, мы увидим, что первый свитч SW0 является корневым, так как у него, в отличие от SW1, значения идентификаторов Root и Bridge совпадают. Кроме того, здесь имеется сообщение о том, что SW0 является корневым – «This bridge is the root».

Оба порта корневого свитча находятся в состоянии Designated, заблокированный порт второго свитча обозначен как Alternative, а второй – как root-порт. Вы видите, как STP безупречно выполняет всю необходимую работу, автоматически настраивая соединение.

Активируем протокол PAGP, для этого в настройках SW0 последовательно введем команды int f0/1 и channel-group 1 mode с одним из 5-ти возможных параметров, я использую desirable.

Вы видите, что линейный протокол сначала отключился, а затем снова включился, то есть сделанные изменения вступили в силу и был создан интерфейс Port-channel 1.

Теперь перейдем к интерфейсу f0/2 и введем ту же команду channel-group 1 mode desirable.

Вы видите, что теперь порты верхнего линка обозначены зеленым маркером, а порты нижнего – оранжевым. В данном случае не может быть смешанного режима портов desirable – auto, потому что все интерфейсы одного свитча должны быть настроены одинаковой командой. Режим auto может быть использован на втором свитче, но на первом все порты должны работать в одинаковом режиме, в данном случае это desirable.

Зайдем в настройки SW1 и используем команду для диапазона интерфейсов int range f0/1-2, чтобы не вводить вручную команды отдельно для каждого из интерфейсов, а настроить оба одной командой.

Я использую команду channel-group 2 mode, но могу использовать любое число от 1 до 6 для обозначения группы интерфейсов второго свитча. Поскольку противоположная сторона канала настроена на режим desirable, интерфейсы этого свитча должны быть в режиме desirable или auto. Я выбираю первый параметр, набираю channel-group 2 mode desirable и нажимаю «Ввод».

Мы видим сообщение о том, что был создан канальный интерфейс Port-channel 2, а порты f0/1 и f0/2 последовательно перешли из состояния down в состояние up. Далее следует сообщение, что интерфейс Port-channel 2 перешел в состояние up и что линейный протокол этого интерфейса также включился. Теперь у нас сформировался агрегированный канал EtherChannel.

В этом можно убедиться, перейдя к настройкам свитча SW0 и введя команду show etherchannel summary. Вы видите различные флаги, которые мы рассмотрим позже, и далее группу 1, использующую 1 канал, число агрегаторов также равно 1. Po1 означает PortChannel 1, а обозначение (SU) расшифровывается как S – флаг уровня 2, U – используется. Далее указан используемый протокол PAGP и физические порты, агрегированные в канал – Fa0/1 (P) и Fa0/2 (P), где флаг P указывает на то, что эти порты входят в состав PortChannel.

Я использую те же команды для второго свитча, и в окне CLI появляется аналогичная информация для SW1.

Я ввожу в настройках SW1 команду show spanning-tree, и вы можете увидеть, что PortChannel 2 представляет собой один логический интерфейс, причем его стоимость по сравнению со стоимостью двух отдельных портов 19 снизилась и теперь равна 9.

Проделаем то же самое с первым свитчем. Вы видите, что параметры Root не изменились, но теперь между двумя свитчами вместо двух физических линков имеется один логический интерфейс Po1-Po2.

Попробуем заменить PAGP протоколом LACP. Для этого в настройках первого свитча я использую команду для диапазона интерфейсов int range f0/1-2. Если я сейчас введу команду channel-group1 mode active для включения LACP, она будет отвергнута, потому что порты Fa0/1 и Fa0/2 уже являются частями канала, использующего другой протокол.

Поэтому я должен сначала ввести команду no channel-group 1 mode active и только после этого использовать команду channel-group1 mode active. Давайте проделаем то же самое со вторым свитчем, сначала введя команду no channel-group 2, а затем команду channel-group 2 mode active. Если посмотреть параметры интерфейсов, видно, что Po2 снова включился, но он по прежнему находится в режиме протокола PAGP. Это не верно, потому что у нас сейчас действует LACP, и в данном случае имеет место некорректное отображение параметров программой Packet Tracer.

Для устранения этого несоответствия я использую временное решение – создание другого PortChannel. Для этого я набираю команды int range f0/1-2 и no channel-group 2, а затем команду channel-group 2 mode active. Давайте посмотрим, как это повлияет на первый свитч. Я ввожу команду show etherchannel summary и вижу, что Po1 снова показан как использующий PAGP. Это проблема симуляции Packet Tracer, потому что сейчас PortChannel отключен и у нас вообще не должно быть канала.

Я снова перехожу в окно CLI второго свитча и ввожу команду show etherchannel summary. Сейчас Po2 показан с индексом (SD), где D означает down, то есть канал не работает. Технически PortChannel здесь присутствует, но не используется, потому что с ним не связан ни один порт.
Я ввожу в настройках первого свитча команды int range f0/1-2 и no channel-group 1, а затем создаю новую канальную группу, на этот раз под номером 2, с помощью команды channel-group 2 mode active. Затем я проделываю то же самое в настройках второго свитча, только теперь канальная группа получает номер 1.

Теперь на первом свитче создана новая группа Port Channel 2, а на втором — Port Channel 1. Я просто поменял местами названия групп. Как видите, технически я создал новый Port Channel на втором свитче, и теперь он отображается с корректным параметром – после ввода команды show etherchannel summary мы видим, что Po1 (SU) использует LACP.

Точно такую же картину мы видим в окне CLI свитча SW0 – новая группа Po2 (SU) работает под управлением LACP.

Рассмотрим разницу между интерфейсом в состоянии active и интерфейсом, который всегда находится в состоянии on. Я создам новую канальную группу для свитча SW0 командами int range f0/1-2 и channel-group 3 mode on. Перед этим необходимо удалить канальные группы 1 и 2 командами no channel-group 1 и no channel-group 2, иначе при попытке использовать команду channel-group 3 mode on система выдаст сообщение о том, что интерфейс уже задействован для работы с другим канальным протоколом.

Аналогично поступаем со вторым свитчем – удаляем channel-group 1 и 2 и создаем группу 3 командой channel-group 3 mode on. Теперь зайдем в настройки SW0 и используем команду show etherchannel summary. Вы увидите, что новый канал Po3 уже запущен в работу и не требует никаких предварительных операций, как PAGP или LACP.

Он включается сразу, без отключения и последующего включения портов. Использовав ту же команду для SW1, мы увидим, что и здесь Po3 не использует никакого протокола, то есть у нас создан статический EtherChannel.

Cisco утверждает, что для широкой доступности сетей нужно забыть о PAGP и использовать статический EtherChannel как более надежный способ агрегирования каналов.
Как мы осуществляем балансировку нагрузки? Я возвращаюсь в окно CLI свитча SW0 и ввожу команду show etherchannel load-balance. Вы видите, что балансировка нагрузки произведена на основе MAC-адреса источника source MAC address.

Обычно балансировка использует именно этот параметр, но иногда это не соответствует нашим задачам. Если мы хотим изменить этот способ балансировки, нужно войти в режим глобальной конфигурации и ввести команду port-channel load-balance, после чего система выдаст подсказки с возможными параметрами для данной команды.

Если указать параметр port-channel load-balance src-mac, то есть указать MAC-адрес источника, будет включена функция хеширования, которая потом сообщит, какой из портов, являющийся частью данного канала EtherChannel, должен использоваться для передачи трафика. Каждый раз, когда адрес источника будет таким же, система будет использовать этот конкретный физический интерфейс для отправки трафика.


Спасибо, что остаётесь с нами. Вам нравятся наши статьи? Хотите видеть больше интересных материалов? Поддержите нас оформив заказ или порекомендовав знакомым, 30% скидка для пользователей Хабра на уникальный аналог entry-level серверов, который был придуман нами для Вас: Вся правда о VPS (KVM) E5-2650 v4 (6 Cores) 10GB DDR4 240GB SSD 1Gbps от $20 или как правильно делить сервер? (доступны варианты с RAID1 и RAID10, до 24 ядер и до 40GB DDR4).

Dell R730xd в 2 раза дешевле? Только у нас 2 х Intel TetraDeca-Core Xeon 2x E5-2697v3 2.6GHz 14C 64GB DDR4 4x960GB SSD 1Gbps 100 ТВ от $199 в Нидерландах! Dell R420 — 2x E5-2430 2.2Ghz 6C 128GB DDR3 2x960GB SSD 1Gbps 100TB — от $99! Читайте о том Как построить инфраструктуру корп. класса c применением серверов Dell R730xd Е5-2650 v4 стоимостью 9000 евро за копейки?

Настройка LACP на Distributed Switch в VMware vSphere - Geek Notes

Выполняем настройку групп агрегации каналов (Link Aggregation Groups) с использованием LACP на распределённом коммутаторе vSphere (vSphere Distributed Switch)

В данной статье мы рассмотрим пример настройки агрегации для VMware vSAN.

Агрегация каналов позволяет объединять несколько сетевых подключений параллельно для увеличения пропускной способности и обеспечения избыточности. Когда группирование сетевых адаптеров настроено с помощью LACP, происходит распределение нагрузки сети vSAN по нескольким аплинкам. Однако это происходит на сетевом уровне, а не через vSAN.

Ознакомиться с общей информацией об агрегировании каналов можно в одной из моих статей про Агрегирование каналов Cisco

В то время как объединение каналов является очень свободным термином, для целей этой статьи основное внимание будет уделяться протоколу управления объединением каналов или LACP. В то время как IEEE имеет свой собственный стандарт LACP 802.3ad, некоторые производители разработали проприетарные типы LACP. Например, PAgP (протокол агрегации портов) похож на LAG, но является собственностью Cisco. Таким образом, руководство поставщика имеет решающее значение, и следует всегда придерживаться лучших практик поставщиков.

Основным выводом при реализации LACP является то, что он использует отраслевой стандарт и реализован с использованием port-channel. Там может быть много алгоритмов хеширования. Политика группы портов vSwitch и конфигурация канала порта (хэш) должны совпадать и соответствовать.

Добавляем LAG

Переходим в наш распределённый коммутатор и создаём новую группу агрегации. Указываем имя, количество портов агрегации, режим работы, а так же режим балансировки.

Активный режим (Active) - устройства немедленно отправляют сообщения LACP, когда порт подходит. Конечные устройства с включенным LACP отправляют/получают кадры, называемые сообщениями LACP, друг другу для согласования создания LAG.

Пассивный режим (Passive) - переводит порт в состояние пассивного согласования, в котором порт отвечает только на полученные сообщения LACP, но не инициирует согласование.

Обратите внимание, что если хост и коммутатор находятся в пассивном режиме, LAG не будет инициализирован, так как нет активной части, которая инициировала бы соединение.

Назначаем LAG для PortGroup

Назначаем созданную группу агрегации необходимой порт группе и переводим LAG в режим ожидания (Standby).

При подтверждение изменений появится предупреждающее окно, о том, что использование комбинации активных аплинков и LAG в режиме ожидания поддерживается только для переноса физических адаптеров между LAG и автономными аплинками. Нажимаем ОК.

Проверяем, что LAG добавился.

Настраиваем адаптеры на хостах

Переходим в меню “Добавление и редактирование хостов” нашего распределённого коммутатора, выбираем пункт “Редактирование хостов”, добавляем хосты, которые подключены к данному distributed switch.

Назначаем LAG-порты к соответствующим vmnic. По аналогии назначаем порты для других хостов.

Создаём PortChannel на Cisco

Тема конфигурации PortChannel затронута в одной из моих статей по настройке объединения портов (bonding) Cisco IOS и CentOS LACP

Рассмотрим пример нашего тестового стенда:

4900m(config)
4900m(config-if-rang)
4900m(config-if-rang)
Creating a port-channel interface Port-channel 2
4900m(config-if-range)

interface Port-channel2
description slv-esxi01[vSAN-LAG]
switchport
switchport access vlan 2
switchport mode access
spanning-tree portfast trunk
spanning-tree bpdufilter enable

interface TenGigabitEthernet1/1
description slv-esxi01[vSAN-LAG]_Uplink1
switchport access vlan 2
switchport mode access
channel-group 2 mode active
spanning-tree portfast trunk
spanning-tree bpdufilter enable

interface TenGigabitEthernet1/2
description slv-esxi01[vSAN-LAG]_Uplink2
switchport access vlan 2
switchport mode access
channel-group 2 mode active
spanning-tree portfast trunk
spanning-tree bpdufilter enable

Проверьте какой алгоритм балансировки используется на физическом коммутаторе.

4900m
port-channel load-balance src-dst-ip

Проверяем состояние PortChannel.

C4900m
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 4
Number of aggregators: 4

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
2 Po2(SU) LACP Te1/1(P) Te1/2(P)
3 Po3(SU) LACP Te1/3(P) Te1/4(P)
4 Po4(SU) LACP Te1/5(P) Te1/6(P)
5 Po5(SU) LACP Te1/7(P) Te1/8(P)

Переводим LAG в активный режим

Возвращаемся к настройкам нашего распределённого коммутатора, переходим в настройки порт группы и переводим LAG в режим Active, а автономные аплинки - в раздел неиспользуемых.

Обратите внимание, что когда LAG выбран, как основной аплинк, режим балансировки порт группы наследуется от режима балансировки, указанного в LAG, о чём нас дополнительно информируют.

Ещё раз проверяем топологию сети.

Особое внимание хочу уделить тому факту, что данная настройка не увеличивает пропускную способность, а выполняет роль отказоустойчивости и балансировки нагрузки.

Источники:
LACP Support on a vSphere Distributed Switch

VMware® vSAN Network Design

ASA и Etherchannel | ciscomaster.ru

Для подключения к коммутатору используем Etherchannel со следующей конфигурацией:
ASA

interface GigabitEthernet0/0 channel-group 1 mode on ! interface GigabitEthernet0/1 channel-group 1 mode on ! interface Port-channel1 port-channel load-balance src-mac no shu ! interface Port-channel1.182 description LAN vlan 182 nameif inside security-level 100 ip address 192.168.252.18 255.255.255.252

WS-C3560X-48

interface Port-channel12 description --3560xUG1 moscow5520-- switchport trunk encapsulation dot1q switchport mode trunk ! interface GigabitEthernet0/28 description --3560xUG1 moscow5520-- switchport trunk encapsulation dot1q switchport mode trunk channel-group 12 mode on no shu ! interface GigabitEthernet0/29 description --3560xUG1 moscow5520-- switchport trunk encapsulation dot1q switchport mode trunk channel-group 12 mode on no shu

Проверим что etherchannel успешно собрался:
ASA

ciscoasa# show port-channel summary Flags: D - down P - bundled in port-channel I - stand-alone s - suspended H - Hot-standby (LACP only) U - in use N - not in use, no aggregation/nameif M - not in use, no aggregation due to minimum links not met w - waiting to be aggregated Number of channel-groups in use: 1 Group Port-channel Protocol Span-cluster Ports ------+-------------+---------+------------+------------------------------------ 1 Po1(U) - No Gi0/0(P) Gi0/1(P)
ciscoasa# show port-channel brief Channel-group listing: ----------------------- Group: 1 ---------- Span-cluster port-channel: No Ports: 2 Maxports = 16 Port-channels: 1 Max Port-channels = 48 Protocol: ON Minimum Links: 1 Load balance: src-mac
3560xUG1#show etherchannel 12 summary Flags: D - down P - bundled in port-channel I - stand-alone s - suspended H - Hot-standby (LACP only) R - Layer3 S - Layer2 U - in use f - failed to allocate aggregator M - not in use, minimum links not met u - unsuitable for bundling w - waiting to be aggregated d - default port Number of channel-groups in use: 9 Number of aggregators: 9 Group Port-channel Protocol Ports ------+-------------+-----------+----------------------------------------------- 12 Po12(SU) - Gi0/28(P) Gi0/29(P)
3560xUG1#show etherchannel load-balance EtherChannel Load-Balancing Configuration: src-mac

Обратите внимание, что на обоих устройствах должен быть выставлен одинаковый Load balance. В нашем случае это src-mac, метод по умолчанию для коммутатора.

Записки Админа

Понятно что MBR уже устарел морально, но Windows по умолчанию размечает диск (при установке), именно в MBR. Сейчас, стоимость дисков 3 и более Тб приравнивается к смешной, поэтому и пишу эту статью. Начинаем процесс установки Windows как обычно, доходим до выбора диска куда ставить, и жмем: Shift+F10 У нас открывается командная строка, куда мы последовательно… Читать далее »

Раздел: Windows

Зачастую, имеется .pfx сертификат, который требуется установить на linux web-server, но для этого его нужно сконвертировать в удобоваримый вариант, начнем-с. 1. Экспортируем приватный ключ из .PFX сертификата: $ openssl pkcs12 -in filename.pfx -nocerts -out key.pem ВАЖНО! нужно обязательно задать PEM pass phrase, иначе ключ не экспортируется нормально. 2. Экспортируем сертификат из .PFX сертификата: $ openssl… Читать далее »

Раздел: Certeficate Linux, UNIX

Есть разные причины, зачем это нужно, но итог один, нужно банить, начнем. Для начала идем на сервер Exchange и открываем EMS. Включаем функцию фильтрации отправителей: Set-SenderFilterConfig -Enabled $true Включаем функцию фильтрации отправителей для внешних подключений: Set-SenderFilterConfig -ExternalMailEnabled $true Теперь можно заняться блокировкой отправителей, по email адресу: Set-SenderFilterConfig -BlockedSenders [email protected],[email protected],[email protected] Или по домену отправителя Set-SenderFilterConfig -BlockedDomains… Читать далее »

Раздел: Echange Windows

Столкнулся с проблем, когда outlook внутри организации работает без проблем, но стоит попробовать подключиться из вне, outlook циклично начинает просить пароль. При этом, в настройках «мобильного outlook» (outlook anywhere), метод проверки подлинности, стоит — согласование Но если посмотреть в настройках outlook, там будет «NTLM» Решение пришло в голову неожиданно. Идем на сервер Exchange 2013, запускаем… Читать далее »

Раздел: Echange Windows

Часто бывает, когда сервер телефонии работает не первый год, свободное место заканчивается, и найти куда оно делось задача не тривиальная. Но можно поставить ПО которое нам в этом поможет, итак по порядку. df -h получим примерно следующий вывод. Filesystem > отображает текущий каталог Size > размер Used > размер использованного Avail > доступное дисковое пространство… Читать далее »

Раздел: Asterisk (FreePBX) Linux, UNIX VOICE

Из всех бесплатных сертификатов, жив остался только Let’s Encrypt, но его особенность в том, что сертификат выдается сроком на 3 месяца. Итак, нам нужно поставить сертификат, и сделать автоматическую выдачу при завершении срока сертификации. В предыдущей статье, мы настроили Reverse Proxy с публикацией HTTPS траффика, теперь приступим к настройке сертификатов, поехали: echo ‘deb http://ftp.debian.org/debian jessie-backports main’… Читать далее »

Раздел: Apache2 Certeficate Linux, UNIX

Решил я поднять реверс прокси на апаче, да чтобы работала автовыдача сертификатов Let’s Encrypt. За основу берем что у нас стоит чистый Debian GNU/Linux 8 (jessie) Ну что-ж, поехали. aptitude install -y build-essential aptitude install -y libapache2-mod-proxy-html libxml2-dev aptitude install -y apache2 После чего активируем следующие модули: a2enmod proxy a2enmod proxy_http a2enmod proxy_ajp a2enmod rewrite a2enmod… Читать далее »

Раздел: Apache2 Certeficate Linux, UNIX

Стандартная проблема в доменной среде Windows, когда в какой-то момент ПК пользователя выдает ошибку типа: Вариантов лечения масса, один из самых простых, перезавести комп в домен. Но решение не всем подходит, потому есть и другие варианты. Варивант 1: Это самый простой, но не самый быстрый и удобный способ. Открываем на любом контроллере домена оснастку Пользователи… Читать далее »

Раздел: Domain Controller Windows Решение общих проблем

В интернете нереальное количество мануалов, но как оказалось, большинство из них не работаю, не полные и прочее остальное. Итак, берем за основу что Asterisk настроен, TFTP стоит, DHCP есть и вещает в сеть. Первым делом настраиваем DHCP-сервер для выдачи информации о сервере Cisco телефонам. Нас интесует опция 66 и 150, там прописываем IP-адрес сервера TFTP.… Читать далее »

Раздел: Asterisk (FreePBX) VOICE

Столкнулся с проблемой, что после переноса сайт на wordpress 4.7.1 не работают никакие страницы кроме главной и админки. Проблема эта старая и известная, решение просто: Требуется зайти в админку — Настройки — Постоянные ссылки и пересохранить настройки. В 99% случаев это решение поможет, но если у вас Apache и такое решение не помогло, то: Требуется… Читать далее »

Раздел: Linux, UNIX WEB WordPress

Заметки о кошководстве :): EtherChannel между коммутаторами

EtherChannel позволяет объединить несколько физических соединений между двумя устройствами в виртуальные. Это дает нам прирост пропускной способности, защищает от возникновения петель 2 уровня и добавляет отказоустойчивости. EtherChannel может быть настроен статически (mode on) или же с использованием протоколов PAgP/LACP. Рассмотрим пример настройки etherchannel между двумя коммутаторами с использованием LACP:
Топология:
Настройка:
3560:
SW1(config)# interface range FastEthernet0/1-3
SW1(config-if-range)# channel-protocol lacp
SW1(config-if-range)# channel-group 1 mode active

SW1(config)# interface Port-channel 1
SW1(config-if)# switchport trunk encapsulation dot1q
SW1(config-if)# switchport mode trunk

SW1(config)# port-channel load-balance src-dst-mac
 
2960:
SW2(config)# interface range FastEthernet0/1-3
SW2(config-if-range)# channel-protocol lacp
SW2(config-if-range)# channel-group 1 mode active

SW2(config)# interface Port-channel 1
SW2(config-if)# switchport mode trunk

SW2(config)# port-channel load-balance src-dst-mac

Проверяем:
show portchannel {summary}

Послесловие:
  • EtherChannel - не удваивает(утраивает) скорость, т.к. фреймы будут распределяться по физическим линиям с учетом выбранного метода (src-ip, dst-ip, src-dst-ip, src-mac, dst-mac, src-dst-mac).
  • Для построения etherchannel все входящие в него порты должны иметь одинаковые настройки, скорость, тип среды.
  • Ограничение на количество портов в один portchannel, не запрещает вам ввести большее количество портов. просто в этом случае такие порты не будут задействованы до отказа активных портов. Дополнительно можно указать какие из портов должны быть активными.
  • EtherChannel можно строить как на L2 портах так и на L3 портах.
  • EtherChannel может быть задействован между коммутаторами и маршрутизаторами, сетевыми хранилищами, серверами и т.д.
Скачать: pkt-файл
Ссылки:

4 типа каналов порта и время их использования :: packetmischief.ca

На днях я просматривал записанный контент с Cisco Live! и я видел упоминание еще об одной реализации каналов портов (на этот раз под названием Enhanced Virtual Port Channels). Я подумал, что это будет хорошая запись в блоге, чтобы описать различия каждого из них, где они используются и какие платформы поддерживаются.

Равнинный канал старого порта⌗

Раньше, до того, как появились все различные разновидности каналов порта, существовал оригинальный канал порта.Это также называется Etherchannel или Link Aggregation Group (LAG) в зависимости от того, с какой документацией или поставщиком вы имеете дело. Этот канал порта использует протокол агрегации и управления каналом (LACP) или, в мире Cisco, также может использовать протокол агрегации портов (PAgP), чтобы сигнализировать об установлении канала между двумя устройствами. Канал порта выполняет несколько функций:

  1. Увеличивает доступную пропускную способность между двумя устройствами.
  2. Создает один логический путь из нескольких физических путей.Поскольку протокол связующего дерева (STP) работает на логическом канале, а не на физических каналах, все физические каналы могут находиться в состоянии пересылки.

Теперь, что касается №1, важно различать полосу пропускания и пропускную способность. Если у нас есть два коммутатора, соединенных вместе (1) каналом 1 ГБ, наша полоса пропускания составляет 1 ГБ, как и наша максимальная пропускная способность. Если мы подключим больше каналов, так что у нас будет (4) канала по 1 ГБ, и поместим их в канал порта, наша полоса пропускания теперь составит 4 ГБ, но наша максимальная пропускная способность останется 1 ГБ.Это почему?

Когда коммутатор отправляет кадры через канал порта, он должен использовать какой-то алгоритм, чтобы определить, по какому физическому каналу отправлять кадры. Алгоритм обеспечивает распределение трафика по всем ссылкам. Теперь, чтобы обеспечить доставку кадров по порядку и не вызывать увеличения джиттера и т. Д., Общепринято помещать все кадры от одного отправителя или между одной парой отправитель / получатель по одному и тому же каналу.

Поскольку все кадры между отправителем и получателем всегда будут находиться на одном и том же канале 1 ГБ, максимальная пропускная способность составляет всего 1 ГБ.

Обычные старые каналы портов могут использоваться между большинством коммутаторов Ethernet, и многие драйверы сетевых адаптеров серверов поддерживают LACP, а также обеспечивают канал порта между сервером и его вышестоящим коммутатором. Обратите внимание, что с обычными каналами портов каждая физическая ссылка, составляющая один конец канала порта, должна заканчиваться на одном и том же коммутаторе. Вы не можете, например, иметь канал порта от сервера к двум вышестоящим коммутаторам. Существует тип канала порта, который поддерживает это, называемый Multi-Chassis Etherchannel (MEC) или Multi-Chassis Link Aggregation Group (MLAG).Когда в сети используется такая технология, как Cisco Stackwise или Virtual Switching System (VSS), можно сформировать MEC между одним устройством (например, сервером) и двумя отдельными вышестоящими коммутаторами, если коммутаторы участвуют в тот же стек Stackwise или VSS.

Канал виртуального порта⌗

Виртуальный канал порта (vPC) - это расширение MEC, которое обеспечивает такую ​​же функциональность - создание канала порта между двумя коммутаторами - без необходимости использования Stackwise или VSS.

Как Stackwise, так и VSS выходят далеко за рамки просто каналов портов: они фактически объединяют плоскости контроля и управления коммутаторов-членов, эффективно превращая их в одну логическую единицу. Это звучит не так уж плохо, если учесть, что вы перешли от (2) точек касания до (1), но в то же время может быть некоторый повышенный риск. В частности, теперь у вас есть единственный экземпляр процессов вашего протокола управления (STP, OSPF, BGP, DTP, LACP и т. Д.), Запущенных на (логическом) коммутаторе. Ошибка программного обеспечения или ошибка протокола приведет к сбою протокола во всем стеке / VSS.Далее, поскольку плоскость управления также объединена, это означает, что существует один общий файл конфигурации. Толстый палец строки конфигурации или отказ управления изменениями может иметь серьезные последствия, поскольку он повлияет на оба физических коммутатора в стеке / VSS.

Теперь, сказав все это, это действительно подчеркивает преимущества vPC: уровни контроля и управления остаются отдельными! Это действительно лучшее из обоих слов. Вы можете построить канал портов между шасси, не рискуя объединить плоскость контроля и управления.

Обратите внимание на специальные ссылки, соединяющие два коммутатора-члена vPC вместе. Они используются для передачи данных управления, конфигурации и поддержки активности между ними. Как показано, поскольку vPC использует LACP для сигнализации (он также может не использовать сигнализацию и просто настраивается вручную), канал виртуального порта может подключаться к обычным коммутаторам Ethernet, а также к серверам, которые поддерживают каналы обычных портов.

vPC в настоящее время доступен (по состоянию на июль 2015 г.):

  • Nexus 7700 и 7000
  • Коммутаторы серий Nexus 5000, 5500 и 5600
  • Коммутаторы серии
  • Nexus 9500 и 9300, работающие в автономном режиме NX-OS
    • Ознакомьтесь с примечаниями к выпуску программного обеспечения на коммутаторах Nexus 9k на предмет предупреждений или ограничений в отношении vPC.Не думайте, что vPC на 9k имеет паритет функций с vPC на 7k или 5k.

Существует серьезное ограничение топологии с vPC при использовании Fabric Extender (FEX) серии Nexus 2000 в сочетании с 5 × 00: вы не можете настроить двухуровневый vPC, как показано на схеме ниже.

«Двухуровневый» - это ссылка на vPC, настроенный между 5500 и FEX, а затем от FEX до конечного устройства. С vPC вы должны делать то или другое.Тем не менее, если вы прочитаете раздел EvPC ниже, вы увидите, что есть способ успешно запустить эту топологию.

Virtual Port Channel Plus⌗

Если vPC был усовершенствованием MEC, vPC +, естественно, является усовершенствованием vPC.

vPC + используется в домене FabricPath, где канал виртуального порта настроен от коммутаторов-членов структуры к какому-либо устройству без структуры, например серверу или так называемому «классическому» коммутатору Ethernet (CE). vPC + позволяет устройству без фабрики подключаться к двум коммутаторам фабрики для обеспечения избыточности и многопутевости, а также позволяет загружать трафик , сбалансированный , совместно используемый на выходе фабрики к устройству без фабрики.

На рисунке показано физическое и логическое представление соединения vPC +. Физически коммутатор CE подключен к двум независимым коммутаторам FabricPath. Эти два коммутатора находятся в домене vPC. Магия vPC + заключается в том, что коммутаторы-участники логически создают виртуальный коммутатор (SwitchID 4), который находится между ними и коммутатором CE. Этот логический коммутатор объявляется остальной части сети FabricPath как граничный коммутатор, к которому подключен коммутатор CE.Это ключ к включению балансировки нагрузки трафика, исходящего от фабрики к коммутатору CE. В приведенном выше примере сети, чтобы достичь коммутатора CE, коммутатор 1 будет адресовать свои кадры FabricPath коммутатору 4, для которого он имеет (2) пути с равной стоимостью. Если логическая топология отражает физическую топологию, коммутатор 1 должен будет адресовать свои кадры либо коммутатору 2, либо коммутатору 3 (но не обоим, потому что таблица пересылки FabricPath может содержать только один идентификатор коммутатора для данного пункта назначения), что не приведет к Балансировка нагрузки.

Расширенный канал виртуального порта⌗

Еще один спин на vPC! Хорошо, это устраняет ограничение, описанное в разделе vPC выше, когда у вас не может быть двухуровневого vPC между Nexus 5500 и FEX, а также между FEX и конечным устройством. EvPC допускает именно такую ​​топологию. Кроме того, EvPC также поддерживает разделение SAN A / B даже при наличии полной сети подключений.

Между Nexus 5500 и FEX трафик хранилища FCoE поддерживает этот традиционный «воздушный зазор» между сторонами A и B и никогда не пересекает общий сетевой элемент.Это достигается за счет явной конфигурации на 5500, которая указывает левому FEX отправлять трафик FCoE только на левый 5500, а правый FEX - только на правый 5500. Обычный трафик Ethernet может проходить по любому из каналов в любом месте топологии.

Причина разницы между vPC и EvPC заключается в ограничениях платформы Nexus 5000 (т.е. 5010 и 5020), которые не позволяют ей поддерживать EvPC. Платформа Nexus 5500 поддерживает EvPC и не требует какой-либо конкретной модели FEX для работы.

Обновление от 23 июля 2015 г. : Nexus 5600 также поддерживает EvPC.

Список литературы⌗


Заявление об ограничении ответственности : Мнения и информация, выраженные в этой статье блога, являются моими собственными и не обязательно принадлежат Cisco Systems.

Почему «Link Aggregation / Port-Channel» не может достичь теоретического значения баланса нагрузки? - Справочный центр Edgecore

Сценарий приложения Port Trunking

Предисловие

Люди часто спрашивают, почему я не могу достичь теоретического значения передачи после включения балансировки нагрузки «Link Aggregation / Port-Channel»? Даже пакетный трафик всегда отправлялся на порт A?

Мы должны знать: баланс нагрузки канала порта основан на «механизме хеширования» для выбора порта для передачи пакета.

Поддерживаемые модели

Серия ECS4620, серия ECS4510, серия ECS4120, серия ECS4100, серия ECS5520, серия ECS4530, серия ECS2100, серия ECS2110, серия ECS3510

Допустимые хеш-значения для балансировки нагрузки Edgecore:

Распределение dst-ip на IP-адрес назначения

Распределение dst-mac на MAC-адрес назначения

src-dst-ip распределение по IP-адресу источника и назначения (SIP XOR DIP)

Распределение src-dst-mac по MAC-адресу источника и назначения (SA XOR DA)

Распределение src-ip на исходном IP-адресе

Распределение src-mac на исходном MAC-адресе

Значение хеш-функции по умолчанию

src-dst-mac

CLI

Настроить баланс нагрузки в режиме src-dst-mac:

 Console # config 

Console (config) # баланс нагрузки порт-канал?

dst-ip Выбор на основе IP-адреса назначения

dst-mac Выбор на основе MAC-адреса назначения

src-dst-ip Выбор на основе IP-адреса источника и назначения

src-dst-mac Выбор на основе источника и назначения MAC-адрес

src-ip Выбор на основе IP-адреса источника

src-mac Выбор на основе MAC-адреса источника

Console (config) # port-channel load-balance src-dst-mac

Console (config) #exit

Показать тип переключателя балансировки нагрузки:

 Console # show port-channel load-balance 

Trunk Load Balance Mode: Source and destination MAC address

.

Практическое руководство

Это общее приложение, клиент загружает файл с сервера, мы используем TestCenter для моделирования эксперимента через балансировку нагрузки канала-порта «src-dst-mac» и «src-mac» , а затем сравниваем различия.

Порт TestCenter 4/4

  • Имитация файлового сервера A и B.

Порт TestCenter 4/3

  1. Тестовая конфигурация по умолчанию «src-dst-mac»
  • Пакетный поток сконцентрирован в одном порту, результат балансировки нагрузки не оправдал ожиданий. (TX: 200 Мбит / с; RX: 100 Мбит / с)

  1. Измените конфигурацию балансировки нагрузки на «src-mac»
  • Пакетный поток распределяется по двум портам, появляется балансировка нагрузки.(TX: 200 Мбит / с; RX: 200 Мбит / с)

Заключение

Баланс нагрузки пакетов зависит от конфигурации микросхемы, три бита (LSB) используются для индексации таблицы соединительных линий для выбора одного из портов.

Критерии SIP и DIP используются для пакетов IPv4, для других пакетов выбор возвращается к критериям, основанным на эквивалентном MAC-адресе.

Обычный способ балансировки нагрузки - «src-dst-mac», поэтому, чтобы проверить, работает ли балансировка нагрузки, у вас должен быть хороший SA или DA для XOR.

Конечно, в нормальном состоянии у нас не будет постоянной ситуации с MAC-адресами, кроме случаев отгрузки всей партии. Если балансировка нагрузки не работает, вы можете попробовать другой хэш, чтобы улучшить результат, как в эксперименте выше.

Соответствующие знания

Как настроить агрегацию каналов на коммутаторе Edgecore?

Конфигурация канала порта Cisco Nexus 9k - шаг за шагом

Конфигурация канала порта Cisco Nexus 9k - шаг за шагом

Платформа: https: // стойки.uninets.com

Название лаборатории: Nexus 9k NXOSv

Задача

  • Удалите предыдущую конфигурацию на коммутаторах NXOS01, NXOS02, NXOS03 и NXOS04 с помощью команды «запись и стирание» и перезагрузите оба коммутатора, назначьте имя хоста одинаковым именем хоста для обоих коммутаторов. При необходимости использовать резервные документы
  • Настройте каналы портов между NXOS01, NXOS02, NXOS03 и NXOS04 следующим образом:
    • Связи между NXOS03 и NXOS01 должны быть сгруппированы вместе в Port-Channel 1.Не используйте протокол согласования для этого канала.
    • Связи между NXOS01 и NXOS02 должны быть сгруппированы в порты-каналы 2. Оба коммутатора должны инициировать согласование LACP и использовать быстрые таймеры LACP.
    • Соединения между NXOS04 и NXOS02 должны сгруппироваться в порт-канал 4. NXOS02 должен инициировать согласование LACP, а NXOS04 должен ответить.
    • Отключить все другие соединения между переключателями.
  • Настройте все эти каналы портов как 802.Магистральные каналы 1 квартал. Создайте VLAN 10 на всех коммутаторах.
  • Настройте NXOS02 с приоритетом LACP 16384, чтобы это устройство было предпочтительным для управления согласованием каналов портов.
  • Настройте все коммутаторы для использования исходных и целевых портов TCP / UDP для потоков балансировки нагрузки между участниками канала порта.
  • Настройте связь NXOS03 с Win Server и связь NXOS04 с ПО в VLAN 10.
  • Win Server должен использовать IP-адрес 10.0.0.1/24, а ПО должно использовать IP-адрес 10.0.0.2 / 24. По завершении Win Server и SW должны иметь IP-доступность друг к другу.
  • Продолжайте сохранять свою конфигурацию, используя команду «copy run start».

Конфигурация

NXOS03:

NXOS03:

!
функция lacp
!
vlan 10
!
балансировка нагрузки канала-порта src-dst l4port
!
Интерфейс Ethernet1 / 1-32
выключение
!
интерфейс Ethernet1 / 3-4
switchport
switchport mode trunk
channel-group 1
no shutdown
!
интерфейс порт-канал1
соединительная линия режима коммутатора
без выключения
!
интерфейс Ethernet1 / 7
switchport
switchport access vlan 10
без выключения
!

NXOS04:

NXOS04:

!
функция lacp
!
vlan 10
!
балансировка нагрузки канала-порта src-dst l4port
!
Интерфейс Ethernet1 / 1-32
выключение
!
интерфейс Ethernet1 / 3-4
switchport
switchport mode trunk
группа каналов 4 пассивный режим
без отключения
!
интерфейс порт-канал4
соединительная линия в режиме коммутационного порта
без выключения
!
интерфейс Ethernet1 / 8
switchport
switchport access vlan 10
без выключения
!

NXOS01:

NXOS01:

!
функция lacp
!
vlan 10
!
балансировка нагрузки канала-порта src-dst l4port
!
Интерфейс Ethernet1 / 1-32
выключение
!
интерфейс Ethernet1 / 3-4
switchport
switchport mode trunk
channel-group 1
no shutdown
!
интерфейс порт-канал1
канал коммутатора режима порта
!
интерфейс Ethernet1 / 1-2
lacp rate быстро
switchport
switchport mode trunk
канал-группа 2 активен режим
без выключения
!
интерфейс порт-канал2
канал коммутации
!

NXOS02:

NXOS02:

!
функция lacp
!
vlan 10
!
системный приоритет lacp 16384
!
балансировка нагрузки канала порта src-dst l4port
!
Интерфейс Ethernet1 / 1-32
выключение
интерфейс Ethernet1 / 3-4
соединительная линия в режиме коммутационного порта
активен режим группы каналов 1
без выключения
!
интерфейс порт-канал1
switchport
switchport mode trunk
!
интерфейс Ethernet1 / 1-2
lacp rate быстро
switchport
switchport mode trunk
канал-группа 2 активен режим
без выключения
!
интерфейс порт-канал2
коммутатор
канал коммутатора
!

SW:

SW:

!
имя хоста SW
!
Интерфейс Eth0 / 1
без порта коммутатора
IP-адрес 10.0.0.2 255.255.255.0
без выключения
!

Проверка

Каналы портов в NX-OS, как и в Catalyst IOS и других платформах, требуют, чтобы интерфейсы-участники сначала имели совместимые параметры для формирования канала. В NX-OS эти параметры можно проверить с помощью команды show port-channel compatibility-parameters. Некоторые из этих параметров можно увидеть ниже:

Проверка: NXOS01

NXOS01 # показать параметры-порт-канал совместимости | include \ *
* режим порта
* скорость
* MTU
* MEDIUM
* Span mode
* интервал загрузки
* порт Voice VLAN

Примечание: - В топологиях (не связанных с нашей топологией) присутствуют модули как серии M, так и серии F, поскольку эти модули имеют разные возможности уровня портов, они несовместимы для совместного использования каналов.Если вы попытаетесь сформировать каналы портов на этих несовместимых модулях, синтаксический анализатор NX-OS обнаружит это и вернет сообщение об ошибке, если вы попытаетесь объединить каналы несовместимых типов, как показано ниже:

% ETH_PORT_CHANNEL-3-COMPAT_CHECK_FAILURE: режим скорости несовместим

Ошибка команды

: порт несовместим [режим скорости]

После того, как каналы успешно сформированы, итоговые выходные данные show port-channel должны указывать, что ссылки-участники находятся в состоянии «Up in the port-channel» с флагом (P).Эти выходные данные также показывают, использовалось ли согласование LACP или нет.

NXOS01 # показать сводку порт-канал

NXOS01 # показать сводку порт-канал
Флаги: D - Вниз P - Вверх в канале порта (участники)
I - Индивидуальный H - Горячее резервирование (только LACP)
с - Приостановлено r - Модуль удален
b - Ожидание сеанса BFD
S - Коммутируемый R - Маршрутизированный
U - Вверх (порт-канал)
p - Вверх в режиме задержки-lacp (член)
M - Не используется. Мин-ссылки не соблюдены
—————————————————————————–
Тип порта группы Порты-участники протокола
Канал
—————— ————————————————————–
1 Po1 (SU) Eth НЕТ Eth2 / 3 (P) Eth2 / 4 (P)
2 Po2 (SU) Eth LACP Eth2 / 1 (P) Eth2 / 2 (P)

NXOS02 # показать сводку порт-канал

NXOS02 # показать сводку порт-канал
Флаги: D - Вниз P - Вверх в канале порта (участники)
I - Отдельный H - Горячее резервирование (только LACP)
с - Приостановлено r - Модуль удален
b - Ожидание сеанса BFD
S - Коммутируемый R - Маршрутизированный
U - Вверх (порт-канал)
p - Вверх в режиме задержки-lacp (член)
M - Не используется.Мин-ссылки не соблюдаются
—————————————————————————–
Тип порта группы Порты-участники протокола
Канал
—————— ————————————————————–
1 Po1 (SU) Eth LACP Eth2 / 3 (P) Eth2 / 4 (P)
2 Po2 (SU) Eth LACP Eth2 / 1 (P) Eth2 / 2 (P)

NXOS03 # показать сводку порт-канал

NXOS03 # показать сводку порт-канал
Флаги: D - Вниз P - Вверх в канале порта (участники)
I - Отдельный H - Горячее резервирование (только LACP)
с - Приостановлено r - Модуль удален
b - Ожидание сеанса BFD
S - Коммутируемый R - Маршрутизированный
U - Вверх (порт-канал)
p - Вверх в режиме задержки-lacp (член)
M - Не используется.Мин-ссылки не выполнены
—————————————————————————–
Тип порта группы Порты-участники протокола
Канал
—————— ————————————————————–
1 Po1 (SU) Eth НЕТ Eth2 / 3 (P) Eth2 / 4 (P)

NXOS04 # показать сводку порт-канал

NXOS04 # показать сводку порт-канал
Флаги: D - Вниз P - Вверх в канале порта (участники)
I - Отдельный H - Горячее резервирование (только LACP)
с - Приостановлено r - Модуль удален
b - Ожидание сеанса BFD
S - Коммутируется R - Маршрутизировано
U - Вверх (порт-канал)
p - Вверх в режиме задержки-задержки (член)
M - Не используется.Мин-ссылки не соблюдаются
—————————————————————————–
Тип порта группы Порты-участники протокола
Канал
—————— ————————————————————–
4 Po4 (SU) Eth LACP Eth2 / 3 (P) Eth2 / 4 (P)

Протокол связующего дерева

должен рассматривать каналы порта как одну логическую ссылку, как показано ниже. На отдельные каналы, указывающие в одном направлении в связующем дереве, такие как каналы портов 1 и 2 ниже, по-прежнему распространяются обычные правила пересылки и блокировки.

NXOS01 # show spanning-tree vlan 10

NXOS01 # show spanning-tree vlan 10
VLAN0010
Протокол с включенным связующим деревом rstp
Приоритет идентификатора корня 32778
Адрес 5000.0001.0007
Этот мост является корнем
Hello Time 2 sec Max Age 20 с Задержка пересылки 15 с
Приоритет идентификатора моста 32778 (приоритет 32768 sys-id-ext 10)
Адрес 5000.0001.0007
Время приветствия 2 с Макс. Возраст 20 с Задержка пересылки 15 с
Интерфейс Роль Sts Стоимость Приоритет.Nbr Тип
—————- —- - —————– ——————————–
Po1 Desg FWD 3 128.4096 P2p
Po2 Desg FWD 3 128.4097 P2p

LACP-соседи NXOS01 и NXOS02 должны увидеть, что их системный приоритет (первая часть системного идентификатора) был снижен до более предпочтительного значения 16384. Выходные данные ниже также показывают, использует ли сосед LACP в активном или пассивном режиме. и используются ли медленные или быстрые приветствия LACP.

NXOS01 # показать интерфейс соседа lacp Po2

NXOS01 # показать интерфейс соседа lacp Po2
Флаги: S - Устройство отправляет медленные LACPDU F - Устройство отправляет быстрые LACPDU
A - Устройство находится в активном режиме P - Устройство находится в пассивном режиме
port-channel2 соседи
Информация о партнере
Партнер Партнер Партнер
Порт ID системы Номер порта Флаги возраста
Eth2 / 1 16384, 50-0-0-2-0-7 0x101 811 FA
Партнер Партнер LACP Партнер Партнер
Приоритет порта Операционный ключ Порт Состояние
32768 0x1 0x3f
Информация о партнере
Партнер Партнер Партнер
Порт ID системы Номер порта Флаги возраста
Eth2 / 2 16384,50-0-0-2-0-7 0x102 812 FA
Партнер LACP Партнер Партнер
Приоритет порта Состояние порта рабочего ключа
32768 0x1 0x3f

Чтобы проверить настроенный метод балансировки нагрузки коммутаторов, используйте команду show port-channel load-balance, как показано ниже.

Обратите внимание, что на Nexus метод балансировки нагрузки может быть изменен только в VDC по умолчанию, так как это изменение распространяется на все шасси между всеми VDC.

NXOS03 # show port-channel load-balance

NXOS03 # show port-channel load-balance
System config:
Non-IP: src-dst mac
IP: src-dst l4port rotate 0
Port Channel Load-Balancing Configuration для всех модулей:
Модуль 1:
Non-IP: src-dst mac
IP: src-dst l4port rotate 0

NXOS01 # show port-channel load-balance

NXOS01 # show port-channel load-balance
System config:
Non-IP: src-dst mac
IP: src-dst l4port rotate 0
Port Channel Load-Balancing Configuration для всех модулей:
Модуль 1:
Non-IP: src-dst mac
IP: src-dst l4port rot

Настройте IP-адрес на Win Server.Сервер Win и ПО должны иметь доступность друг к другу по IP

Чтобы пройти обучение под руководством инструктора, посетите: https://www.uninets.com/data-center/nexus/

Проблемы с портами, vPC и связующим деревом

На прошлой неделе я разговаривал с двумя разными клиентами о проблемах с их портами-каналами, виртуальными ПК и протоколом связующего дерева. Первый заказчик думал, что у него проблема с протоколом STP между его N7K и N5K, но на самом деле у него была проблема с дизайном VPC.У второго покупателя также была такая же проблема с дизайном, но он не знал об этом, пока я не указал ему на это. Поскольку мне показалось интересным, что у обоих возникла одна и та же проблема, я подумал, что напишу резюме.

Сломанная конструкция
Сломанная конструкция выглядит как на следующей диаграмме:

Одинаковый набор VLAN поддерживается на обоих каналах порта. Вы видите проблему?

Оба клиента хотели иметь большую пропускную способность между парами N7K и N5K.Однако их сеть не пересылала трафик по всем ссылкам. Команда show spanning-tree vlan 10 должна помочь проиллюстрировать проблему:

 N7K1 # ш диапазон влан 10

VLAN0010
 Протокол с включенным связующим деревом rstp
 Приоритет корневого идентификатора 32778
 Адрес 0005.73ba.8abc
 Стоимость 1
 Порт 4109 (порт-канал14)
 Время приветствия 2 секунды Максимальный возраст 20 секунд Задержка пересылки 15 секунд

 Приоритет идентификатора моста 32778 (приоритет 32768 sys-id-ext 10)
 Адрес 0026.980a.8d42
 Время приветствия 2 секунды Максимальный возраст 20 секунд Задержка пересылки 15 секунд

Роль интерфейса Приоритетная стоимость.Nbr Тип
---------------- ---- --- --------- -------- ---------- ----------------------
Po1 Desg FWD 1 128.4096 (одноранговая связь vPC) Сеть P2p
Po11 Корень FWD 1 128.4109 (vPC) P2p
Po12 Altn BLK 1 128.4110 (vPC) P2p
. . .
N7K1



N7K2 # sh span vlan 10

VLAN0010
 Протокол с включенным связующим деревом rstp
 Приоритет корневого идентификатора 32778
 Адрес 0005.73ba.8abc
 Стоимость 2
 Порт 4096 (порт-канал1)
 Время приветствия 2 секунды Максимальный возраст 20 секунд Задержка пересылки 15 секунд

 Приоритет идентификатора моста 32778 (приоритет 32768 sys-id-ext 10)
 Адрес f866.f210.8ea2
 Время приветствия 2 секунды Максимальный возраст 20 секунд Задержка пересылки 15 секунд

Интерфейс Роль Sts Стоимость Приоритетный номер Тип
---------------- ---- --- --------- -------- ---------- ----------------------
Po1 Root FWD 1 128.4096 (одноранговая связь vPC) Сеть P2p
Po11 Корень FWD 1 128.4109 (vPC) P2p
Po12 Altn BLK 1 128.4110 (vPC) P2p
. . .
N7K2 #



N5K1 # sh span vlan 10

VLAN0010
 Протокол с включенным связующим деревом rstp
 Приоритет корневого идентификатора 32778
 Адрес 0005.73ba.8abc
 Этот мост - корень
 Время приветствия 2 секунды Максимальный возраст 20 секунд Задержка пересылки 15 секунд

 Приоритет идентификатора моста 32778 (приоритет 32768 sys-id-ext 10)
 Адрес 0005.73ba.8abc
 Время приветствия 2 секунды Максимальный возраст 20 секунд Задержка пересылки 15 секунд

Интерфейс Роль Sts Стоимость Приоритетный номер Тип
---------------- ---- --- --------- -------- ---------- ----------------------
Po10 Desg FWD 1 128.4096 (одноранговая связь vPC) Сеть P2p
Po11 Desg FWD 1 128.4109 P2p
. . .
N5K1 #



N5K2 # показать span vlan 10

VLAN0010
 Протокол с включенным связующим деревом rstp
 Приоритет корневого идентификатора 32778
 Адрес 0005.73ba.8abc
 Стоимость 1
 Порт 4096 (порт-канал1)
 Время приветствия 2 секунды Максимальный возраст 20 секунд Задержка пересылки 15 секунд

 Приоритет идентификатора моста 32778 (приоритет 32768 sys-id-ext 10)
 Адрес 0005.73bc.de3a
 Время приветствия 2 секунды Максимальный возраст 20 секунд Задержка пересылки 15 секунд

Роль интерфейса Приоритетная стоимость.Nbr Тип
---------------- ---- --- --------- -------- ---------- ----------------------
Po10 Корневой FWD 1 128.4096 (одноранговая связь vPC) Сеть P2p
Po12 Desg FWD 1 128.4110 P2p
. . .
N5K2 #
 

Логическое представление
Таким образом, проблема заключается в том, что два канала порта между уровнями N7K и N5K создают петлю уровня 2, а протокол STP соответствующим образом блокирует один набор интерфейсов от пересылки трафика.

Обратите внимание, что замена портов-каналов на N5K на vPC на N5K НЕ решит проблему - если у вас одинаковые VLAN на обоих vPC, у вас все равно будет блокировка на VLAN.

Рекомендуемый дизайн
Что нужно сделать обоим клиентам, так это объединить все каналы между двумя парами Nexus в один большой vPC. С этими небольшими изменениями в конструкции все ссылки будут пересылаться между устройствами:

vPC и операции с портами и каналами
Я предлагаю некоторые наблюдения из моих тестов миграции vPC и port-каналов на устройствах Nexus на тот случай, если вам когда-нибудь понадобится перенести портовые каналы на vPC в производственной сети:

  • Когда один интерфейс настроен как порт-канал, интерфейс сбрасывается.(Я заметил потерю 4 пакетов при длительном тесте ping по ссылке, а в файле журнала показано, что интерфейс отключен в течение 5 секунд.)
  • Когда интерфейс добавляется к рабочему порту-каналу, он сбрасывается, но порт-канал и существующие интерфейсы не сбрасываются.
  • Когда порт-канал перенастраивается как vPC, порт-канал и его интерфейс сбрасываются. Это разрушительно, даже когда я пытался свести к минимуму влияние, я видел потерю 7 пакетов в своих тестах. (Я настроил вторичный коммутатор в паре vPC с интерфейсом выключения на членском порте, поместил его в vPC, а затем настроил первичный коммутатор.Первичный выключатель вышел из строя. Я вернулся к вторичному переключателю, не закрывая интерфейс, и увидел, что вторичный переключатель сработал за 7 секунд. В моем тесте первичный переключатель сработал через 15 секунд после того, как он изначально вышел из строя.)
  • Если vPC не настроены на обоих одноранговых узлах, сети VLAN на канале порта приостанавливаются. Когда я удалил порт-канал из вторичного коммутатора, а затем снова применил его, физический порт на первичном коммутаторе vPC никогда не выходил из строя, но когда VLAN были приостановлены, устройства теряли связь.
  • Когда ссылка однорангового члена добавляется к существующему vPC (например, включение правой ссылки, когда левая ссылка активна), левая ссылка остается в рабочем состоянии.


Минимизация времени простоя
У моих клиентов еще не было возможности запланировать период обслуживания для исправления своих проектов. В зависимости от того, какой порт-канал заблокирован, они могут выполнять несколько разный порядок шагов по переходу на параллельный vPC. В любом случае им потребуется создать новый vPC на обоих N5K и переместить порты в новый vPC на N5K2.Им также придется переместить порты из vPC 12 в vPC11 на N7K.

- крутящий момент

_____________________________________________________________________________________________

Если вам нужна дополнительная информация о vPC, вам могут быть полезны следующие ссылки:

nxos_portchannel - Управляет интерфейсами порт-канал - Документация Ansible

Параметр Выбор / значения по умолчанию Комментарии
сила

-

При значении истина заставляет участников порта-канала соответствовать тому, что объявлено в параметре members.Это можно использовать для удаления участников.

группа

- / требуется

Номер группы каналов для порта-канала.

участника

-

Список интерфейсов, которыми будет управлять данный портканал.

min_links

-

Минимум ссылок, необходимых для поддержания канала порта в рабочем состоянии.

режим

-

    Выбор:
  • активный
  • пассив
  • по
По умолчанию:

«да»

Режим для порта-канала, т.е.е. на, активный, пассивный.

провайдер

толковый словарь

Устарело

Начиная с Ansible 2.5 мы рекомендуем использовать соединение : network_cli .

Эта опция требуется, только если вы используете NX-API.

Объект dict, содержащий сведения о соединении.

auth_pass

нить

добавлен в 2.5,3

Задает пароль, который будет использоваться при необходимости входа в привилегированный режим на удаленном устройстве. Если авторизовать ложно, то этот аргумент ничего не делает.Если значение не указано в задаче, вместо него будет использоваться значение переменной окружения ANSIBLE_NET_AUTH_PASS .

авторизовать

логический

добавлено в 2.5.3

Дает команду модулю перейти в привилегированный режим на удаленном устройстве перед отправкой любых команд.Если не указан, устройство попытается выполнить все команды в непривилегированном режиме. Если значение не указано в задаче, вместо него будет использоваться значение переменной окружения ANSIBLE_NET_AUTHORIZE .

хост

нить / требуется

Задает имя хоста DNS или адрес для подключения к удаленному устройству через указанный транспорт.Значение host используется как адрес назначения для транспорта.

пароль

нить

Задает пароль для аутентификации подключения к удаленному устройству.Это общий аргумент, используемый для транспорта cli или nxapi . Если значение не указано в задаче, вместо него будет использоваться значение переменной окружения ANSIBLE_NET_PASSWORD .

порт

целое число

По умолчанию:

«0 (использовать общий порт)»

Задает порт для использования при создании подключения к удаленному устройству.Это значение применяется либо к cli , либо к nxapi . Значение порта по умолчанию будет соответствовать соответствующему общему транспортному порту, если в задаче не указан ни один из них. (cli = 22, http = 80, https = 443).

ssh_keyfile

нить

Задает ключ SSH, используемый для аутентификации подключения к удаленному устройству.Этот аргумент используется только для транспорта cli . Если значение не указано в задаче, вместо него будет использоваться значение переменной окружения ANSIBLE_NET_SSH_KEYFILE .

тайм-аут

целое число

добавлен в 2.3

По умолчанию:

10

Задает тайм-аут в секундах для связи с сетевым устройством для подключения или отправки команд.Если тайм-аут будет превышен до завершения операции, модуль выдаст ошибку. NX-API может медленно возвращать долго выполняющиеся команды (sh mac, sh bgp и т. Д.).

транспорт

нить / требуется

Настраивает транспортное соединение для использования при подключении к удаленному устройству.Аргумент транспорта поддерживает подключение к устройству через cli (ssh) или nxapi.

use_proxy

логический

добавлено в 2.5

Если не , переменные среды http_proxy и https_proxy будут проигнорированы.

use_ssl

логический

Настраивает транспорт для использования SSL, если установлено значение да , только если транспорт = nxapi , в противном случае это значение игнорируется.

имя пользователя

нить

Настраивает имя пользователя, которое будет использоваться для аутентификации соединения с удаленным устройством.Это значение используется для аутентификации входа в CLI или аутентификации nxapi в зависимости от того, какой транспорт используется. Если значение не указано в задаче, вместо него будет использоваться значение переменной среды ANSIBLE_NET_USERNAME .

validate_certs

логический

Если не , сертификаты SSL не будут проверены.Это должно использоваться только на лично контролируемых сайтах, использующих самозаверяющие сертификаты. Если транспортный аргумент не nxapi, это значение игнорируется.

состояние

-

    Выбор:
  • присутствует

  • отсутствует

Управляет состоянием ресурса.

Конфигурация режима LACP (Cisco) - Grandmetric

Технология: Коммутация
Область: Агрегация каналов
Производитель: Cisco
Программное обеспечение: 12.X, 15.X
Платформа: Платформы Catalyst

Link Aggregation Control Protocol IEEE 802.3ad (LACP) - это открытый стандарт агрегации каналов Ethernet.LACP позволяет коммутаторам Cisco управлять каналами Ethernet между коммутаторами, которые соответствуют протоколу 802.3ad. Вы можете настроить максимум 16 портов для формирования канала в зависимости от версии IOS и платформы. Восемь портов находятся в активном режиме, а остальные восемь - в режиме горячего резервирования. Есть несколько режимов LACP: «активный», «пассивный» и «включен».

Во-первых, для настройки логического интерфейса etherchannel:

Switch # configure terminal
Switch (config) #interface port-channel 5
Затем вам нужно назначить физические порты и указать режим LACP.

Активный режим LACP:

Режим LACP, который переводит порт в активное состояние согласования, в котором порт инициирует согласование с другими портами, отправляя пакеты LACP.

Чтобы настроить порт как активный режим LACP:

switch # configure terminal
switch (config) # interface fastethernet 0/1
switch (config-if) # channel-group 5 mode active

Чтобы проверить, объединены ли порты:

Switch # показать канал Ethernet сводка nel

Режим LACP Пассивный:

Режим LACP, который переводит порт в состояние пассивного согласования, в котором порт отвечает на пакеты LACP, которые он получает, но не инициирует согласование LACP.

Чтобы настроить порт как активный режим LACP:

коммутатор # настройка терминала
коммутатор (конфигурация) # интерфейс fastethernet 0/1
коммутатор (config-if) # группа каналов 5 режим пассивный

Чтобы проверить, объединены ли порты:

Switch # показать канал Ethernet сводка nel

Режим LACP Вкл .:

Все статические каналы EtherChannels, то есть порт не выполняет обмен сообщениями LACP, а выполняет статическое связывание.В этом режиме переключатель или другой конечный переключатель не распознает проблемы с эфирным каналом и не сообщит о проблеме.

коммутатор # настройка терминала
коммутатор (конфигурация) # интерфейс fastethernet 0/1
коммутатор (config-if) # режим группы каналов 5 на

Чтобы проверить, объединены ли порты:

Switch # показать канал Ethernet сводка nel

Проверьте, как настроить PAgP на коммутаторе Cisco.

Автор: Марчин Бялы

EtherChannel в компьютерной сети - GeeksforGeeks

EtherChannel - это технология агрегации каналов портов, в которой несколько каналов физических портов сгруппированы в одну логическую связь. Он используется для обеспечения высокоскоростных каналов связи и резервирования. Можно объединить максимум 8 ссылок в одну логическую ссылку.

Потребность в EtherChannel -

Вот топология, в которой два коммутатора соединены с одним ПК каждый. Канал между коммутаторами и ПК составляет 1000 МБ / с, а канал между коммутаторами - 100 МБ / с.

Теперь предположим, что если вы хотите отправить трафик со скоростью более 100 МБ / с, тогда у нас есть перегрузка, поскольку канал между коммутаторами имеет скорость только 100 МБ / с, и пакеты начнут сбрасываться. Теперь, чтобы решить эту проблему, мы должны иметь высокоскоростную связь между коммутаторами.Для этого мы можем просто заменить текущую ссылку на высокоскоростную или объединить более одной ссылки с одинаковой скоростью 100 МБ / с. Создав EtherChannel, вы можете связать более одного канала в один логический канал.


Но, когда вы подключаете коммутаторы более чем к одному каналу, STP (протокол связующего дерева) блокирует наименее избыточное соединение. Поскольку мы создали EtherChannel, все ссылки (которые сгруппированы как одна логическая ссылка k) будут обрабатываться как одна логическая ссылка, поэтому ни одна ссылка не будет заблокирована, а также обеспечит нам высокоскоростную связь и избыточность в нашей сети.

Критерии - Для формирования EtherChannel все порты должны иметь:

  1. Одинаковый дуплекс
  2. Одинаковая скорость
  3. Та же конфигурация VLAN (т.е. собственная VLAN и разрешенная VLAN должны быть одинаковыми)
  4. Режимы портов коммутатора должны быть одинаковыми (режим доступа или транка)

Протоколы EtherChannel - Для формирования EtherChannel существует 2 протокола: протокол агрегации портов (PAgP) и протокол управления агрегацией каналов (LACP).

1.Протокол агрегации портов (PAgP) -
Протокол агрегации портов - это проприетарный протокол Cisco, используемый для формирования канала EtherChannel. Есть разные режимы, в которых вы можете настроить свой интерфейс. А именно:

  1. ON: В этом режиме интерфейс будет частью EtherChannel, но согласование не происходит.
  2. Желательно: В этом режиме интерфейс будет постоянно пытаться преобразовать другой боковой интерфейс в EtherChannel.
  3. Авто: В этом режиме интерфейс станет частью EtherChannel тогда и только тогда, когда он будет запрошен противоположным интерфейсом.
  4. Не горит: На интерфейсе не настроен канал EtherChannel.

Конфигурация -

Существует небольшая топология, в которой 2 коммутатора S1 и S2 соединены друг с другом, и мы должны объединить эти два канала в один логический канал.

  S1 (config) #  интерфейс fa0 / 1
  S1 (config-if) #  желателен режим группы каналов 1
  S1 (config) #  интерфейс fa0 / 2
  S1 (config-if) #  желателен режим группы каналов 1

  S1 (config) #  интерфейс порт-канал 1
  S1 (config-if) #  инкапсуляция транка порта коммутатора dot1q
  S1 (config-if) #  соединительная линия режима switchport 

Здесь пользователь использовал желаемый режим и соединительную линию режима switchport.Режимы должны быть одинаковыми на обоих коммутаторах, поэтому пользователь может настроить это и на другом коммутаторе.


Теперь настройка на коммутаторе S2:

  S2 (config) #  interface fa0 / 1
  S2 (config-if) #  желателен режим группы каналов 1
  S2 (config) #  интерфейс fa0 / 2
  S2 (config-if) #  желателен режим группы каналов 1
  S2 (config) #  интерфейс порт-канал 1
  S2 (config-if) #  инкапсуляция транка порта коммутатора dot1q
  S2 (config-if) #  switchport mode trunk 

2.Link Aggregation Control Protocol (LACP) -
Link Aggregation Control Protocol - это протокол IEEE, первоначально определенный в 802.3ad, используемый для формирования EtherChannel. Этот протокол почти аналогичен Cisco PAgP. Есть разные режимы, в которых вы можете настроить свой интерфейс. А именно:

  1. ON: В этом режиме интерфейс будет частью EtherChannel, но согласование не происходит
  2. Active: В этом режиме интерфейс будет постоянно пытаться преобразовать другой боковой интерфейс в EtherChannel.
  3. Passive: В этом режиме интерфейс станет частью EtherChannel тогда и только тогда, когда он будет запрошен противоположным интерфейсом.
  4. Не горит: На интерфейсе не настроен канал EtherChannel.

Конфигурация -

Используя ту же топологию, вы теперь настроите LACP на обоих коммутаторах. Во-первых, настройка для S1:

  S1 (config) #  interface fa0 / 1
  S1 (config-if) #  активен режим группы каналов
  S1 (config) #  интерфейс fa0 / 2
  S1 (config-if) #  активен режим группы каналов

  S1 (config) #  интерфейс порт-канал 1
  S1 (config-if) #  инкапсуляция транка порта коммутатора dot1q
  S1 (config-if) #  switchport mode trunk 

Теперь, настройка для S2:

  S2 (config) #  interface fa0 / 1
  S2 (config-if) #  активен режим группы каналов
  S2 (config) #  интерфейс fa0 / 2
  S2 (config-if) #  активен режим группы каналов

  S2 (config) #  интерфейс порт-канал 1
  S2 (config-if) #  инкапсуляция транка порта коммутатора dot1q
  S2 (config-if) #  switchport mode trunk 

Внимание читатель! Не прекращайте учиться сейчас.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *