Network manager l2tp gnome: Network Manager L2TP плагин для NetworkManager для L2TP VPN-подключений

Содержание

Network Manager L2TP плагин для NetworkManager для L2TP VPN-подключений

В целом в настоящее время большинство дистрибутивов Linux наряду с существующей средой рабочего стола Обычно они предоставляют пользователю простой способ управления сетями подключения к Интернету. через сетевого менеджера или администратора.

Многие из это обычно довольно простоs, поскольку они показывают вам только доступные соединения (LAN и Wi-Fi), многие другие позволяют установить соединение с более продвинутыми функциями. (добавьте прокси, используйте VPN. и т. д.).

Сегодня мы поговорим об отличном надстройка для сетевого администратора под названием Network Manager L2TP.

Это плагин для сетевого менеджера Gnome (NetworkManager), этот плагин — мощный плагин VPN для управления сетью.

Обеспечивает поддержку соединений протокола туннелирования уровня 2. Это тыПодключаемый модуль для NetworkManager 1.

8 и более поздних версий, который обеспечивает поддержку соединений L2TP и L2TP / IPsec (то есть L2TP через IPsec).

Использует протокол для виртуальных частных сетей, разработанный рабочей группой IETF. как наследник протоколов PPTP и L2F, созданный для исправления недостатков этих протоколов и утверждения себя в качестве стандарта, одобренного IETF.

L2TP использует PPP для предоставления коммутируемого доступа, который может быть туннелирован через Интернет в указанную точку. L2TP определяет собственный протокол туннелирования, основанный на L2F. Транспортный протокол L2TP определен для широкого спектра типов пакетов данных, включая X.25, Frame Relay и ATM.

Как установить L2TP Network Manager на Ubuntu 14.05 LTS и Ubuntu 16.06 LTS?

Создано с помощью GIMP

Чтобы установить этот сетевой менеджер L2TP / Ipsec в версиях Ubuntu 14.04 LTS и Ubuntu 16.04 LTS, вы должны добавить этот репозиторий в свою систему.

Во-первых, мы собираемся открыть терминал с помощью Ctrl + Alt + T и выполнить в нем следующие команды

Мы добавим репозиторий с помощью следующей команды:

sudo add-apt-repository ppa:nm-l2tp/network-manager-l2tp

Сейчас Приступаем к обновлению списка пакетов и репозиториев:

sudo apt-get update

И, наконец, Приступаем к установке сетевого администратора в систему следующей командой:

sudo apt install network-manager-l2tp network-manager-l2tp-gnome

Как установить L2TP Network Manager на Ubuntu 18.

04 LTS?

В случае тех, кто является пользователями Ubuntu 18.04 LTS и хочет установить это приложение в своей системе, они должны открыть терминал в своей системе с помощью Ctrl + Alt + T, и в нем они должны выполнить следующие команды.

Приложение можно найти в официальных репозиториях Ubuntu. поэтому установку можно выполнить прямо из центра программного обеспечения Ubuntu или, если хотите, с терминала, вы можете ввести:

sudo apt install network-manager-gnome-l2tp

Если возникнут проблемы и окажется, что приложение не найдено, необходимо включить репозиторий Ubuntu «Вселенная», для этого просто введите следующую команду:

sudo add-apt-repository universe

Мы обновляем список репозиториев и пакетов с:

sudo apt update

И повторно набираем команду для установки приложения в системе:

sudo apt install network-manager-gnome-l2tp [/ исходный код]

И готово Благодаря этому они смогут использовать это дополнение для создания своего VPN-соединения в системе.

При переходе к параметрам NetworkManager> добавить VPN должны появиться параметры L2TP и PPTP.

На данный момент единственная проблема, с которой они могут столкнуться, заключается в том, что NetworkManager-l2tp запускает свой собственный экземпляр xl2tpd, и если запущена системная служба xl2tpd, его собственный экземпляр xl2tpd не сможет использовать порт UDP 1701, поэтому он будет использовать случайный высокий порт.

При остановке системной службы xl2tpd необходимо освободить UDP-порт 1701, службу xl2tpd можно остановить следующими способами:

sudo systemctl stop xl2tpd

Если остановка службы xl2tpd устраняет проблему с подключением к VPN, вы можете отключить запуск службы xl2tpd во время загрузки с помощью:

sudo systemctl disable xl2tpd

Ubuntu link L2TP VPN, автоматическая ссылка VPN

Используйте настройки VPN на основе L2TP в Ubuntu (поддержка аппаратных ключей).

1. Добавьте PPA


[url]https://launchpad. net/~seriy-pr/+archive/ubuntu/network-manager-l2tp/+build/5967945[/url]

sudo apt-add-repository ppa:seriy-pr/network-manager-l2tp


2. Обновите кеш пакетов.

sudo apt-get update

3. Установите network-manager-l2tp

sudo apt-get install network-manager-l2tp-gnome

Не забудьте после установки запустить следующую команду

sudo service xl2tpd stop

sudo update-rc.d xl2tpd disable


Перезагрузите машину

Как показано на рисунке, в новом VPN будут следующие параметры: (L2TP)

Получено с: [url] http://www.linuxidc.com/Linux/2012-10/71621.htm [/ url]

Автоматический повторный набор номера через VPN
Новый файл authVPN.sh


touch ~/authVPN.sh
И отредактируйте файл
vim ~/authVPN.sh
Содержание выглядит следующим образом

#!/bin/bash
vpnuuid=e84e6ac0-7663-4471-9919-2684566d83ef
IP=192.168.234.237
while true
do
echo `date "+%Y/%m/%d %H:%M:%S"`
ping -c 5 -q $IP > /dev/null
if [ $? -ne 0 ]; then
echo "connect vpn"
#su vpc -c "nmcli con up uuid $vpnuuid"
nmcli con up uuid $vpnuuid
else
echo "vpn already connected"
fi
echo "sleep for next check period"
sleep 10
done

Только нужно изменить vpnuuid и IP
[i] запрос vpnuuid в / etc / NetworkManager / system-connections / vpn name [/ i]
[i] IP — это адрес, который нужно посетить [/ i]
Выполнить в режиме командной строки

sudo chmod +x ~/authVPN.sh
nohup ~/authVPN.sh &

Следующий фрагмент кода также является сценарием для автоматического связывания VPN.

#!/bin/bash
user = scue # TODO: Заменить имя пользователя
vpnuuid = b8a9ec50-8bec-4d53-8c8e-0ba8db19ae50 # TODO: заменить UUID
while true
do
if [[ "$(nmcli con status|grep $vpnuuid)" == "" ]]; then
echo "Disconnected, trying to reconnect..."
sleep 1s
su $user -c "nmcli con up uuid $vpnuuid"
else
echo "Already connected !"
fi
sleep 10

не удается установить VPN-соединение с Stonesoft VPN

I’m using Ubuntu 16.04.3 LTS 64-bit I’m trying to estabilish a VPN connection to a Stonesoft VPN As far as I know stonesoft means a L2TP VPN Since Ubuntu seems no more support L2TP, I followed this instructions in order to create VPN: Xerus — missing L2TP plugin for Network-Manager?

К сожалению, я до сих пор не могу установить связь. Они дали мне только

  • IP-адрес
  • Имя пользователя
  • Пароль

В syslog я вижу следующее:

Nov 12 09:58:42 immediata NetworkManager[996]:   [1510477122.7520] audit: op="connection-activate" uuid="a944d391-ad32-4386-abed-902943385e1f" name="AreaVastaVpn" pid=2853 uid=1000 result="success"
Nov 12 09:58:42 immediata NetworkManager[996]:   [1510477122.8019] vpn-connection[0x1523200,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: Started the VPN service, PID 4275
Nov 12 09:58:42 immediata NetworkManager[996]:   [1510477122.8207] vpn-connection[0x1523200,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: Saw the service appear; activating connection
Nov 12 09:58:43 immediata gnome-session[2594]: Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Nov 12 09:59:16 immediata NetworkManager[996]:   [1510477156.8682] keyfile: update /etc/NetworkManager/system-connections/AreaVastaVpn (a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn")
Nov 12 09:59:16 immediata NetworkManager[996]:   [1510477156.8735] vpn-connection[0x1523200,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: VPN connection: (ConnectInteractive) reply received
Nov 12 09:59:16 immediata NetworkManager[996]: nm-l2tp[4275]   ipsec enable flag: yes
Nov 12 09:59:16 immediata NetworkManager[996]: ** Message: Check port 1701
Nov 12 09:59:16 immediata NetworkManager[996]: ** Message: Can't bind to port 1701
Nov 12 09:59:16 immediata NetworkManager[996]: nm-l2tp[4275]   L2TP port 1701 is busy, using ephemeral.
Nov 12 09:59:16 immediata NetworkManager[996]: nm-l2tp[4275]   starting ipsec
Nov 12 09:59:16 immediata NetworkManager[996]: Stopping strongSwan IPsec...
Nov 12 09:59:16 immediata charon: 00[DMN] signal of type SIGINT received. Shutting down
Nov 12 09:59:16 immediata ipsec[4316]: Stopping strongSwan IPsec failed: starter is not running
Nov 12 09:59:19 immediata NetworkManager[996]: Starting strongSwan 5.3.5 IPsec [starter]...
Nov 12 09:59:19 immediata NetworkManager[996]: Loading config setup
Nov 12 09:59:19 immediata NetworkManager[996]: Loading conn 'a944d391-ad32-4386-abed-902943385e1f'
Nov 12 09:59:19 immediata NetworkManager[996]: found netkey IPsec stack
Nov 12 09:59:19 immediata charon: 00[DMN] Starting IKE charon daemon (strongSwan 5.3.5, Linux 4.4.0-98-generic, x86_64)
Nov 12 09:59:19 immediata kernel: [  543.237222] audit: type=1400 audit(1510477159.053:41): apparmor="DENIED" operation="open" profile="/usr/lib/ipsec/charon" name="/usr/local/lib/libxml2.so.2.9.1" pid=4345 comm="charon" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
Nov 12 09:59:19 immediata charon: 00[CFG] disabling load-tester plugin, not configured
Nov 12 09:59:19 immediata charon: 00[LIB] plugin 'load-tester': failed to load - load_tester_plugin_create returned NULL
Nov 12 09:59:19 immediata charon: 00[CFG] dnscert plugin is disabled
Nov 12 09:59:19 immediata charon: 00[CFG] ipseckey plugin is disabled
Nov 12 09:59:19 immediata charon: 00[CFG] attr-sql plugin: database URI not set
Nov 12 09:59:19 immediata charon: 00[CFG] loading ca certificates from '/etc/ipsec.d/cacerts'
Nov 12 09:59:19 immediata charon: 00[CFG] loading aa certificates from '/etc/ipsec.d/aacerts'
Nov 12 09:59:19 immediata charon: 00[CFG] loading ocsp signer certificates from '/etc/ipsec.d/ocspcerts'
Nov 12 09:59:19 immediata charon: 00[CFG] loading attribute certificates from '/etc/ipsec.d/acerts'
Nov 12 09:59:19 immediata charon: 00[CFG] loading crls from '/etc/ipsec.d/crls'
Nov 12 09:59:19 immediata charon: 00[CFG] loading secrets from '/etc/ipsec.secrets'
Nov 12 09:59:19 immediata charon: 00[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-7a4acce7-0546-4531-a80f-5fc950241a95.secrets'
Nov 12 09:59:19 immediata charon: 00[CFG]   loaded IKE secret for %any
Nov 12 09:59:19 immediata charon: 00[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-8fa9aa57-6f5a-42cf-adf7-b84da24e632c.secrets'
Nov 12 09:59:19 immediata charon: 00[CFG]   loaded IKE secret for XX.XXX.XX.XX
Nov 12 09:59:19 immediata charon: 00[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-a944d391-ad32-4386-abed-902943385e1f.secrets'
Nov 12 09:59:19 immediata charon: 00[CFG]   loaded IKE secret for %any
Nov 12 09:59:19 immediata charon: 00[CFG] sql plugin: database URI not set
Nov 12 09:59:19 immediata charon: 00[CFG] opening triplet file /etc/ipsec.d/triplets.dat failed: No such file or directory
Nov 12 09:59:19 immediata charon: 00[CFG] eap-simaka-sql database URI missing
Nov 12 09:59:19 immediata charon: 00[CFG] loaded 0 RADIUS server configurations
Nov 12 09:59:19 immediata charon: 00[CFG] no threshold configured for systime-fix, disabled
Nov 12 09:59:19 immediata charon: 00[CFG] coupling file path unspecified
Nov 12 09:59:19 immediata charon: 00[LIB] loaded plugins: charon test-vectors unbound ldap pkcs11 aes rc2 sha1 sha2 md4 md5 rdrand random nonce x509 revocation constraints acert pubkey pkcs1 pkcs7 pkcs8 pkcs12 pgp dnskey sshkey dnscert ipseckey pem openssl gcrypt af-alg fips-prf gmp agent chapoly xcbc cmac hmac ctr ccm gcm ntru bliss curl soup mysql sqlite attr kernel-netlink resolve socket-default connmark farp stroke updown eap-identity eap-sim eap-sim-pcsc eap-aka eap-aka-3gpp2 eap-simaka-pseudonym eap-simaka-reauth eap-md5 eap-gtc eap-mschapv2 eap-dynamic eap-radius eap-tls eap-ttls eap-peap eap-tnc xauth-generic xauth-eap xauth-pam xauth-noauth tnc-tnccs tnccs-20 tnccs-11 tnccs-dynamic dhcp whitelist lookip error-notify certexpire led radattr addrblock unity
Nov 12 09:59:19 immediata charon: 00[LIB] dropped capabilities, running as uid 0, gid 0
Nov 12 09:59:19 immediata charon: 00[JOB] spawning 16 worker threads
Nov 12 09:59:19 immediata charon: 07[CFG] received stroke: add connection 'a944d391-ad32-4386-abed-902943385e1f'
Nov 12 09:59:19 immediata charon: 07[CFG] added configuration 'a944d391-ad32-4386-abed-902943385e1f'
Nov 12 09:59:20 immediata charon: 06[CFG] rereading secrets
Nov 12 09:59:20 immediata charon: 06[CFG] loading secrets from '/etc/ipsec.secrets'
Nov 12 09:59:20 immediata charon: 06[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-7a4acce7-0546-4531-a80f-5fc950241a95.secrets'
Nov 12 09:59:20 immediata charon: 06[CFG]   loaded IKE secret for %any
Nov 12 09:59:20 immediata charon: 06[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-8fa9aa57-6f5a-42cf-adf7-b84da24e632c.secrets'
Nov 12 09:59:20 immediata charon: 06[CFG]   loaded IKE secret for XX.XXX.XX.XX
Nov 12 09:59:20 immediata charon: 06[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-a944d391-ad32-4386-abed-902943385e1f.secrets'
Nov 12 09:59:20 immediata charon: 06[CFG]   loaded IKE secret for %any
Nov 12 09:59:20 immediata NetworkManager[996]: nm-l2tp[4275]   Spawned ipsec up script with PID 4370.
Nov 12 09:59:20 immediata charon: 10[CFG] received stroke: initiate 'a944d391-ad32-4386-abed-902943385e1f'
Nov 12 09:59:20 immediata charon: 11[IKE] initiating Main Mode IKE_SA a944d391-ad32-4386-abed-902943385e1f[1] to XX.XXX.XX.XX
Nov 12 09:59:20 immediata charon: 11[ENC] generating ID_PROT request 0 [ SA V V V V ]
Nov 12 09:59:20 immediata charon: 11[NET] sending packet: from XX.XXX.XX.XX[500] to XX.XXX.XX.XX[500] (248 bytes)
Nov 12 09:59:20 immediata charon: 12[NET] received packet: from XX.XXX.XX.XX[500] to XX.XXX.XX.XX[500] (102 bytes)
Nov 12 09:59:20 immediata charon: 12[ENC] parsed INFORMATIONAL_V1 request 1567910028 [ N(NO_PROP) ]
Nov 12 09:59:20 immediata charon: 12[IKE] received NO_PROPOSAL_CHOSEN error notify
Nov 12 09:59:20 immediata NetworkManager[996]: initiating Main Mode IKE_SA a944d391-ad32-4386-abed-902943385e1f[1] to XX.XXX.XX.XX
Nov 12 09:59:20 immediata NetworkManager[996]: generating ID_PROT request 0 [ SA V V V V ]
Nov 12 09:59:20 immediata NetworkManager[996]: sending packet: from XX.XXX.XX.XX[500] to XX.XXX.XX.XX[500] (248 bytes)
Nov 12 09:59:20 immediata NetworkManager[996]: received packet: from XX.XXX.XX.XX[500] to XX.XXX.XX.XX[500] (102 bytes)
Nov 12 09:59:20 immediata NetworkManager[996]: parsed INFORMATIONAL_V1 request 1567910028 [ N(NO_PROP) ]
Nov 12 09:59:20 immediata NetworkManager[996]: received NO_PROPOSAL_CHOSEN error notify
Nov 12 09:59:20 immediata NetworkManager[996]: establishing connection 'a944d391-ad32-4386-abed-902943385e1f' failed
Nov 12 09:59:20 immediata NetworkManager[996]: Stopping strongSwan IPsec...
Nov 12 09:59:20 immediata charon: 00[DMN] signal of type SIGINT received. Shutting down
Nov 12 09:59:20 immediata NetworkManager[996]: nm-l2tp[4275]   Could not establish IPsec tunnel.
Nov 12 09:59:20 immediata NetworkManager[996]: (nm-l2tp-service:4275): GLib-GIO-CRITICAL **: g_dbus_method_invocation_take_error: assertion 'error != NULL' failed
Nov 12 09:59:20 immediata NetworkManager[996]:   [1510477160.4101] vpn-connection[0x1523200,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: VPN service disappeared
Nov 12 09:59:20 immediata NetworkManager[996]:   [1510477160.4110] vpn-connection[0x1523200,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: VPN connection: failed to connect: 'Message recipient disconnected from message bus without replying'

Может ли кто-нибудь дать мне совет о том, как я могу решить проблему? Спасибо Angelo

UPDATE

Извините, что я только что видел в журнале, я опубликовал ошибку, связанную с портом 1701. Я забыл отключить службу xl2tpd. Я сделал это, и я до сих пор не могу подключиться

Это моя новая трассировка syslog

Nov 13 09:35:35 immediata NetworkManager[996]:   [1510562135.1201] audit: op="connection-activate" uuid="a944d391-ad32-4386-abed-902943385e1f" name="AreaVastaVpn" pid=2853 uid=1000 result="success"
Nov 13 09:35:35 immediata NetworkManager[996]:   [1510562135.1264] vpn-connection[0x15235c0,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: Started the VPN service, PID 8554
Nov 13 09:35:35 immediata NetworkManager[996]:   [1510562135.1374] vpn-connection[0x15235c0,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: Saw the service appear; activating connection
Nov 13 09:35:35 immediata gnome-session[2594]: Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Nov 13 09:35:44 immediata NetworkManager[996]:   [1510562144.2090] keyfile: update /etc/NetworkManager/system-connections/AreaVastaVpn (a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn")
Nov 13 09:35:44 immediata NetworkManager[996]:   [1510562144.2150] vpn-connection[0x15235c0,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: VPN connection: (ConnectInteractive) reply received
Nov 13 09:35:44 immediata NetworkManager[996]: nm-l2tp[8554]   ipsec enable flag: yes
Nov 13 09:35:44 immediata NetworkManager[996]: ** Message: Check port 1701
Nov 13 09:35:44 immediata NetworkManager[996]: nm-l2tp[8554]   starting ipsec
Nov 13 09:35:44 immediata NetworkManager[996]: Stopping strongSwan IPsec failed: starter is not running
Nov 13 09:35:46 immediata NetworkManager[996]: Starting strongSwan 5.3.5 IPsec [starter]...
Nov 13 09:35:46 immediata NetworkManager[996]: Loading config setup
Nov 13 09:35:46 immediata NetworkManager[996]: Loading conn 'a944d391-ad32-4386-abed-902943385e1f'
Nov 13 09:35:46 immediata NetworkManager[996]: found netkey IPsec stack
Nov 13 09:35:46 immediata charon: 00[DMN] Starting IKE charon daemon (strongSwan 5.3.5, Linux 4.4.0-98-generic, x86_64)
Nov 13 09:35:46 immediata kernel: [ 2727.978478] audit: type=1400 audit(1510562146.258:46): apparmor="DENIED" operation="open" profile="/usr/lib/ipsec/charon" name="/usr/local/lib/libxml2.so.2.9.1" pid=8601 comm="charon" requested_mask="r" denied_mask="r" fsuid=0 ouid=0
Nov 13 09:35:46 immediata charon: 00[CFG] disabling load-tester plugin, not configured
Nov 13 09:35:46 immediata charon: 00[LIB] plugin 'load-tester': failed to load - load_tester_plugin_create returned NULL
Nov 13 09:35:46 immediata charon: 00[CFG] dnscert plugin is disabled
Nov 13 09:35:46 immediata charon: 00[CFG] ipseckey plugin is disabled
Nov 13 09:35:46 immediata charon: 00[CFG] attr-sql plugin: database URI not set
Nov 13 09:35:46 immediata charon: 00[CFG] loading ca certificates from '/etc/ipsec.d/cacerts'
Nov 13 09:35:46 immediata charon: 00[CFG] loading aa certificates from '/etc/ipsec.d/aacerts'
Nov 13 09:35:46 immediata charon: 00[CFG] loading ocsp signer certificates from '/etc/ipsec.d/ocspcerts'
Nov 13 09:35:46 immediata charon: 00[CFG] loading attribute certificates from '/etc/ipsec.d/acerts'
Nov 13 09:35:46 immediata charon: 00[CFG] loading crls from '/etc/ipsec.d/crls'
Nov 13 09:35:46 immediata charon: 00[CFG] loading secrets from '/etc/ipsec.secrets'
Nov 13 09:35:46 immediata charon: 00[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-7a4acce7-0546-4531-a80f-5fc950241a95.secrets'
Nov 13 09:35:46 immediata charon: 00[CFG]   loaded IKE secret for %any
Nov 13 09:35:46 immediata charon: 00[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-8fa9aa57-6f5a-42cf-adf7-b84da24e632c.secrets'
Nov 13 09:35:46 immediata charon: 00[CFG]   loaded IKE secret for XX.XXX.XX.XX
Nov 13 09:35:46 immediata charon: 00[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-a944d391-ad32-4386-abed-902943385e1f.secrets'
Nov 13 09:35:46 immediata charon: 00[CFG]   loaded IKE secret for %any
Nov 13 09:35:46 immediata charon: 00[CFG] sql plugin: database URI not set
Nov 13 09:35:46 immediata charon: 00[CFG] opening triplet file /etc/ipsec.d/triplets.dat failed: No such file or directory
Nov 13 09:35:46 immediata charon: 00[CFG] eap-simaka-sql database URI missing
Nov 13 09:35:46 immediata charon: 00[CFG] loaded 0 RADIUS server configurations
Nov 13 09:35:46 immediata charon: 00[CFG] no threshold configured for systime-fix, disabled
Nov 13 09:35:46 immediata charon: 00[CFG] coupling file path unspecified
Nov 13 09:35:46 immediata charon: 00[LIB] loaded plugins: charon test-vectors unbound ldap pkcs11 aes rc2 sha1 sha2 md4 md5 rdrand random nonce x509 revocation constraints acert pubkey pkcs1 pkcs7 pkcs8 pkcs12 pgp dnskey sshkey dnscert ipseckey pem openssl gcrypt af-alg fips-prf gmp agent chapoly xcbc cmac hmac ctr ccm gcm ntru bliss curl soup mysql sqlite attr kernel-netlink resolve socket-default connmark farp stroke updown eap-identity eap-sim eap-sim-pcsc eap-aka eap-aka-3gpp2 eap-simaka-pseudonym eap-simaka-reauth eap-md5 eap-gtc eap-mschapv2 eap-dynamic eap-radius eap-tls eap-ttls eap-peap eap-tnc xauth-generic xauth-eap xauth-pam xauth-noauth tnc-tnccs tnccs-20 tnccs-11 tnccs-dynamic dhcp whitelist lookip error-notify certexpire led radattr addrblock unity
Nov 13 09:35:46 immediata charon: 00[LIB] dropped capabilities, running as uid 0, gid 0
Nov 13 09:35:46 immediata charon: 00[JOB] spawning 16 worker threads
Nov 13 09:35:46 immediata charon: 09[CFG] received stroke: add connection 'a944d391-ad32-4386-abed-902943385e1f'
Nov 13 09:35:46 immediata charon: 09[CFG] added configuration 'a944d391-ad32-4386-abed-902943385e1f'
Nov 13 09:35:47 immediata charon: 05[CFG] rereading secrets
Nov 13 09:35:47 immediata charon: 05[CFG] loading secrets from '/etc/ipsec.secrets'
Nov 13 09:35:47 immediata charon: 05[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-7a4acce7-0546-4531-a80f-5fc950241a95.secrets'
Nov 13 09:35:47 immediata charon: 05[CFG]   loaded IKE secret for %any
Nov 13 09:35:47 immediata charon: 05[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-8fa9aa57-6f5a-42cf-adf7-b84da24e632c.secrets'
Nov 13 09:35:47 immediata charon: 05[CFG]   loaded IKE secret for XX.XXX.XX.XX
Nov 13 09:35:47 immediata charon: 05[CFG] loading secrets from '/etc/ipsec.d/nm-l2tp-ipsec-a944d391-ad32-4386-abed-902943385e1f.secrets'
Nov 13 09:35:47 immediata charon: 05[CFG]   loaded IKE secret for %any
Nov 13 09:35:47 immediata NetworkManager[996]: nm-l2tp[8554]   Spawned ipsec up script with PID 8627.
Nov 13 09:35:47 immediata charon: 13[CFG] received stroke: initiate 'a944d391-ad32-4386-abed-902943385e1f'
Nov 13 09:35:47 immediata charon: 03[IKE] initiating Main Mode IKE_SA a944d391-ad32-4386-abed-902943385e1f[1] to XX.XXX.XX.XX
Nov 13 09:35:47 immediata charon: 03[ENC] generating ID_PROT request 0 [ SA V V V V ]
Nov 13 09:35:47 immediata charon: 03[NET] sending packet: from XX.XXX.XX.XX[500] to XX.XXX.XX.XX[500] (248 bytes)
Nov 13 09:35:51 immediata charon: 04[IKE] sending retransmit 1 of request message ID 0, seq 1
Nov 13 09:35:51 immediata charon: 04[NET] sending packet: from XX.XXX.XX.XX[500] to XX.XXX.XX.XX[500] (248 bytes)
Nov 13 09:35:57 immediata NetworkManager[996]: nm-l2tp[8554]   Timeout trying to establish IPsec connection
Nov 13 09:35:57 immediata NetworkManager[996]: nm-l2tp[8554]   Terminating ipsec script with PID 8627.
Nov 13 09:35:57 immediata NetworkManager[996]: Stopping strongSwan IPsec...
Nov 13 09:35:57 immediata charon: 00[DMN] signal of type SIGINT received. Shutting down
Nov 13 09:35:57 immediata charon: 00[IKE] destroying IKE_SA in state CONNECTING without notification
Nov 13 09:35:57 immediata NetworkManager[996]: initiating Main Mode IKE_SA a944d391-ad32-4386-abed-902943385e1f[1] to XX.XXX.XX.XX
Nov 13 09:35:57 immediata NetworkManager[996]: generating ID_PROT request 0 [ SA V V V V ]
Nov 13 09:35:57 immediata NetworkManager[996]: sending packet: from XX.XXX.XX.XX[500] to XX.XXX.XX.XX[500] (248 bytes)
Nov 13 09:35:57 immediata NetworkManager[996]: sending retransmit 1 of request message ID 0, seq 1
Nov 13 09:35:57 immediata NetworkManager[996]: sending packet: from XX.XXX.XX.XX[500] to XX.XXX.XX.XX[500] (248 bytes)
Nov 13 09:35:57 immediata NetworkManager[996]: destroying IKE_SA in state CONNECTING without notification
Nov 13 09:35:57 immediata NetworkManager[996]: establishing connection 'a944d391-ad32-4386-abed-902943385e1f' failed
Nov 13 09:35:57 immediata NetworkManager[996]: nm-l2tp[8554]   Could not establish IPsec tunnel.
Nov 13 09:35:57 immediata NetworkManager[996]: (nm-l2tp-service:8554): GLib-GIO-CRITICAL **: g_dbus_method_invocation_take_error: assertion 'error != NULL' failed
Nov 13 09:35:57 immediata NetworkManager[996]:   [1510562157.3575] vpn-connection[0x15235c0,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: VPN service disappeared
Nov 13 09:35:57 immediata NetworkManager[996]:   [1510562157.3587] vpn-connection[0x15235c0,a944d391-ad32-4386-abed-902943385e1f,"AreaVastaVpn",0]: VPN connection: failed to connect: 'Message recipient disconnected from message bus without replying'
Nov 13 09:36:06 immediata wpa_supplicant[1346]: wlan0: Failed to initiate sched scan

Кто-нибудь может дать мне совет?

спасибо

Angelo

ОБНОВЛЕНИЕ 2 ike-scan.sh РЕЗУЛЬТАТ

Я запускаю ike-scan.sh

Result of command sudo ./ike-scan.sh XX.XXX.XX.XX | grep SA

ike-scan grep sa

Result of command sudo ./ike-scan.sh XX.XXX.XX.XX

ike-scan no grep

Как настроить L2TP из под Ubuntu Bionic Desktop

Прочитано: 6 841

Задача: Как настроить L2TP подключение из под Ubuntu 18.04 Desktop к домашней сети где в качестве роутера используется Mikrotik RB2012UiAS-2HnD с развернутым сервисом: PPPL2TP Server.

Просто я к сожалению когда работал на Ubuntu Trusty Desktop так и не смог настроить L2TP подключение и использовал PPTP подключение. Читал что это не безопасно, но с учетом того как в меня все дома настроена я не беспокоился.

А тут я уже давным давно перешел на другой долговременный релиз UbuntuUbuntu 18.04 Desktop в качестве домашней системы. И просматривая свои заметки на этот счет на меня накинулось, что есть не завершенная часть настройки удаленного подключения, может в этой системе все сложится удачно.

И вот теперь я разбираю новую заметку которая мне понадобится, но сперва создаю стенд под Virtualbox на основной системе: Lenovo E555 Ubuntu 18.04 Desktop, где в наличии две виртуальные машины.

Одна: Mikrotik x86 (с поднятым сервисом L2TP Server поднятым по заметке с двумя интерфейсами: eth2 — смотрит в интернет (172.33.33.34), eth3 — смотрит в локальную сеть

  • Login для подключения через L2TP: l2tp_user1
  • Password для подключения через L2TP: Aa1234567
  • IPSec phrase: [email protected]

Вторая: Ubuntu 18.04 Desktop (eth2 (172.33.33.26) — смотрит в интернет))

На второй системе проделываю:

Посредством заметки где я показал, как я загружаю репозитарий Mercurial где содержится скрипт настройки системы произвожу настройку. В вашем случае он у каждого уважаемого системного администратора должен быть самолично написанным или же использовать дефолтную систему.

Если перейти в Настройки, они же «Параметры» (значок с изображением отвертки и гаечного ключа) из правого верхнего угла, затем перейти на элемент «Сеть», щелкнуть на плюсик у VPN, то можно заметить что в системе присутствует только один вид настройки удаленного подключения — это «Туннельный протокол типа точка-точка (PPTP)». Вот только мне не это нужно. Чтобы это дело исправить нужно:

[email protected]:~$ apt-cache search network-manager-l2tp

network-manager-l2tp - network management framework (L2TP plugin core)

network-manager-l2tp-gnome - network management framework (L2TP plugin GNOME GUI)

[email protected]:~$ sudo apt-get install network-manager-l2tp-gnome -y

Затем закрыть «Настройки» и заново дойти до VPN меню и нажать плюсик будет доступно новое подключение: «Layer 2 Tunneling Protocol (L2TP)» выбираю его.

Вкладка «Идентификация» окна «Добавить VPN»

  • Название: home
  • Шлюз: 172.33.33.34
  • Имя пользователя: l2tp_user1
  • Пароль: Aa1234567 (здесь же нажимаю на восклицательный знак в ромбе и выбираю «Запомнить пароль только для этого пользователя»

затем нажимаю «Настройки Ipsec»

  • Enable Ipsec tunnel to L2TP host: отмечаю галочкой
  • Pre-shared key: [email protected]
  • Phase1 Algorithms: 3des-sha1-modp1024
  • Phase2 Algorithms: 3des-sha1

и нажимаю кнопку OKДобавить (окна «Добавить VPN»), затем нужно указать пароль для разблокировки связки ключей (это пароль при использовании команды sudo для текущего пользователя, в моем случае он совпадает с паролем ([email protected]) от учетной записи ekzorchik текущей системы) и нажимаю «Разблокировать».

Вот теперь если в настроенного VPN подключения передвинуть бегунок в положение «Включено» должно произойти подключение к L2TP Server развернутому на Mikrotik. Но обычно все сразу не начинает работать как и планируется и следует углубиться в детали почему. В логах на Mikrotik наблюдаю вот такие вот сообщения:

ага, проблемы со второй фазой аутентификации, это либо то что передает Ubuntu 18.04 Desktop, либо на Mikrotik. Когда все было поправлено, то на Mikrotik станет видно активное VPN соединение:
winbox — IP&DNS:PORT — user&pass — PPP — вкладка Active Connections

Отлично, раз работает в лабораторных условиях, то будет и работать на боевых условиях.
Для справки приведу полный конфиг настроенного Mikrotik в этой заметки:
winbox — IP&DNS:PORT — user&pass — New Terminal

[[email protected]] > export
# aug/25/2018 19:41:58 by RouterOS 6.42.5
# software id = Z4W6-YUUQ
#
#
#
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip ipsec policy group
add name=ipsec_policy_group1
/ip ipsec proposal
add enc-algorithms=3des name=l2tp_proposal
/ip pool
add name=l2tp_pool ranges=192.168.199.1-192.168.199.10
add name=dhcp_pool1 ranges=10.10.10.2-10.10.10.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether2 name=dhcp1
/ppp profile
add change-tcp-mss=yes local-address=192.168.199.1 name=l2tp_profile \
remote-address=l2tp_pool use-compression=yes use-encryption=yes use-ipv6=\
no
/tool user-manager customer
set admin access=\
own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface l2tp-server server
set authentication=mschap2 enabled=yes ipsec-secret=866%sacred.77 use-ipsec=\
yes
/ip address
add address=10.10.10.1/24 interface=ether2 network=10.10.10.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=10.10.10.0/24 gateway=10.10.10.1
/ip firewall filter
add action=accept chain=input port=1701,500,4500 protocol=udp
add action=accept chain=input protocol=ipsec-esp
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1 src-address=\
192.168.199.0/24
add action=masquerade chain=srcnat src-address=10.10.10.0/24
/ip ipsec policy
set 0 proposal=l2tp_proposal
/ppp secret
add name=l2tp_user1 password=Aa1234567 profile=l2tp_profile service=l2tp
#error exporting /routing pim
#error exporting /routing rip
#error exporting /routing ripng
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
set ether2 disabled=yes display-time=5s
set <l2tp-l2tp_user1> disabled=yes display-time=5s
/tool user-manager database
set db-path=user-manager

На заметку: если настраиваете с нуля Mikrotik то можно под каждую задачу подготовить скрипт настройки, но предварительно убрав из него строки отмеченные символом комментария («#»).

Итого заметка работоспособна. С уважением автор блога Олло Александр aka ekzorchik.

16.04 — VPN-клиент L2TP / IPSec в Ubuntu 16.04 VPN-сервису не удалось запуститься

В Ubuntu 16.04 я уже выполнил пару уроков по перестройке сетевого менеджера, также установленного через apt-get install network-manager-l2tp network-manager-l2tp-gnome.

Это работало до вчерашнего дня, когда появилось случайное сообщение с надписью The VPN connection failed because the VPN service failed to start. В конфигурации нет ошибок, так как те же учетные данные VPN и хост использовались в другой Ubuntu, также 16.04 и Windows 8.1.

Глядя на /var/log/syslog:

NetworkManager[899]: <info>  [1496143714.1953] audit: op="connection-activate" uuid="cac1651d-9cbd-4989-bc57-b9707ddd012a" name="VPNCS" pid=2295 uid=1000 result="success"
NetworkManager[899]: <info>  [1496143714.1973] vpn-connection[0xa56420,cac1651d-9cbd-4989-bc57-b9707ddd012a,"VPNCS",0]: Started the VPN service, PID 5798
NetworkManager[899]: <info>  [1496143714.2013] vpn-connection[0xa56420,cac1651d-9cbd-4989-bc57-b9707ddd012a,"VPNCS",0]: Saw the service appear; activating connection
NetworkManager[899]: <info>  [1496143714.2760] vpn-connection[0xa56420,cac1651d-9cbd-4989-bc57-b9707ddd012a,"VPNCS",0]: VPN connection: (ConnectInteractive) reply received
NetworkManager[899]: nm-l2tp[5798] <info>  ipsec enable flag: yes
NetworkManager[899]: ** Message: Check port 1701
NetworkManager[899]: nm-l2tp[5798] <info>  starting ipsec
NetworkManager[899]: Stopping strongSwan IPsec...
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22167, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22168, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22169, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22170, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22171, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22172, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22173, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22174, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22175, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22176, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22177, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22178, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22179, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22180, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22181, major_opcode = 33, minor_opcode = 0
gnome-session[1843]: X protocol error:
gnome-session[1843]: <class 'Xlib.error.BadWindow'>: code = 3, resource_id = Xlib.xobject.resource.Resource(0x00e003ad), sequence_number = 22182, major_opcode = 33, minor_opcode = 0
NetworkManager[899]: Starting strongSwan 5.5.2 IPsec [starter]...
NetworkManager[899]: Loading config setup
NetworkManager[899]: Loading conn 'cac1651d-9cbd-4989-bc57-b9707ddd012a'
NetworkManager[899]: found netkey IPsec stack
charon: 00[DMN] Starting IKE charon daemon (strongSwan 5.5.2, Linux 4.4.0-78-generic, x86_64)
NetworkManager[899]: nm-l2tp[5798] <warn>  IPsec service is not ready.
NetworkManager[899]: nm-l2tp[5798] <warn>  Could not establish IPsec tunnel.
NetworkManager[899]: (nm-l2tp-service:5798): GLib-GIO-CRITICAL **: g_dbus_method_invocation_take_error: assertion 'error != NULL' failed
NetworkManager[899]: <info>  [1496143732.4905] vpn-connection[0xa56420,cac1651d-9cbd-4989-bc57-b9707ddd012a,"VPNCS",0]: VPN plugin: state changed: stopped (6)
NetworkManager[899]: <info>  [1496143732.4929] vpn-connection[0xa56420,cac1651d-9cbd-4989-bc57-b9707ddd012a,"VPNCS",0]: VPN plugin: state change reason: unknown (0)
NetworkManager[899]: <info>  [1496143732.4952] vpn-connection[0xa56420,cac1651d-9cbd-4989-bc57-b9707ddd012a,"VPNCS",0]: VPN service disappeared
NetworkManager[899]: <warn>  [1496143732.4971] vpn-connection[0xa56420,cac1651d-9cbd-4989-bc57-b9707ddd012a,"VPNCS",0]: VPN connection: failed to connect: 'Message recipient disconnected from message bus without replying'

Я уже пытался удалить пакеты network-manager-l2tp и -gnome и переустановить их, но у меня все еще остается та же ошибка.

Любое исправление?

Network Manager L2TP подключаемый модуль для NetworkManager для соединений L2TP VPN

Обычно в настоящее время большинство дистрибутивов Linux вместе с существующими средами рабочего стола Обычно они предоставляют пользователю простой способ управления сетями подключения к Интернету через сетевого менеджера или администратора.

Многие это обычно довольно простые s, так как они показывают только доступные соединения (LAN и Wi-Fi), многие другие позволяют вам установить тип соединения с более продвинутыми функциями (добавить прокси, использовать VPN.и т.д).

Сегодня мы поговорим об отличном плагине для сетевого администратора, который называется Network Manager L2TP.

Это плагин для сетевого менеджера Gnome (NetworkManager). Этот плагин представляет собой мощный плагин VPN для управления сетью.

Обеспечивает поддержку соединений протокола туннелирования уровня 2. Это U Плагин для NetworkManager 1.8 и более поздних версий, обеспечивающий поддержку соединений L2TP и L2TP/IPsec (то есть L2TP через IPsec).

Использует протокол для виртуальных частных сетей, разработанный рабочей группой IETF как прямой наследник протоколов PPTP и L2F, созданный для исправления недостатков этих протоколов и утверждения себя в качестве стандарта, утвержденного IETF.

L2TP использует PPP для обеспечения доступа по коммутируемой линии, который можно туннелировать через Интернет в указанную точку. L2TP определяет собственный протокол туннелирования, основанный на L2F. Транспорт L2TP определен для широкого спектра типов пакетов данных, включая X.25, Frame Relay и ATM.

Как установить L2TP Network Manager на Ubuntu 14.05 LTS и Ubuntu 16.06 LTS?

Создано с помощью GIMP

Чтобы установить этот сетевой менеджер L2TP / Ipsec в версиях Ubuntu 14.04 LTS и Ubuntu 16.04 LTS, вы должны добавить этот репозиторий в свою систему.

Сначала мы собираемся открыть терминал с помощью Ctrl + Alt + T и выполнить в нем следующие команды

Мы добавим репозиторий с помощью следующей команды:

 sudo add-apt-repository ppa:nm-l2tp/network-manager-l2tp 

Теперь Продолжаем обновлять список пакетов и репозиториев:

 sudo apt-получить обновление 

Y наконец Приступаем к установке сетевого администратора в системе с помощью следующей команды:

 sudo apt install network-manager-l2tp network-manager-l2tp-gnome 

Как установить L2TP Network Manager в Ubuntu 18.04 ЛТС?

Для тех, кто является пользователем Ubuntu 18.04 LTS и хочет установить это приложение в своей системе, они должны открыть терминал в своей системе с помощью Ctrl + Alt + T и выполнить в нем следующие команды.

Приложение можно найти в официальных репозиториях Ubuntu , поэтому установку можно выполнить непосредственно из программного центра Ubuntu или, если хотите, из терминала, введите:

 sudo apt установить сетевой менеджер-гном-l2tp 

В случае возникновения проблем и кажется, что приложение не найдено, необходимо включить репозиторий Ubuntu «вселенная», для этого просто введите следующую команду:

 вселенная sudo add-apt-repository 

Обновляем список репозиториев и пакетов с помощью:

 судо подходящее обновление 

И повторно набираем команду для установки приложения в систему:

sudo apt install network-manager-gnome-l2tp[/исходный код]

И готово с этим они смогут использовать это дополнение, чтобы установить свое VPN-соединение в системе.

При переходе в параметры NetworkManager > добавить VPN должны появиться параметры L2TP и PPTP.

На данный момент единственная проблема, с которой они могут столкнуться, заключается в том, что NetworkManager-l2tp запускает свой собственный экземпляр xl2tpd, и если запущена системная служба xl2tpd, его собственный экземпляр xl2tpd не сможет использовать UDP-порт 1701, поэтому он будет использовать случайный высокий порт.

При остановке системной службы xl2tpd необходимо освободить UDP-порт 1701, служба xl2tpd может быть остановлена ​​следующим образом:

 sudo systemctl остановить xl2tpd 

Если остановка службы xl2tpd устраняет проблему с VPN-подключением, вы можете отключить запуск службы xl2tpd во время загрузки с помощью:

 sudo systemctl отключить xl2tpd 

Ubuntu — Подробная информация о пакете network-manager-l2tp-gnome в бионике

Ссылки для network-manager-l2tp-gnome

Ресурсы Ubuntu:

Загрузить исходный пакет network-manager-l2tp:

Специалист по сопровождению:

Прежде чем обращаться непосредственно к специалисту по сопровождению, подумайте о том, чтобы сообщить об ошибке или задать вопрос через Launchpad.

Первоначальный сопровождающий (обычно из Debian):

Как правило, пользователям не нужно связываться с первоначальным сопровождающим.

Внешние ресурсы:

Аналогичные упаковки:

платформа управления сетью (плагин L2TP GNOME GUI)

Другие пакеты, относящиеся к network-manager-l2tp-gnome

  • отд: libc6 (>= 2.17) [arm64, ppc64el]
    Библиотека GNU C: общие библиотеки
    также виртуальный пакет, предоставленный libc6-udeb
    отд: libc6 (>= 2,4) [не arm64, ppc64el]
  • отд: библиотека libglib2.0-0 (>= 2.37.3)
    Библиотека GLib подпрограмм C
  • отд: libgtk-3-0 (>= 3.0,0)
    Библиотека графического пользовательского интерфейса GTK+
  • отд: libnm0 (>= 1.1.90)
    Клиентская библиотека на основе GObject для NetworkManager
  • отд: libnma0 (>= 1.1.90)
    библиотека для беспроводных и мобильных диалогов (версия libnm)
  • отд: libsecret-1-0 (>= 0.18)
    Секретный магазин
  • отд: сетевой менеджер-l2tp (= 1.2.8-2сборка1)
    платформа управления сетью (ядро подключаемого модуля L2TP)

Скачать network-manager-l2tp-gnome

Ubuntu — Подробная информация о пакете network-manager-l2tp в бионике

Ссылки для network-manager-l2tp

Ресурсы Ubuntu:

Загрузить исходный пакет network-manager-l2tp:

Специалист по сопровождению:

Прежде чем обращаться непосредственно к специалисту по сопровождению, подумайте о том, чтобы сообщить об ошибке или задать вопрос через Launchpad.

Первоначальный сопровождающий (обычно из Debian):

Как правило, пользователям не нужно связываться с первоначальным сопровождающим.

Внешние ресурсы:

Аналогичные упаковки:

платформа управления сетью (ядро подключаемого модуля L2TP)

Другие пакеты, относящиеся к network-manager-l2tp

  • отд: libc6 (>= 2.17) [arm64, ppc64el]
    Библиотека GNU C: общие библиотеки
    также виртуальный пакет, предоставленный libc6-udeb
    отд: libc6 (>= 2,4) [не arm64, ppc64el]
  • отд: библиотека libglib2.0-0 (>= 2.41.1)
    Библиотека GLib подпрограмм C
  • отд: libnm0 (>= 1.1.90)
    Клиентская библиотека на основе GObject для NetworkManager
  • отд: сетевой менеджер (>= 1.2.0)
    платформа управления сетью (демон и инструменты пользовательского пространства)
  • отд: ппп (
    Протокол двухточечной связи (PPP) — демон
    отд: ппп (>= 2.4.7-2+~)
  • отд: сильный лебедь
    Метапакет решения IPsec VPN
    или либрешван
    Демон обмена ключами в Интернете
  • отд: ксл2тпд
    Реализация протокола туннелирования уровня 2

Скачать сетевой менеджер-l2tp

Как настроить VPN-клиент L2TP/IPsec в Linux

L2TP (что означает Протокол туннелирования уровня 2 ) — это протокол туннелирования, предназначенный для поддержки виртуальных частных сетей (подключений VPN) через Интернет.Он реализован в большинстве, если не во всех современных операционных системах, включая Linux и устройства с поддержкой VPN.

L2TP не предоставляет каких-либо механизмов аутентификации или шифрования непосредственно для трафика, проходящего через него. Обычно это реализуется с помощью набора аутентификации IPsec ( L2TP/IPsec ) для обеспечения шифрования в туннеле L2TP .

В этой статье мы покажем, как настроить соединение L2TP/IPSec VPN в Ubuntu и его производных и Fedora Linux .

В этом руководстве предполагается, что сервер L2TP/IPsec VPN настроен и что вы получили следующие сведения о VPN-подключении от системного администратора вашей организации или компании.

 IP-адрес или имя хоста шлюза
Имя пользователя и пароль
Общий ключ (секретный)
 

Как настроить VPN-соединение L2TP в Linux

Чтобы добавить параметр L2TP/IPsec в NetworkManager, необходимо установить подключаемый модуль NetworkManager-l2tp VPN , который поддерживает NetworkManager 1.8 и выше. Он обеспечивает поддержку L2TP и L2TP/IPsec .

Чтобы установить модуль L2TP в Ubuntu и дистрибутивах Linux на основе Ubuntu, используйте следующий PPA.

 $ sudo add-apt-repository ppa:nm-l2tp/network-manager-l2tp
$ sudo apt-получить обновление
$ sudo apt-get install network-manager-l2tp network-manager-l2tp-gnome
 

В RHEL/CentOS и Fedora Linux используйте следующую команду dnf для установки модуля L2TP .

 # dnf установить xl2tpd
# dnf установить NetworkManager-l2tp
# dnf установить NetworkManager-l2tp-gnome
ИЛИ
# ням установить xl2tpd
# ням установить NetworkManager-l2tp
# yum установить NetworkManager-l2tp-gnome
 

После завершения установки пакета щелкните значок Network Manager , затем перейдите к Network Settings .

Доступ к настройкам сети

Затем добавьте новое VPN-соединение, нажав на знак (+) .

Добавить новое VPN-подключение

Затем выберите Протокол туннелирования уровня 2 (L2TP) во всплывающем окне.

Выберите Layer 2 Tunneling Protocol

. Затем введите данные VPN-подключения (IP-адрес шлюза или имя хоста, имя пользователя и пароль), которые вы получили от системного администратора, в следующем окне.

Добавить сведения о VPN

Затем нажмите Параметры IPsec , чтобы ввести общий ключ для подключения. Затем включите туннель IPsec на хост L2TP , введите (или скопируйте и вставьте) общий ключ и нажмите «ОК».

Добавить общий ключ

После этого нажмите Добавить . Теперь ваше новое VPN-подключение должно быть добавлено.

VPN-подключение создано

Затем включите VPN-подключение, чтобы начать его использовать. Если сведения о соединении верны, соединение должно быть установлено успешно.

Enable VPN ConnectionEnabled VPN Connection

И последнее, но не менее важное: проверьте, нормально ли работает VPN. Вы можете проверить общедоступный IP-адрес вашего компьютера, чтобы подтвердить это в веб-браузере: теперь он должен указывать на IP-адрес шлюза.

Подтвердите ваше VPN-подключение

На этом статья заканчивается. Если у вас есть какие-либо вопросы или мысли, чтобы поделиться, свяжитесь с нами через форму обратной связи ниже.

Если вы цените то, что мы делаем здесь, в TecMint, вам следует подумать:

TecMint — это самый быстрорастущий и пользующийся наибольшим доверием сайт сообщества, где можно найти любые статьи, руководства и книги по Linux в Интернете. Миллионы людей посещают TecMint! искать или просматривать тысячи опубликованных статей, доступных всем БЕСПЛАТНО.

Если вам нравится то, что вы читаете, пожалуйста, купите нам кофе (или 2) в знак признательности.

Мы благодарны за вашу бесконечную поддержку.

Как удалить network-manager-l2tp-gnome в Kali Linux 2017.1

Чтобы удалить network-manager-l2tp-gnome, просто следуйте этим инструкциям.

Удалите только network-manager-l2tp-gnome

http://installion.co.uk/kali/kali/main/n/network-manager-l2tp-gnome/uninstall/index.htmlинфраструктуру управления сетью (плагин L2TP GNOME GUI ) и подключения, пытаясь поддерживать активное сетевое подключение, когда оно доступно.Он управляет устройствами Ethernet, WiFi, мобильного широкополосного доступа (WWAN) и PPPoE, а также обеспечивает интеграцию VPN с различными VPN-сервисами.

Это удалит только сам пакет network-manager-l2tp-gnome.

Удалить network-manager-l2tp-gnome и его зависимости

 sudo apt-get remove --auto-remove network-manager-l2tp-gnome 

Это удалит пакет network-manager-l2tp-gnome и все другие зависимые пакеты, которые больше не нужны.

Очистка вашей конфигурации/данных тоже

Если вы также хотите удалить локальные файлы/файлы конфигурации для network-manager-l2tp-gnome, это сработает.

  Внимание! Очищенная конфигурация/данные не могут быть восстановлены путем переустановки пакета. пакет Данные

Пакет network-manager-l2tp-gnome
Версия 1.2.6-2
5
Обслуживание
Обслуживание Douglas Kosovic <[Email Protected]>
Главная страница https://github.com/nm-l2tp/network-manager-l2tp
Описание структура управления сетью (плагин L2TP GNOME GUI) и соединения, пытаясь поддерживать активное сетевое соединение, когда оно доступно. Он управляет устройствами Ethernet, WiFi, мобильного широкополосного доступа (WWAN) и PPPoE, а также обеспечивает интеграцию VPN с различными VPN-сервисами.
Distro kalilinux
выпуска kalilinux
Repo Основной
Раздел нетто

Зависимости

Как установить или удалить сетевой менеджер-L2TP -gnome в Ubuntu 20.04 LTS (Focal Fossa)?

1. Установите пакет

network-manager-l2tp-gnome .

Пожалуйста, следуйте приведенным ниже инструкциям, чтобы установить пакет network-manager-l2tp-gnome :

  судо подходящее обновление  
  sudo apt установить сетевой менеджер-l2tp-gnome  

2.Удалите / удалите пакет

network-manager-l2tp-gnome .

Пожалуйста, следуйте приведенным ниже инструкциям, чтобы удалить пакет network-manager-l2tp-gnome :

  sudo apt удалить сетевой менеджер-l2tp-gnome  
  sudo apt autoclean && sudo apt autoremove  

3.Полная информация о пакете

network-manager-l2tp-gnome .

 Пакет: network-manager-l2tp-gnome 
Архитектура: amd64
Версия: 1.2.16-1
Приоритет: необязательный
Раздел: Universe/net
Источник: network-manager-l2tp
Происхождение: Ubuntu
Сопровождающий: Ubuntu Developers
Исходный сопровождающий: Дуглас Косович
Ошибки: https://bugs.launchpad.net/ubuntu/+filebug
Установленный размер: 258
Зависит: libc6 (>= 2.14), libglib2.0-0 (>= 2.37.3), libgtk-3-0 (>= 3.3.16), libnm0 (>= 1.1.90), libnma0 (>= 1.1.90), libsecret-1 -0 (>= 0,18), network-manager-l2tp (= 1.2.16-1)
Имя файла: pool/universe/n/network-manager-l2tp/network-manager-l2tp-gnome_1.2.16-1_amd64.deb
Размер: 28820
MD5sum: a95209b7de67eae479fc5a2842252c70
SHA1: 80b9e59e8418d8a28373a9178fd647b62865355e
SHA256: 17432e7636869c337d46060e56ba3bf86af52bf02790fbb0a1e8fab87936d758
Домашняя страница: https://github.com/nm-l2tp/NetworkManager-l2tp
Описание-ен: система управления сетью (L2TP плагин GNOME GUI)
NetworkManager является системная сетевая служба, которая управляет вашими сетевыми устройствами
и подключениями, пытаясь поддерживать активное сетевое подключение, когда
доступно.Он управляет устройствами Ethernet, WiFi, мобильного широкополосного доступа (WWAN) и PPPoE
, а также обеспечивает интеграцию VPN с различными службами VPN
.
.
Этот пакет предоставляет биты GNOME подключаемого модуля NetworkManager L2TP.
Описание-md5: b3e18299e9ea1d8f9ee1a13a3b4ebd1a